Device manager error code 43 on Fujitsu SATA disk RRS feed

  • Question

  • I have an Acer Aspire 8920G which initially had only a Western Digital SATA disk (WDC WD3200BEVT-22ZCT0, firmware 11.01A11). I added a 2nd SATA disk (Fujitsu MJA2320BH G2, firmware revision 00000018). Initially this seemed to work fine, but after a reboot the 2nd disk dispappeared from Vista Home Premium SP2 '6002.18005.x86fre.lh_sp2rtm.090410-1830' although it was present in the BIOS. Doing a repair and system restore got it back.

    Subsequently, it disappeared again, still showing in the BIOS. This time a repair did not get it back, although powering down, removing it, booting and shutting down then putting it back in did.

    More reboots have shown that if it's a straight reboot the disk is likely to disappear, however if a disk check is scheduled or something gets installed/updated during startup, the disk will be detected properly.

    Further investigation showed that the device manager had marked the drive 'hidden' with a message that it had been stopped as the driver had reported a failure (code 43). The advice was to check the hardware manual. Since it's a SATA disk with no settable jumpers, there is no hardware manual (supposedly, you install it, it works!).

    I have since checked that the Intel Matrix Storage Console consistently reports it as running OK irrespective of whether Vista has stopped it or not; it's connected to an Intel ICH8M SATA AHCI Controller (WD disk on port 0, Fujitsu on port 1, port 2 unused).

    I have also run the Fujitsu HDD Diagnostic Tool (both the short and long tests) and this reports no problem with the drive.

    I'm fairly certain that there is actually no hardware problem (unless it's a timing issue) and that this is either a registry corruption or a software driver issue. Both drives are using the standard Microsoft drivers, disk.sys and partmgr.sys '6.06002.18005 (lh_sp2rtm.090410-1830)'.

    So how can I fix this problem, preferably so it doesn't recur?



    Tuesday, September 1, 2009 1:15 PM