locked
BUG - Login keyboard layout Windows 2012 R2 RRS feed

  • General discussion

  • When installing Windows 2012 R2 core bare metal, the keyboard layout picked during installation will not be respected for the system account (used when logging in to the server or setting the password for the first time). This is not an issue on non-core installations

    I created 4 core servers and set the keyboard layout on all to UK during the installation phase.

    As soon as the installation finishes, I am asked to set the administrator password. On the bottom right hand corner, I am able to pick the keyboard layout (US and UK available, US selected by default).

    After setting the password and logging in as local administrator, the keyboard layout is set to UK on the administrator profile.

    Opening the registry and looking at HKU\.DEFAULT\Keyboard Layout\Preload shows 2 values under it:

    Name - Value

    1 - 00000409

    2 - 00000809

    Looking at HKU\.DEFAULT\Control Panel\International\User Profile shows:

    Name - Value

    Languages - en-US en-GB

    Performing either a restart, or locking the workstation, causes the second keyboard layout to disappear (no more button to change keyboard layout on bottom right hand corner) and the keyboard layout is now US.

    After unlocking/logging in and looking at the registry again, a few things have changed:

    HKU\.DEFAULT\Keyboard Layout\Preload now only has:

    Name  - Value

    - 00000409

    HKU\.DEFAULT\Control Panel\International\User Profile only shows:

    Languages - en-US

    Subsequent restarts do not change anything nor changing the value of HKU\.DEFAULT\Keyboard Layout\Preload\1 to 00000809 (the system will reset it back to 00000409 after a restart).

    This issue only affects core versions of Windows 2012 R2 (have not tested Windows 2012 non-R2 version, but can confirm non-Core versions of Windows 2012 R2 are not affected).

    Is this something that is known and has a fix?


    • Edited by JohnUbuntu Friday, April 4, 2014 3:06 PM
    • Changed type AnnaWY Tuesday, April 22, 2014 1:11 AM
    Friday, April 4, 2014 3:05 PM

All replies

  • Hi John,

    Thanks for your efforts, and I also find a relevant issue with you here:

    Change default input language on Windows 2012 R2 Core

    I will log this and report to related department.

    Have a good day.

    Monday, April 7, 2014 3:57 PM
  • Also worth pointing out that other regional settings are also not applied. Perhaps not as important but could cause some bugs in applications.

    Things like the time being in US format, the decimal symbol etc etc, which cannot be fixed by the link provided by AnnaWY.

    Sunday, May 4, 2014 7:23 AM
  • I have the exact same issue, did you find a workaround for this issue?

    I'm running mine in Hyper-V from a Win10, the gui one is working (although the login screen keep changing to US), but the core is US on both login screen, and after login.

    I selected Norwegian (bokmål) during installation. I can change it to that at the login screen, but it changes back to US after login.

    Tried changing registry, by removing US, and only having Norwegian, but dosent work, and after a restart everything is back.

    Thursday, July 28, 2016 6:15 PM