none
Can not copy: The file exists. (Explorer View)

    Question

  • Hello Community,

     

                I used to copy bunch of files from windows explorer to sharepoint 2007 document library in its explorer view. But now I could not. It gives me error "Can not copy xyz: The file exists". The files does not exists already.

                I also created many different new files [Different Name/Different File Type] and copy to server but still no luck. I have logged in to SharePoint with Admin Account and verified that no such file already exists.

                I have the many machines and using Windows XP and Windows 7. For Windows 7 I never found the problem and Windows XP [with IE 6] if I use normal user for windows logon [Normal user have the “Full Control” permission in SP] I cannot use drag and drop files. It shows the error message “Cannot copy file <filename> The file exists”. For “My Network Places” I created and point to document libraries such as http://serversite/Docs [“Docs” It’s a document libraries list] but no luck. I tried from multiple Windows XP workstations and It works in few but cannot make out any differences between these machines.

                    Any  help is highly appreciated. Thank you in your advance.

    Thanks and Regards,

           Aitsara K.

    Tuesday, August 31, 2010 8:06 AM

Answers

  • Hi,

     

    Can you open files in the document library with the explorer view?

     

    Are you sure you have used the same user account when you use the Windows XP?

     

    Please have a check whether you have got the Web Client service started,

    if not, start it and try accessing again.

     

    PS: You can also try to use STSADM to add documents to SP 2007.

     

    Hope it helps!

    Monday, September 6, 2010 9:05 AM
  • I have a Sharepoint 3.0 site at work.

    I have 2 workstations BOTH with XP Pro and IE. 

    One I have had for more that a year, and the second one is to replace my first, but I am comparing the two before retiring the first.

    The both workstations can open Sharepoint "Shared Documents" location, and under the Actions menu, i can choose "Open with Windows Explorer".

    PC#1 (old) has IE7,

    would open the sharepoint folders in Explorer and I can copy, paste, create new files, everything as I expected.

    I even turned on Version Control in Sharepoint and it still works, maintaining file version history.

    I even mapped a drive letter V: to point to the sharepoint location:

    \\share.sample.com\sharepoint\tech\collab\Shared Documents\TechStuff

    Everything works great!!!!!!!!!!!!! (on the old PC#1)

     

    I get brand new PC#2, same OS.  First thing I did is install IE8,

    but when I connect to Sharepoint, and opend the explorer view expecting the same behavior,

    the Explorer window would open, but I could NOT create or copy files from the folders due to a "Access Denied" message.

    (No changes to Sharepoint, only a new PC client).

    I uninstall IE8 and install IE7 same version as old PC#1,

    open folders in Explorer view and this time I do NOT get he Access Denied, I get the "The file exists" error message.

    Try to create a new file: Cannot create file: The file exists. 

    Try to copy a file from the sharepoint explorer view, I get: "Can not copy ___: The file exists" 

    I open up PC#1 and it can still map and copy and create files as before.

    The browser DOES seem to affect it, since IE8 was "access denied", and IE7 is now "file exists"

    I have verified the web client service is running on both PCs, the "Local Service" user settings had 'Authenticated User' listed in the security tab like I saw on PC#1, etc...

    I even stopped the Web Client Service and tried Explorer view, all that happpened was it used FPRPC and  the folders had the flat icons, but same "File Exists" message, so I restarted the Web Client Service.

    The problem is NOT sharepoint, since it still works with PC#1,

    where else do I look in PC#2 that could affect this behavior? 

    Friday, September 10, 2010 6:44 PM

All replies

  • Hi  Aitsara K,

    Thanks to share your problem.

    Will suggest you to check below points

    1. What are the file names? Make sure that there are no special symbols i.e.

    !~@#$%^&*()<>{}\/?    etc.

    2. Go to Central Administration and check if There is any file extension / type blocked

    3. Do you have versioning switched on ?

    4. Have you tried "Open with windows explorer" from "Actions" menu.

    Let me know your answer


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Tuesday, August 31, 2010 10:42 AM
    Moderator

  • Hi Hemendra,

                Thank you for your recommended. For your questions please see my answers belows:

                1. What are the file names? Make sure that there are no special symbols i.e.

                !~@#$%^&*()<>{}\/?    etc.

               ---- I'm using normal text without special symbols for file names.

                2. Go to Central Administration and check if There is any file extension / type blocked
               ---- I using the same type (normal .doc .xls .txt etc.) with Windows XP and Windows 7. For the results In Windows 7 can drag and drop file but In some Windows XP cannot.

                3. Do you have versioning switched on ?
               ---- No

                4. Have you tried "Open with windows explorer" from "Actions" menu.
               ---- Yes, I tried in 3 ways (Explorer View , Open with Windows Explorer and create my the network places).


    Additional Information :
        I have tried in many machines using Windows XP and Windows 7. I found this problem in 90% of machines with Windows XP and ie 6.

    Tuesday, August 31, 2010 11:09 AM
  • OK, This may be your IE version problem. Please have a look into below url's

    http://collaborationnation.blogspot.com/2008/05/sharepoint-explorer-view-problem-for-ie.html

    http://support.microsoft.com/kb/923906

    Let me know if it works


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Tuesday, August 31, 2010 11:16 AM
    Moderator
  • Also check Document Library Settings > Checked Out Files

    Make sure you do not have a file with the same name currently checked out.


    Planet Technologies || SharePoint Task Force
    Tuesday, August 31, 2010 10:42 PM
  • Hi Hemendra,

                     Thank you for your suggestions but the KB link that you provided is for a url lenght issue and our site url is within the limits.

                     Any other thougths ????

    Hi Roland,

                     Thank you for your inputs but I have verifed that this is not the situation. Anythings else to check ??? :(...

     

     

    Wednesday, September 1, 2010 1:10 PM
  •  

                  I installed Internet Explorer version 7 in problem machine, and tried the same operation again... but to my disbelief, the problem still exists! even with IE 7 (in same windows XP)!!!

    But atleast this tells me it does not have anything to do with IE version...

    Any further thoughts??

    Thursday, September 2, 2010 3:32 AM
  • OK, have you tried this

    http://support.microsoft.com/kb/841215/


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Thursday, September 2, 2010 4:11 AM
    Moderator
  • Hi Hemendra,

                  I have already done for this solution but the problem still exists. Thank you for your support. Any recommend?

    Thursday, September 2, 2010 5:03 AM
  •  

    Hello Community,

                   I am still waiting for a new solution. Any ideas? Thank you in advance.

    Aitsara K.

    Friday, September 3, 2010 9:02 AM
  • Hi,

     

    Can you open files in the document library with the explorer view?

     

    Are you sure you have used the same user account when you use the Windows XP?

     

    Please have a check whether you have got the Web Client service started,

    if not, start it and try accessing again.

     

    PS: You can also try to use STSADM to add documents to SP 2007.

     

    Hope it helps!

    Monday, September 6, 2010 9:05 AM
  • Hi,

    Please try simple way to upload.

    go to "Upload Multiple Documents" and select "Overwrite existing files" and click OK. and before doing this please check whether your uploaded existing files are checked -out or not? if existing files are checked-out then please discard all check-out.


    thanksArup MCTS - SharePoint
    Monday, September 6, 2010 1:37 PM
  • I have a Sharepoint 3.0 site at work.

    I have 2 workstations BOTH with XP Pro and IE. 

    One I have had for more that a year, and the second one is to replace my first, but I am comparing the two before retiring the first.

    The both workstations can open Sharepoint "Shared Documents" location, and under the Actions menu, i can choose "Open with Windows Explorer".

    PC#1 (old) has IE7,

    would open the sharepoint folders in Explorer and I can copy, paste, create new files, everything as I expected.

    I even turned on Version Control in Sharepoint and it still works, maintaining file version history.

    I even mapped a drive letter V: to point to the sharepoint location:

    \\share.sample.com\sharepoint\tech\collab\Shared Documents\TechStuff

    Everything works great!!!!!!!!!!!!! (on the old PC#1)

     

    I get brand new PC#2, same OS.  First thing I did is install IE8,

    but when I connect to Sharepoint, and opend the explorer view expecting the same behavior,

    the Explorer window would open, but I could NOT create or copy files from the folders due to a "Access Denied" message.

    (No changes to Sharepoint, only a new PC client).

    I uninstall IE8 and install IE7 same version as old PC#1,

    open folders in Explorer view and this time I do NOT get he Access Denied, I get the "The file exists" error message.

    Try to create a new file: Cannot create file: The file exists. 

    Try to copy a file from the sharepoint explorer view, I get: "Can not copy ___: The file exists" 

    I open up PC#1 and it can still map and copy and create files as before.

    The browser DOES seem to affect it, since IE8 was "access denied", and IE7 is now "file exists"

    I have verified the web client service is running on both PCs, the "Local Service" user settings had 'Authenticated User' listed in the security tab like I saw on PC#1, etc...

    I even stopped the Web Client Service and tried Explorer view, all that happpened was it used FPRPC and  the folders had the flat icons, but same "File Exists" message, so I restarted the Web Client Service.

    The problem is NOT sharepoint, since it still works with PC#1,

    where else do I look in PC#2 that could affect this behavior? 

    Friday, September 10, 2010 6:44 PM
  • SOLVED!

    My corporate help desk guy figured it out.

    He said remove my install of IE7 and let the help desk push the company version, and let them also push a "Corporate SetRights" package.

    1) I uninstalled the existing IE7 (and the 3 security updates listed under it in Add Remove programs list)

    2) they remotely pushed the SAME version of IE7 to PC#2 when I looked in the Add remove programs list, it had IE7 but no security updates. 

    3) I then called back after reboot for the Corp Setrights package to be pushed.

    I opened IE7 before I hung up on the help desk guy, and everything was working. (it seemed before he even started the Corp SetRights push)

    My guess is Internet Explorer 7.0.5730.13 with no additional security updates is the solution,

    Since nothing else changed.  (unless he pushed the setrights so fast, it took effect before he hung up)

    GREAT!!!

    PC#2 now works and has the same functionality as PC#1 :)

    (I don't know what is it he CorpSetright package, but I guess I could ask, later....enjoying productivity with current setup)

    • Proposed as answer by Arup Biswas Saturday, September 11, 2010 2:08 PM
    Friday, September 10, 2010 9:21 PM
  •  

                 Thank you very much Leoyi Sun , Arup R , sxd0fr1. I will try and tell you all.

    Monday, September 13, 2010 2:26 PM
  • Hi Leoyi Sun , sxd0fr1 and Community

                      Updated result, I have to restart Web Client Service via Command at problem machine then, It worked but if I restart the machine again but still problem.

                      My workaround for now need to restart Web Client Service every time that restart machine.

                      Any other thougths ????


    Thanks and Regards,
            Aitsara K.

    Tuesday, October 5, 2010 10:24 AM
  • Hello Community,

              Solved!!! I changed log on as "Local Service" of Web Client Service to "Local System" after that, When I restart machine it's still good :)

     

    Thank you very much

            Aitsara K.

    Thursday, October 7, 2010 6:25 AM