"Add Operating System Installer Wizard" Throws Error When Adding OS's


  • Good Afternoon All - 

    Okay - I just installed SCCM 2012 in our production environment - whoo hoo!

    Going through the initial setup and configuration, I had a few errors that I had to take care of, but was able to figure out what caused them OR just uninstall / reinstall them fixed it.  I've got a new issue I can't figure out, though.

    On my SCCM 2012 Primary Site Server, I created a folder named Images and shared it to my SCCMAdmin account (full) and SCCM Admin group (full).  Inside of it, I created sub folders for each of the OS's that I want to have installers for.  For now, I am working with Windows 7 Professional SP1 x64.

    In the console (signed in as SCCMAdmin), I go to Software library, then Add Operating System Installer Wizard.  I type in the UNC path going to shared folder, then sub folder holding the ISO file and click Next.  I then get an error saying

    "The specified path does not contain a valid operating system or you do not have permission to access it.  Specify a valid path."

    Perhaps I'm doing something wrong, but here's what I've tried to fix it so far...

    - Tried pointing it to a folder with the ISO's contents extracted as well as to the Sources folder

    Downloaded the ISO from TechNet so that I know it was fresh - nogo

    Tried adding a Windows 8 ISO I had laying around - nogo

    Checked folder share permissions as well as security ones.  I even gave Everyone full access - nogo

    Checked SCCM component and site status - green across the board.

    Any ideas? - Thanks!

    Ben K.

    Monday, June 04, 2012 8:15 PM

All replies

    1. You cant use a native ISO as source...
    2. How did you extract the ISO? Don't use WinRAR etc. mount the ISO and copy the files (I've seen error related to this)
    3. The Site Server needs access to the source share/folder. Not just the admin (the user).

    Ronni Pedersen | Microsoft MVP - ConfigMgr | Blogs: and | Twitter @ronnipedersen

    Monday, June 04, 2012 8:20 PM
  • Thanks for your reply...

    I thought I could use native ISOs.  Like I said, might be something I'm doing.  Still trying to learn all transitions from 2007.  For the extractions, I used 7Zip with default settings.  I'll add the server, itself, to the share.  Thought having it as it's own local admin would put that in automatically, but guess not.

    I'll let you know what happens - Thanks!

    Ben K.

    Monday, June 04, 2012 8:43 PM
  • 7-Zip could be the issue here... Try to mount the the ISO to a DVD drive in a virtual server, and copy the files from the virtual DVD drive.
    I know this sound stupid, but I've seen this issue a few times...

    Ronni Pedersen | Microsoft MVP - ConfigMgr | Blogs: and | Twitter @ronnipedersen

    Monday, June 04, 2012 8:49 PM
  • Sorry to bring up a relatively old post, but wanted to relay my experience with this same problem.  In my case, I knew all permissions were correct, but I received the same error message.  Turns out the problem was that I had only copied the install.wim file to my Images directory.  I then directed SCCM to the Images directory and got the error message.  The reason for the error was that SCCM is looking for the folder structure that is on the DVD, namely, the "sources" directory.  By the time I figured this out, I had already copied the entire "sources" directory to the root of my Images directory.  I moved all of these files under the Images\Sources directory and went ahead and copied the rest of the DVD to the Images directory.  After doing that, I was able to complete the wizard as expected.  Hope that helps someone to not have to waste the same 2 hours that I just did.  :)
    Wednesday, September 05, 2012 5:26 PM
  • Ronni, I have extracted the ISO and I still get the same error message.  Does the file need to be on the SCCM Server or can it be on a different server?  Do you have to select a specific file within the folder like the set up or what am I missing?



    Tuesday, November 13, 2012 3:29 PM
  • You dont need to have the source files on the site server. You can you use remote file server if you want.

    You dont just need a single file on the DVD. You need to copy ALL files from the DVD to the source folder.

    Ronni Pedersen | Microsoft MVP - ConfigMgr | Blogs: and | Twitter @ronnipedersen

    Tuesday, November 13, 2012 8:55 PM
  • Thank you... I ended up re extracting the ISO and it worked.  



    • Proposed as answer by robiul Monday, March 25, 2013 4:44 AM
    Tuesday, November 13, 2012 9:26 PM
  • It is strange issue; I had similar issue. check permission everything are OK but still no luck on adding the UNC path.

    Finally I have copied contents to local SCCM server as \\localhost\win7 and it worked [solved]


    Monday, March 25, 2013 4:46 AM
  • Hi,

    I had the same error,I solved it :

    Be sure to use ADK8.0 with SCCM 2012 (ver 6.2)

    Tuesday, December 17, 2013 7:26 PM