locked
OWA Phone Options Tab 500 Unexpected Error RRS feed

  • Question

  • Hello,

    We had a strange issue with a UM Call Answering Rule but have since removed the problem rule via EMS.  But we continue to have a problem with one mailbox when the user logs into OWA > Settings > Options > Phone > Voice Mail Tab he gets a 500 Unexpected Error Message (see Image):

    I came across an O365 thread that talks about what was fixed, but I can't seem to find where to fix this....

    "This issue was caused by the one of the value of Time of Day was converted to 0. This is an invalid value so OWA cannot display the rule."

    From forum: 

    http://community.office365.com/en-us/f/158/t/214649.aspx

    Where can I to go check/change the Time of Day value the Support Rep is referring to?  Or is there another way to fix this issue?  We had a 2010 to 2013 Migration last August (2013) and we do still have our two 2010 servers in our environment.  One was a CAS and the other was UM.

    Thank You.


    Rory Schmitz


    • Edited by RorySchmitz Wednesday, May 14, 2014 7:04 PM spelling error
    Wednesday, May 14, 2014 7:03 PM

All replies

  • Rory,

    I've had this same issue before and it was fixed by changing the Mailbox Policy for the user that has the issue, or you can do it programmatically via PowerShell.

    Using ECP, go into the user > Mailbox Features > Role Assignment Policy, and change it, or set it as Default Role Assignment Policy. Wait for AD replication and try again.

    Gonzalo

    Tuesday, September 16, 2014 7:17 PM
  • Thank you for the reply.  I have to think back on who was having this problem and make that change. I will report back with what I find. I appreciate the suggestion!

    Rory Schmitz

    Tuesday, September 16, 2014 7:30 PM
  • Hi Rory,

    Was the solution I had proposed helpful? Let me know if it worked or not.

    Thanks,

    Gonzalo

    Friday, September 19, 2014 8:24 PM
  • Hi Gonzalo,

    Unfortunately, it didn't work in my instance.  We only have one Role Assignment Policy; the Default one.  I had created a new policy and changed all of the options so they were opposite of the Default one.  I applied this to the users account, waited a couple hours and tried again.  No luck.  I then changed it back to the default policy, waited a couple of more hours then tried.  Still no luck.  This seems to be the only user account were having problems with that I've heard about.  It used to work with our 2010 Exchange environment.  We've since then decommissioned all 2010 servers and now only have two 2013 servers in a DAG.

    I appreciate the suggestion.  Any other ideas I could try?


    Rory Schmitz

    Friday, September 19, 2014 8:53 PM
  • I had the same problem.  The way I fixed it was to go into the properties of the Default Role Assignment Policy and check the box to allow "My Voicemail".

    Traci

    Thursday, October 2, 2014 7:06 PM
  • Hi Traci,

    Thanks for the suggestion.  I did look again and the option for My Voicemail is already checked.  When I created the new policy just for this one user, I toggled all of those options, then applied settings, a few times to see if it would fix it but unfortunately it did not.


    Rory Schmitz

    Thursday, October 2, 2014 8:06 PM
  • Did anyone find a working solution ? I have the exact same problem Exchange 2013 for a single user out of 15000, I tried to do repair of the mailbox as Microsoft states the information is stored in user's mailbox, well it did not fix the problem, I only have 1 default Role assignment policy and yes My Voicemail is selected
    Friday, January 20, 2017 4:12 PM
  • I never did get this working with the suggestions above.  We ended up migrating to O365 and used a Session Border Controller to talk back to our on-prem UM servers (Cisco Unity and Call Manager).  The problem does not exist in our current environment.

    Rory Schmitz

    Monday, January 23, 2017 1:53 PM