locked
install+configuration of Office Web Apps SP1 fails on install with no Port 80 webapp with "Failed to create sample data" RRS feed

  • Question

  • NOTE: I had initially posted this on the Office Web Apps forum, but the response I got there was to instead post it on a SharePoint forum, so I'm creating a copy of it here.

    OS = 2008 R2 SP1 x64 (Enterprise)

    SharePoint 2010 (14.0.6029.1000)

    Installed Office Web Apps SP1

    The SharePoint install is a little 'weird' in that there's no webapp on port 80 (the machine already has non-IIS software running on port 80), so SharePoint is on 2 sites in IIS - 'SharePoint Central Administration v4' on port 1599 and then the 'regular' webapp on port 8888.  The 8888 site is running fine and we've been using it with no problems.

     

    The install of the office web apps sp1 worked fine, but during the configuration (using the SharePoint Products Configuration Wizard), the first 6 (of 11) steps works fine, but it fails during step 7 with 'Failed to create sample data'.

     

    The full log file is a little over 5MB, so I won't paste it in here (is there some way I can share it?  File a connect but and attach it?), but the relevant snippets seem to indicate that it's somehow unable to find the port 8888 site (even though log lines just above it show that a different value of 'provisionedUrl' correctly shows the site found on port 8888).

     

    Is there anyway to 'pass in' the port as 8888 to the relevant bit (env var? cmdline param? registry key?  other?) so it correctly finds it and can proceed with configuration?

     

    06/30/2012 22:03:15  15  INF              Leaving function SharedEvaluatorModeProvisioner.Provision

    06/30/2012 22:03:15  15  INF              Provisioned uri is http://3bs001bkup:8888/

    06/30/2012 22:03:15  15  INF              Entering function Command.this[string key]

    06/30/2012 22:03:15  15  INF                Entering function CommandCollectionBase.Get

    06/30/2012 22:03:15  15  INF                  Found value in collection for key provisionedUrl

    06/30/2012 22:03:15  15  INF                Leaving function CommandCollectionBase.Get

    06/30/2012 22:03:15  15  INF                Found parameter provisionedUrl in collection

    06/30/2012 22:03:15  15  INF              Leaving function Command.this[string key]

    06/30/2012 22:03:15  15  INF              The parameter provisionedUrl is set to be chosen, and is given a value of http://3bs001bkup:8888

    06/30/2012 22:03:15  15  INF            Leaving function EvalModeProvisionTask.EvalProvision

    06/30/2012 22:03:15  15  INF            Entering function EvalModeProvisionTask.ProvisionServiceApplicationsAndProxies

    06/30/2012 22:03:15  15  INF              Entering function Command.this[string key]

    06/30/2012 22:03:15  15  INF                Entering function CommandCollectionBase.Get

    06/30/2012 22:03:15  15  INF                  Found value in collection for key port

    06/30/2012 22:03:15  15  INF                Leaving function CommandCollectionBase.Get

    06/30/2012 22:03:15  15  INF                Found parameter port in collection

    06/30/2012 22:03:15  15  INF              Leaving function Command.this[string key]

    06/30/2012 22:03:15  15  INF              The parameter port is NOT chosen, so returning the default value as 80

    06/30/2012 22:03:15  15  INF              Entering function EvalModeProvisionTask.FindWebApplicationAtPort

    06/30/2012 22:03:15  15  INF                Entering function StringResourceManager.GetResourceString

    06/30/2012 22:03:15  15  INF                  Resource id to be retrieved is WebApplicationWithSpecifiedPortNotFound for language English (United States)

    06/30/2012 22:03:15  15  INF                  Resource retrieved id WebApplicationWithSpecifiedPortNotFound is A web application with the specified port {0} was not found in the server farm.

    06/30/2012 22:03:15  15  INF                Leaving function StringResourceManager.GetResourceString

    06/30/2012 22:03:15  15  INF                Entering function Common.BuildExceptionMessage

    06/30/2012 22:03:15  15  INF                  Entering function StringResourceManager.GetResourceString

    06/30/2012 22:03:15  15  INF                    Resource id to be retrieved is ExceptionInfo for language English (United States)

    06/30/2012 22:03:15  15  INF                    Resource retrieved id ExceptionInfo is An exception of type {0} was thrown.  Additional exception information: {1}

    06/30/2012 22:03:15  15  INF                  Leaving function StringResourceManager.GetResourceString

    06/30/2012 22:03:15  15  INF                Leaving function Common.BuildExceptionMessage

     

    Thanks!

    Monday, July 2, 2012 2:52 PM

Answers

All replies

  • Hi! Try here

    MVP Office Development, MCP, MCTS SharePoint 2010 Development

    Monday, July 2, 2012 5:18 PM
  • I f the server is connected to a domain,check if you have the access to the domain controller. This is a common problem when you are installing at home where the domain controller is not available. If the server is not connected to a domain,it is necessary to include in the domain and change the service accounts to the domain accounts.You can setup DC on this server but need to change property DisableLoopBack to 1. Another solution not found ... still looking.
    Thursday, November 29, 2012 12:47 PM