none
Can't delete favorites from IE 10 - Windows 8 RRS feed

  • Question

  • Yesterday out of the blue some old pages from my favorites list reappeared.  I deleted these in the past and now they just showed up.  When I right click on them to delete them or go to organize favorites to delete them, they delete for a few seconds, but then reappear.  I try again and again, but they just keep coming back.  The "favorites bar" in my favorites list does the same thing.  I have also gone to users/profile/favorites to try and delete them and they just come back.

    I've run multiple scans with my antivirus software and spybot software, but it didn't fix it.

    Anyone know how to fix this or know what the problem could be?  I am not a tech guy, just an average joe, but can get around windows decently.

     

    Thanks for your help.

    Wednesday, September 25, 2013 6:33 PM

All replies

  • Have you tried to delete favorites in the Favorites folder? (C:\Users\User\Favorites)

    Verify that there isn't the iexplore.exe processes running in the Task Manager.

    Thursday, September 26, 2013 5:36 PM
  • Yes, I've gone into the favorites folder to delete them and they do the same thing.  They disappear for 1-2 seconds and then reappear.  There is no iexplore.exe process running in the task manager.

    This just happened out of the blue.  Some of these saved web pages are ones I deleted months ago, and a few of them are duplicates of my existing favorites web pages.

    Very weird to happen so randomly.

    Thursday, September 26, 2013 5:59 PM
  • Hi,

    It seems this copy may be recreated by malware. I suggest you to boot into a safe mode (press F8, choose safe mode) and then make a full scan with antivirus.

    Following this, please try to delete the favorites by holding Shift+ Delete. Or use the CD command (Change Directory) to navigate to the folder the file is in. Then use the DEL command (DEL) to delete the favorites.

    Wednesday, October 2, 2013 12:11 AM
    Moderator
  • I did what you asked above and the "favorites bar" folders stayed gone until I reopened IE.  Now there is roughly 40-50 of them.  If this is malware and my anti virus software won't detect it, how do I go about getting rid of it?

    Thanks for the help

    Wednesday, October 2, 2013 10:34 PM
  • Yesterday out of the blue some old pages from my favorites list reappeared.

    Try disconnecting from the Internet and seeing if your problem persists?  Otherwise check your Skydrive.  Perhaps you have copies of old Favorites synchronizing from it?  As another test you could try switching from being logged on using a Microsoft account (aka Live ID) versus using a local account.  E.g. doing that would allow you to have an Internet connection but not use the same Skydrive.  Etc.

     

    Good luck



    Robert Aldwinckle
    ---

    Thursday, October 3, 2013 1:42 PM
    Answerer
  • Robert,

    I do not use skydrive or any other MS accounts.  I do have a external HD that I use for backing up, but I haven't done it in a while.  I did disconnect from the internet to see what affect it would have.  It seemed that the favorites bar folder would stay gone while being disconnected because when I re-connected, the favorites bar folder came back.  BUT I can't be certain if it would have stayed like this because sometimes the folder won't come back until I've been surfing a while.  I will look in my external and see if I can find a favorites folder in it where I can delete things.  I also have an icloud account, but that is only used for my iTunes and my ipad, neither of which have my favorites links in them.

    This seems to be a new issue that other people are having as well as I've seen other posts about it.

    Thanks again for the help and input.

    Will

    Thursday, October 3, 2013 9:28 PM
  • Hi,

    I too, was having the same problem, deleted favourites seem to re-appear a few seconds after being deleted.

    I've come across a solution that worked for me:

    Since the latest Apple updates I've had a new program appear called iCloud. I'm running windows 8 and I find it by going top right of the screen, down to the magnifying glass, and typing 'icloud'.

    When iCloud appears you will get the option to sync either [Mail, Contacts, Calendars and Tasks], or [Bookmarks], or [Photos].

    I deselected bookmarks, and now I can delete favourites from internet explorer.

    I didn't think this would work as the favourites in Safari in my iPhone are different to those on my desktop PC. But who knows....

    Good Luck.

    • Proposed as answer by TriSail Tuesday, October 8, 2013 8:35 PM
    Saturday, October 5, 2013 1:50 PM
  • I un-installed and re-installed IE for the second time, and this time it seems to have worked.  I also copied al of my favorites from the favorites folder to a new folder on my desktop.  I then manually entered each of my favorites into the new installed IE and it seems to be working.

    Thank for the help.

    Monday, October 7, 2013 2:53 PM
  • iCloud - THANK YOU. Completely forgot I had turned it on and the reappearing Favorites was very puzzling.

    Tuesday, October 8, 2013 8:36 PM
  • IE favorites sinking with you iDevices.

    Today I too noticed favorite links that had previously been deleted reappeared. After finding list thread and reading @Paulio999 reply I did the fallowing to solve the issue, because I keep all my web browser's, computer's, and device's favorites synced.

      • Open iCloud control panel on all computer you use iCloud on.
        1. Under bookmarks-Options, un-check Internet Explorer.
        2. Click OK button
        3. Click Apply button
        4. Close  iCloud control panel
      • On one iDevice open Safari.
        1. Open Bookmarks
        2. Delete all bookmarks
        3. Select done
        4. Close Safari
      • On your Windows machine under C:\Users\-user name-\Favorites
        1. Delete all the links that are no longer wanted
      • Open iCloud control panel
      1. Under bookmarks-Options, check Internet Explorer.
      2. Click OK button
      3. Click Apply button
      4. Close  iCloud control panel

    Your favorites should now reappear on you iDevices and any changes you make from your windows machine to your IE favorites should now work correctly between your devices.

    I tested this on two Laptops, one tower, an iPhone5, and an iPad3.


    • Proposed as answer by Mr Heaton Sunday, October 13, 2013 5:35 PM
    • Edited by Mr Heaton Sunday, October 13, 2013 5:40 PM
    Sunday, October 13, 2013 5:34 PM
  • Had just done the update for I Cloud and then could not delete favorites,  Changed the I Cloud bookmark setting and I can now delete favorites on internet explorer.  Not sure yet if I bookmark something on my I Phone if it will transfer that to Internet exp as it did before.
    Sunday, October 27, 2013 10:32 PM
  • Its fixed for me now!  Thanks
    Monday, October 28, 2013 3:58 PM
  • I have been so puzzled by my reappearing favorites...

    I had forgotten all about iCloud. I guess that is what happens when something is working properly, right?

    I unchecked my bookmarks option in iCloud Control Panel and deleted the said bookmarks. Thanks a million!

    Tuesday, November 5, 2013 11:08 AM
  • iCloud was indeed the culprit to my magically reappearing favorites, as well.  Like the old saying goes:  "If you hear hoof beats, think horses (iCloud), not zebras (viruses)."

    Thanks for the reminder that it was there!


    • Edited by xEODGuy Wednesday, December 4, 2013 4:06 PM
    Wednesday, December 4, 2013 4:04 PM
  • This was a very helpful walk-thru, so thank you!
    Wednesday, December 4, 2013 4:10 PM
  • This worked like a charm! It was Icloud that was keeping my favorite list cluttered. Thank you. Took all of 10 secs to fix it once I knew where to look.
    Sunday, January 5, 2014 4:33 PM
  • Thank you, thank you, thank you.  This was driving me crazy....

    Thursday, January 16, 2014 11:56 AM
  • This worked for me on the first attempt.  I opened the iCloud control panel and unchecked Bookmarks with Internet Explorer.  When to Organize Favorites in IE and now I am able to delete the shortcuts.  I've now turned back on the iCloud Bookmarks and they are still gone.   Thanks for the solution.  
    Wednesday, February 5, 2014 12:53 PM
  • (grumbling) Stupid iCloud...
    Thursday, March 13, 2014 3:10 PM
  • Phew! Thanks for the pointer. Managed to get rid of seriously unwanted bookmarks on my work PC.
    Tuesday, May 13, 2014 3:35 PM
  • Great help! I unchecked the Bookmarks in icloud & I'm free of the "malware."
    Friday, July 25, 2014 4:48 AM
  • Thanks Paulio999 that fixed my problem. 
    Saturday, September 13, 2014 1:57 AM
  • Brilliant, thanks
    Monday, September 22, 2014 1:24 PM
  • I've had the problem for a while and this solution (i.e. stop syncing Bookmarks with iCloud) worked for me. Thanks!
    Monday, November 10, 2014 8:34 PM
  • Thank You!!!  I forgot all about ICloud.
    Friday, December 19, 2014 12:16 AM
  • This worked perfectly.  Thank you.
    Thursday, April 9, 2015 4:06 PM
  • I think the malware is OneDrive. Haven't logged into it but ever since it got downloaded I can't get rid of favourites from MS Edge. If they've been uploading without my permission they'll be getting a massive lawsuit
    Sunday, October 25, 2015 10:50 PM
  • yes. I experienced the same "crazy" behavior with reappearing favorites after deletion.  Thanks for the clue!!

    With iCloud installed, and synchronize favorites enabled, iCloud does exactly what is intended when it "helps you" by recreating the "missing" favorite from your iCloud copy.

    The multi-platform synchronization feature is convenient (when it works as intended), but this particular behavior would suggest that there is a missing operation between Windows an iCloud:  i.e., iCloud needs some method to be informed that I intentionally deleted the favorite and it should NOT be recreated from my iCloud copy.

    Saturday, January 30, 2016 1:02 PM
  • True Answer.

    Go to the favourites tab in the top left corner of your screen which should be between 'view' and 'tools'.

    Open Favourites and then open 'Organise favourites' - a box will open with your favourites in it with options at the bottom of it

    Highlight just one Favourite that you want to remove, use the delete function at the bottom right of the box, then close the Organise favourites box.

    Just repeat the process to remove any others BUT youcvan only do them one at a time

    YOU MUST CLOSE 'ORGANISE FAVOURITES' AFTER EVERY INDIVIDUAL DELETE.

    Then close internet explorer and restart computer without running any maintenance programs :-)

    Tuesday, February 9, 2016 10:38 AM
  • same you might see in Win 10.

    in IE, rename the favorite and delete it afterwards, this will help as a workaround

    Tuesday, March 1, 2016 3:50 PM
  • I had this same problem. I tried everything I could think of. Nothing worked. I also tried all the suggestions from a bunch of tech pages. The bookmarks kept reappearing in my favorites folder. Out of desperation I started looking at solutions outside of Internet Explorer and Windows. And just by chance I found the solution that worked for me. It turned out to be ICloud. I signed into my ICloud account. Then I went to settings. In settings you have choices as to what you can backup. I unselected Internet Explorer bookmarks. Saved my changes, signed out of ICloud and restarted my computer. Then went into Internet Explorer and started deleting my old bookmarks and they have not reappeared. I now have complete control of my favorites once again.
    • Proposed as answer by Maxx22 Saturday, June 4, 2016 3:04 PM
    • Unproposed as answer by Maxx22 Saturday, June 4, 2016 3:04 PM
    Thursday, May 12, 2016 5:57 AM
  • Windows 10.

    In my case, the problem was NOT ICloud which isn't even installed.

    Rather, it was syncing between my office and home computers.

    On  one computer,  go to Settings - Accounts - Sync your settings and TURN OFF internet explorer settings.  Then reboot and delete the offending favorites.

    Then do the same on the second computer.

    Should work.

    Saturday, June 4, 2016 3:09 PM
  • My case: I use a connected account (a Live/Microsoft account or whatelse is named right now).

    I've iCloud installed but not syncing anything (all options unchecked).

    Turning off OneDrive doesn't work.

    As Maxx22 says if, in Setting-Account-Sync, I turned off IE settings, it works... until turning on that feature again, and those unawanted zombies bookmarks come to life again.

    Before checking the step-by-step deletion method (a bit lazy today), I've "invented" a workaround: make a folder in bookmarks (let's say "TRASH") and move the unwanted ones to that folder.

    They are there, indeed, but you don't see them...


    Thursday, June 9, 2016 6:03 PM
  • Thank you Maxx22, your solution was the only thing that worked for me.
    Wednesday, June 15, 2016 4:02 PM
  • Thank-You Maxx22.  This also worked for me.  You are doing Microsoft's work for them.  And it is greatly appreciated.

    Monday, June 20, 2016 5:04 PM
  • I have Windows 10 and IE 11. My favorites would not permanently delete from the Favorites folder. This seem to happen only with the Favorites folder, not the sub-folders. 

    Go to Settings | Accounts | Sync Your Settings \ Turn 'off' Internet Explore settings.

    Exit IE and go back in to delete the favorites.

    • Proposed as answer by Dano_727 Tuesday, June 21, 2016 8:53 PM
    Tuesday, June 21, 2016 8:53 PM