locked
SP 2007 Migration problem RRS feed

  • Question

  • Hi all,

    I'm having a problem migrating a site from an old installation of Sharepoint to a new site on a different server. I'm trying to import all of the site content to the new site.

    I've used stsadm export and have ended up with a directory full of .dat files.

    I've created a new web application and site collection with the collaboration portal template. Now I'm trying to import my data into this site (The above may not be the way to do it, that's just what I've done).

    Now I'm using the command:
    t
    stsadm -url http://sharepoint-test:11114/ -o import -filename C:\impordata -nofilecompression

    With http://sharepoint-test:11114/ at my newly created site and C:\impordata as the directory where my .dat backup files are stored.

    However, I'm encountering the following error and have no idea how to remedy it:

    Start Time: 8/12/2013 2:59:57 PM.
    Progress: Initializing Import.
    FatalError: There is an error in XML document (0, 0).
       at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, St
    ring encodingStyle, XmlDeserializationEvents events)
       at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader)
       at Microsoft.SharePoint.Deployment.SPImport.DeserializeExportSettings()
       at Microsoft.SharePoint.Deployment.SPImport.Run()
    *** Inner exception:
    Root element is missing.
       at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
       at System.Xml.XsdValidatingReader.Read()
       at System.Xml.XmlReader.MoveToContent()
       at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReaderSPExpo
    rtSettings.Read11_ExportSettings()
    Progress: Import Completed.
    Finish Time: 8/12/2013 3:00:03 PM.
    Completed with 0 warnings.
    Completed with 1 errors.

    Any ideas? Don't have much experience with SP and google is throwing a blank.

    Thanks
    Monday, August 12, 2013 5:39 PM

All replies

  • Hi,

    When you say "migrate", are you trying to move the site from one version of SharePoint to another ?

    * If it's the case, you cannot migrate by using this method : tell us which 2 versions of SharePoint are concerned (2007, 2010, 2013 ?)

    * If not, are your 2 farms at the version version of patching ?

    Monday, August 12, 2013 7:34 PM
  • Hi, it's just a simple export really. Sorry for the confusion.

    I have 2 installations of SP2007. One on an old server and one I've just setup on new hardware. I'm just trying to move the site that's hosted on the old server to the new one. The installations are identical (Except the old one is on Server 2003 and needs to be retired).

    After this migration I plan on upgrading to 2010 in the near future. This import error is halting my progress though.


    Monday, August 12, 2013 10:54 PM
  • Did you try a stsadm backup/restore instead of export/iimport ?

    stsadm -o backup -url <URL name> -filename <file name>

    and

    stsadm -o restore -url <URL Name> -filename <file name>

    Tuesday, August 13, 2013 8:23 AM