locked
Temporary Word File in ..\INetCache\Content.Word are not trusted RRS feed

  • Question

  • Hello Community, 

    via GPO I set some Trusted Locations (also on the Network). But when I open some .docx files with macros from the trusted network location, Word creates WRCxxxx.tmp as well as some other .tmp files in the %userprofile%\AppData\Local\Microsoft\Windows\INetCache\Content.Word folder. Of course this directory is not trusted and Word shows the Notification Bar and blocks all macros. Even the original source directory is trusted. 

    Whats the best way to get word trusting these files? And how can I do it?

    My goal is, to allow documents on special network folders, without any notification bar or blocked macros, but every other directory has to be a non trusted location. 

    Thank you for your help!

    Thomas

    Tuesday, September 11, 2018 11:32 AM

Answers

  • Problem was solved Bay the newest Win10 / Office365 Update!
    • Marked as answer by Thomas Tasler Thursday, November 8, 2018 1:27 PM
    Thursday, November 8, 2018 1:27 PM

All replies

  • Hi,

    Could you tell me what information is currently displayed in the notification bar? I noticed that you are currently opening a .docx file with macros , you can view the settings of related macros in the Word Trust Center locally.

    Click File > Options > Trust Center > Trust Center Setting > Marco Settings. If you disable all macros with notification, you will see the notification bar when open files with macros.

    If you don’t want to have the notification bar, you should select “Disable all macros without notification” or “Enable all macros”(not recommended) .

    If you have any question or update, please feel free to let me know.
    Best Regards,
    Herb Gu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Microsoft Team

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams
    Wednesday, September 12, 2018 10:27 AM
  • Hello,

    Any update here? Have you solved the problem? Is my answer helpful to you?

    I'm looking forward to your response. If you have any additions, or update, please feel free to let me know.

    Best Regards,
    Herb Gu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Microsoft Team

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams
    Monday, September 17, 2018 10:24 AM
  • Hi,

    This thread has been around for a long time.Please remember to mark the replies as answers if they helped.Please help us close the thread.

    Thank you for understanding! If you have any question, or update, please feel free to let me know.
    Best Regards,
    Herb Gu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Microsoft Team

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams
    Tuesday, September 25, 2018 3:58 AM
  • Hello, 

    sorry for my late reply! I had some time off. 

    Unfortunately, your answer does not solve my problem. 
    I have set this setting to "Disable all macros with notification". 

    I try to explain the problem in detail: 

    What I want: 
    - All macros are disabled with notification, if the user opens the .docx file NOT from a trusted location.
    - All macros are enabled and no notification is shown, if the user opens the .docx file from a trusted location.

    What now happens: 
    - The user opens a .docx file or a Word template file from a trusted location
    - Word creates  and opens a WRCxxxx.tmp file in the "%userprofile%\AppData\Local\Microsoft\Windows\INetCache\Content.Word" directory- this directory is not a trusted location (imo it is a security risk to declare this directory as trusted location)-> Word opens this temporary file, which is not trusted and disables all macros
    -> But the user actually opened a .docx file form a trusted location, and expects all macros enabled and no warning.

    Is there any possibility to change this temporary directory to a custom location? 
    Do you know any other solution for this problem?

    Thanks for your help! 

    Thomas
    Friday, October 19, 2018 8:48 AM
  • Problem was solved Bay the newest Win10 / Office365 Update!
    • Marked as answer by Thomas Tasler Thursday, November 8, 2018 1:27 PM
    Thursday, November 8, 2018 1:27 PM
  • Problem was solved Bay the newest Win10 / Office365 Update!

    Hello,

    We have exactly the same issue but we have to (sadly) still working with Word 2007.I have a with GPO trusted location, works perfectly on Windows 7, but no with W10.

    We can't either enable all macros because of the involved risks.

    Thomas, would you remember which update that solved your problem? Whas it a Windows 10 update?

    Thanks for your help,

    Xisco

    Thursday, September 5, 2019 7:13 AM
  • Problem was solved Bay the newest Win10 / Office365 Update!

    Hello,

    We have exactly the same issue but we have to (sadly) still working with Word 2007.I have a with GPO trusted location, works perfectly on Windows 7, but no with W10.

    We can't either enable all macros because of the involved risks.

    Thomas, would you remember which update that solved your problem? Whas it a Windows 10 update?

    Thanks for your help,

    Xisco

    Hello, I have solved the problem with the Office 2007 SP3.

    Cheers

    Monday, September 16, 2019 7:33 AM