none
MDT 2013 - Custom Settings Per Task Sequence RRS feed

  • Question

  • I'm using MDT 2013 and WDS.  I want to be able to have custom settings based on the Task Sequence chosen.  For example, if Task Sequence ID 01 is chosen, the PC will join domain A.  If Task Sequence ID 02 is chosen, it will join domain B.  Currently my CustomSettings.ini file starts with:

    [Settings]

    Priority=TaskSequenceID, Default

    [01]

    <Stuff I want to happen during Task Sequence ID 01>

    [Default]

    <Default actions I want to occur for other tasks>

    This is being ignored unless once I choose the task during deployment I open a command prompt, rerun ZTIGather.wsf, then click Back and choose the task again.  I've tried adding ZTIGather.wsf as the first action in the task sequence, but it's not working.  What's the easiest/best way to customize actions based on the task?

    Thursday, March 3, 2016 11:24 AM

All replies

  • If you want custom settings per task, you can add them directly to the task sequence itself.

    Such as:


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, March 3, 2016 2:36 PM
  • I tried that initially, but it wasn't working.  I wound up downloading the DeployWiz_SelectTS.vbs script from here and following the steps in the article.  It seems to work now.

    • Proposed as answer by Dan_Vega Thursday, March 3, 2016 2:54 PM
    Thursday, March 3, 2016 2:39 PM
  • Interesting that it didn't work for you. At least you found the other way I was going to suggest.

    When you added it to the task sequence did you add a "Set Task Sequence Variable"?

    Either way, goal reached.


    If this post is helpful please vote it as Helpful or click Mark for answer.


    • Edited by Dan_Vega Thursday, March 3, 2016 2:54 PM forgot picture
    Thursday, March 3, 2016 2:54 PM
  • I'm pretty sure I did.  I'm running into another problem now.  I've added the OU for the Task Sequence in my TaskSequence.ini file in the format of:

    JoinDomain=my.domain

    MachineObjectOU=OU=MDT,DC=my,DC=domain

    But when I click Next after entering the computer name during deployment I get the error:

    "Object doesn't support this property or method: 'MachineObjectOUOptional'

    If I don't automate the joining of the domain I'm able to choose the OU from a dropdown list using the same formatting.

    Thursday, March 3, 2016 3:14 PM