none
Scorecard dimension with many members RRS feed

  • Question

  • Hi,

    Our sales cube has an account dimension which consists of Account Name and Account Agent Name.

    Trying to create a scorecard I've added to it the Account Agent Name and then (below it, as a child) the Account Name (selected all members for both).

    For some reason when retrieving the data it keeps on giong and does not display. Looks like it tries to bring all account names (there are many!!!) for each agent and not only the accounts related to the agent.

    When I do the same in a grid report it works fine- having both the  Account Agent Name and Account Name in the rows group brings under each agent only his accounts.

    How could the scorecard display under each agent only his account names?

    Edit- I now see the dashboard designer still shows empty rows eventhough the filter empty rows is checked on measure and target in the scorecard, but why?

    Thanks


    Namnami


    • Edited by namnami Monday, January 16, 2017 12:12 PM
    Monday, January 16, 2017 10:50 AM

Answers

  • The solution I've found was to check the Filter Empty Rows ON THE RIGHT CLICK MENU OF THE "ACTUAL" COLUMN ITSELF (as opposed to only though the view settings filters). So now the scorecard filters empty value and successfully displays only the account which the agent has deals with.

    Still, since we have many accounts not related to agent, this takes very long time to load (4 minutes!).

    So what I did was add the account dimension to the scorecard while using auto-select all children in the members selection. So the scorecard displays fast for the agent but when he click the + sign next to all, it takes 4 minutes in order for all the accounts to show. 

    UPDATE-

    I've added a hierarchy of agent> account to the cube, and that shortened the time from 4 minutes to a few seconds! 


    Namnami



    • Marked as answer by namnami Tuesday, January 17, 2017 11:13 AM
    • Edited by namnami Wednesday, January 25, 2017 6:49 AM better answer
    Tuesday, January 17, 2017 11:13 AM