locked
Vista Ultimate 64-bit edition - Not detecting all my installed RAM RRS feed

  • Question

  •  

    I was using two 1-gig sticks of ram, and windows/bios always detected the proper 2-gig total amount.

     

    After installing another 1-gig stick, the bios properly detected 3 gigs....but Vista does not. Vista (along with dxdiag, 32 and 64 bit versions) report 2 gigs of system memory still.

     

    I thought it might be a problem with the ram, so I took out the new 1-gig stick and added two 512 sticks (still total of 3 gigs). The bios again detected 3 gigs, but Vista Ultimate 64-bit edition will only detect 2 gigs.

     

    What's going on? (And yes, the OS is genuine and properly registered)

    Thursday, May 8, 2008 3:13 AM

Answers

  • I found the solution.

     

    For some reason unknown to me, Vista was configured to only use 2048 megs of memory. To access this configuration, I went to:

     

    start->run->msconfig->boot tab->Advanced Options->Maximum Memory checkbox

     

    The "maximum memory" checkbox was checked, at set at 2048. I did not set this. When vista was installed, the machine only have 2048 megabytes, so I am guessing that is why the box was marked this way.

     

    I unchecked the maximum memory option, restarted, and now vista properly reports all the installed RAM.

    Sunday, May 11, 2008 3:21 AM

All replies

  •  

    Hello,

     

    This problem maybe caused by following two factors:

     

    1.    PAE(Physical Address Extension) not enabled: For this situation, Open an elevated command prompt, type BCDEDIT /SET PAE ForceEnable, press Enter.

    For more information on this, refer to the following KB article:

    (KB929580) Windows Vista or Windows Server 2003 may report less memory than you expect
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;929580


    2.    Motherboard built-in feature: Some motherboards have built-in features, for example integrated video card may share some memory without noticing you. For this possibility, you can contact hardware manufaturer to confirm it.

     

    Hope this helps.
    Friday, May 9, 2008 7:39 AM
  • I found the solution.

     

    For some reason unknown to me, Vista was configured to only use 2048 megs of memory. To access this configuration, I went to:

     

    start->run->msconfig->boot tab->Advanced Options->Maximum Memory checkbox

     

    The "maximum memory" checkbox was checked, at set at 2048. I did not set this. When vista was installed, the machine only have 2048 megabytes, so I am guessing that is why the box was marked this way.

     

    I unchecked the maximum memory option, restarted, and now vista properly reports all the installed RAM.

    Sunday, May 11, 2008 3:21 AM
  • Hi. I am unsure now. The man building my 64-bit machine phoned today to say the computer will not start when he inserts all 4 2GB RAM cards. The OS is not even installed on the HDD yet. He says the computer starts with 4GB but not with 8GB. Is this BIOS, main board, RAM, Processor or other that is causing this issue?

    Thank you. We appreciate your knowledge and assistance.

    Thursday, September 4, 2008 4:48 PM