locked
Windows Mail Painfully slow RRS feed

  • Question

  • Anyone had problems with windows mail??? its really slow compared to outlook express... So is microsoft outlook. But when i boot into XP i get no issues at all..

    I have searched the net and some people are having this problem but no solution has been found.

    Any ideas? sometimes it really locks up and then the wait stop message appears...

    I have NO antivirus program
    I have NO firewall
    Surfing the web is very smooth and fast
    my connection is cable 3mbit.
    Monday, December 4, 2006 12:37 AM

Answers

  • I've found a solution to the slow composing or replying to email issue - although not sure if it is going to solve the problem for all situations.

    In my situation, my client had roughly 1000 entries in her contact list.  Every time she went to create, reply or forward an email, it would take 25 seconds for the new/reply/forward email window to "fill in".  I removed (randomly) half of her contact list entries (after creating a backup of them) and it reduced the lag time to 4 seconds.  I went the whole way and removed the lot and it reduced the lag to zero.

    I got to thinking what might Windows Mail possibly be doing with all the contacts that causes it to lag so long before it can finish drawing the mail composition window. I thought maybe it is loading all the email addresses into memory so that it can autocomplete any email address that is typed into the To: or CC: boxes.  So, I loaded up the 1000 entry contact list again and went hunting in Tools > Options.  I can't remember which tab I found it under (I don't have Vista myself yet, so can't double-check), but I found an "autocomplete email addresses as you type" check box that was (by default) checked. I unchecked this and the mail composition window went to zero lag again, I re-checked it and it went back to the 25 second lag - I think this fairly conclusively proves what the problem was.

    As an epilogue to this story, the client told me that out of the 1000 email addresses, she only uses about 50.  Her job function is to reply to email enquiries for her business, so she gave up on trying to reduce the list as about 20 new ones would be added each day due to the "automatically add contacts that I reply to" feature.  I turned off that feature and told her to cull the ones that she didn't need and she'd eventually get back to a speedy Windows Mail with the added bonus of email autocomplete.

    Saturday, March 3, 2007 6:50 AM
  • I found the solution with Microsoft Support. We looked for about 2 weeks and found the solution. It's a problem of TCP/IP incompabilité with Windows Vista and the router. The solution is: get a firmware update for the router and no more problems.

    Wednesday, February 21, 2007 5:58 PM
  • I have the answer for you problem! it's very simple. Windows Vista has some problems with most routers (from dlink to cisco and many other). I opened a HELP call at Microsoft Support and I found the solution before Microsoft.

    Solution: Actually you need update your FIRMWARE of your router. If tere is no resent firmware version available for your router, then you will need to buy a new one. The problem is coming from an Incompability of the TCP/IP Protocol between your router and Windows Vista.

    It is NOT your provider, and it is NOT your Computer, juste the router. I have an older D-LINK (about 2 years old) at home, well guess what, it is not compatible with Vista and there is no firmwair available for it. The last firmware dates on the december 2005. DLINK will not bring a new firmware for the router, so I cannot use it with Windows Vista!

    Now I have a Linksys Bussiness Router and guess what, I needed to update the firmware hade the same problem. But Linksys has all firmware for all routers (old and new). So if you want to buy a new one take Linksys (http://www.linksys.com/vista).

    Thursday, March 1, 2007 10:35 PM

All replies

  • I'm having same problem Walt Mossberg reporter in his column: long wait (10 seconds?) to create a new message. No idea what the problem is. Dell OEM support couldn't help.
    Thursday, February 1, 2007 9:45 PM
  • Just got Ultimate up-and-running. Mainly problem free, but now notice the same as highlanderc- that Mail is very slow to generate New Message/ Reply etc windows....

    What's happening I wonder?

     

    Friday, February 2, 2007 9:23 AM
  • Do we all have Dells? I do. Mossberg reported this problem only on the Dell he was testing.

     

    Saturday, February 3, 2007 4:22 AM
  • No, mine's an Evesham Axis Dominator (!).
    Saturday, February 3, 2007 9:23 AM
  • i have a New HP pavillion s7700n Amd anthlon 64x2 1 gig ram-

    everything runs fine BUT Windows mail is so slow-- i think i might even return my computer

    Friday, February 9, 2007 7:00 PM
  • In addition, Windows Mail shows my "received" mail time as 8 hours late, despite the fact that the system clock is correct, and also that the time in the header is correct. Anyone else with this?
    Saturday, February 10, 2007 9:07 AM
  • was on the phone with tech support with HP- didnt know a thing

    What i did do that solved my problem ( a bandaid)

    i created a new user, and tried my email box- without any transfered emails and folders (i have 6 gig of emails) and it worked pretty fast- samething with the contacts i have a few thousand- without any it was fast

     

    i think Windows Mail looks at all the emails every single time- like it was in one folder on Ouytlook express.

     

    im going for Mozzilla Thunderbird- till Windows fixes this

    Sunday, February 11, 2007 2:05 AM
  • Interesting- however, I think that the problem goes deeper than that. I have tried twice now with completely "virgin" empty mailboxes, and the delay/ slowness is still there. Any other boards to post on possibly?
    Sunday, February 11, 2007 8:41 AM
  • Hi I opened a new post that has similar problems with Windows Mail and Office Outlook 2003. I think it's the same problem... http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1215022&SiteID=17

    Sunday, February 11, 2007 4:07 PM
  • Yes, it's excruciatingly slow when either composing mail or sending. Normal receipt of mail and surfing are about the same as with XP Pro, but what is WRONG with Windows Mail in these other areas?  Certainly we're not the only ones!!?
    Wednesday, February 21, 2007 3:11 AM
  • It's very strange, and extremely annoying. Tired Mozilla Thunderbird mail, and that works perfectly- just as good as Windows Mail except that it is not possible (as far as I can see) to import Windows Mail- as opposed to Outlook Express etc-  contacts into it! Are you listening Microsoft? Please do something.....
    Wednesday, February 21, 2007 8:53 AM
  • I found the solution with Microsoft Support. We looked for about 2 weeks and found the solution. It's a problem of TCP/IP incompabilité with Windows Vista and the router. The solution is: get a firmware update for the router and no more problems.

    Wednesday, February 21, 2007 5:58 PM
  • Interesting- but no help in my case! Firmware completely updated- no difference...woe is me....

     

     Alain Kumschick wrote:

    I found the solution with Microsoft Support. We looked for about 2 weeks and found the solution. It's a problem of TCP/IP incompabilité with Windows Vista and the router. The solution is: get a firmware update for the router and no more problems.

    Thursday, February 22, 2007 10:36 AM
  • Same here. Updating did not help.
    Sunday, February 25, 2007 11:57 PM
  • I'm having the same problem - 3 hours late with the clock.

    Called Hp, who blamed it on Microsoft. Called Microsoft, who blamed it on my ISP. Called my ISP who balmed it on Microsoft.

    I seem to be caught in the blame game.

     

    Did you ever solve this problem?

    Thursday, March 1, 2007 8:33 AM
  •  tntnyc wrote:

    I'm having the same problem - 3 hours late with the clock.

    Called Hp, who blamed it on Microsoft. Called Microsoft, who blamed it on my ISP. Called my ISP who balmed it on Microsoft.

    I seem to be caught in the blame game.

     

    Did you ever solve this problem?

    No- still 8 hours behind! Finally got in touch with Microsoft's so-called "Help" dept, and sent them chapter-and-verse. After four days, they told me that the problem "was too complicated to deal with by email", and that I should call their premium-rate 0890 phone number to speak to someone. So far I have resisted the offer- but the problem remains....

    Thursday, March 1, 2007 8:56 AM
  • I have the answer for you problem! it's very simple. Windows Vista has some problems with most routers (from dlink to cisco and many other). I opened a HELP call at Microsoft Support and I found the solution before Microsoft.

    Solution: Actually you need update your FIRMWARE of your router. If tere is no resent firmware version available for your router, then you will need to buy a new one. The problem is coming from an Incompability of the TCP/IP Protocol between your router and Windows Vista.

    It is NOT your provider, and it is NOT your Computer, juste the router. I have an older D-LINK (about 2 years old) at home, well guess what, it is not compatible with Vista and there is no firmwair available for it. The last firmware dates on the december 2005. DLINK will not bring a new firmware for the router, so I cannot use it with Windows Vista!

    Now I have a Linksys Bussiness Router and guess what, I needed to update the firmware hade the same problem. But Linksys has all firmware for all routers (old and new). So if you want to buy a new one take Linksys (http://www.linksys.com/vista).

    Thursday, March 1, 2007 10:35 PM
  • I've found a solution to the slow composing or replying to email issue - although not sure if it is going to solve the problem for all situations.

    In my situation, my client had roughly 1000 entries in her contact list.  Every time she went to create, reply or forward an email, it would take 25 seconds for the new/reply/forward email window to "fill in".  I removed (randomly) half of her contact list entries (after creating a backup of them) and it reduced the lag time to 4 seconds.  I went the whole way and removed the lot and it reduced the lag to zero.

    I got to thinking what might Windows Mail possibly be doing with all the contacts that causes it to lag so long before it can finish drawing the mail composition window. I thought maybe it is loading all the email addresses into memory so that it can autocomplete any email address that is typed into the To: or CC: boxes.  So, I loaded up the 1000 entry contact list again and went hunting in Tools > Options.  I can't remember which tab I found it under (I don't have Vista myself yet, so can't double-check), but I found an "autocomplete email addresses as you type" check box that was (by default) checked. I unchecked this and the mail composition window went to zero lag again, I re-checked it and it went back to the 25 second lag - I think this fairly conclusively proves what the problem was.

    As an epilogue to this story, the client told me that out of the 1000 email addresses, she only uses about 50.  Her job function is to reply to email enquiries for her business, so she gave up on trying to reduce the list as about 20 new ones would be added each day due to the "automatically add contacts that I reply to" feature.  I turned off that feature and told her to cull the ones that she didn't need and she'd eventually get back to a speedy Windows Mail with the added bonus of email autocomplete.

    Saturday, March 3, 2007 6:50 AM
  • Yes, this works! Many thanks- although it does reveal a weakenss in Vista- as opposd to XP for instance, where even with thousands of address-book entries, there was no delay. In any case, it is good practice no doubt to cull the address-book from time-to-time! (The tick-box is under Tools/ Options/ Send, by the way)
    Saturday, March 3, 2007 9:08 AM
  • EXCELLENT!  Thanks very much.  It was not the culling out of addresses at all, but rather just switching off the autocomplete email addresses box in Tools|Options|Send as the next the guy just prior to me and just after you cited. 

    The very funny thing to me is that that was a feature that has NOT been working for me even though I have had the box checked!  So I lose NOTHING by unchecking it and gain SCADS of free time by losing the ridiculous delay.

     

    Microsoft Vista Team ATTENTION!!!!

    Saturday, March 3, 2007 10:45 PM
  • Thank you for the pointers in the right direction.  Unchecking the Autofill helped for most of the windows mail functions and they are working for me now...it was driving me crazy...I have two tickets open with MS....

    I still have a problem with newly created mail....the system won't keep up with my entry (typing).  The keystrokes for this reply are just fine, but in Windows mail....I type.... hello as an example and it fills in h...then..ell...then o as though it is in slow motion...very frustrating to get anything done....any ideas?   Supra93

    Friday, March 9, 2007 9:10 PM
  • In my case at least turning off the auto-complete for email address was only partly successful.  That is, the time delay was reduced quite a bit, but the inconvenience of having to complete the address is almost not worth it.

     

    MS MUST fix this.  Windows Mail is far more sluggish than OE (just as Vista is as compared to XP) and I, as is virtually every other consultant I know, am recommending against Vista upgrades except when absolutely critical  Certainly this is not what MS desires! 

    Monday, May 7, 2007 12:56 AM
  • Is your Windows mail still acting slow??? 

     

     Try this.....Open Windows Mail, goto Options/Read.....and uncheck >>> Automatically download message when viewing in Preview Pane

     

     

    This was able to fix my slowness   

    Thursday, June 14, 2007 8:30 PM
  • Yes, I recently installed Vista and have experienced extreme slowness with Windows Mail.  I am already browned off with the fact that my work email was changed from Outlook Express to Outlook, with unecessary extra complexities, but to have to abandon Outlook Express at home in favour of Windows Mail sucks.  When I highlight a message it takes about 20 seconds to see the message contents.  Surely there was some functional testing done before release of this software!  Why should consumers take a backward step in performance when upgrading to the latest operating system and its enforced new email application?  I run a Pentium D 2.6GHz dual core processor and I am sure that this has nothing to do with the degraded performance.
    Friday, June 15, 2007 12:08 PM
  • Hi,

    Thanks.  Did this and I can instantly view messages when I hignlight them, rather than wait 20 seconds or more.  Thanks again for this tip... Vita3351

    Friday, June 15, 2007 12:15 PM
  • I have this problem and nothing that has been suggested so far helps. I fail to see how the router can be the problem as it makes no difference on line or off. It takes many seconds for any action to be processed.  I have only just started using Windows Mail after purchasing a new laptop with Vista installed. It seemed OK for the first few days but is now almost impossible to use. I do have a large address book that was imported form my other computer but do not have auto complete turned on.
    Saturday, June 23, 2007 10:03 AM
  • I have also had Windows Mail, recently, start to react VERY slowly. Perhaps it was because of a system update but I seriously doubt it.

     

    Microsoft needs to address this issue. It seems to be fairly widespread and it's VERY annoying. Maybe I should upgrade to Outlook, instead?

    Thursday, June 28, 2007 10:02 PM
  • Your fix absolutely worked!!  Thanks, so much.  I have to write many, many emails and I've been wasting hours.  Of course, this is a major flaw in the way Mail works.  We should be able to have Windows Mail automatically complete addresses without having to wait 20 to 30 seconds on every action. 

     

    Thanks again. 

    Tuesday, July 17, 2007 6:44 PM
  • Right now I'm deleting approx 15,000 messages from my Inbox... Sounds a lot, sure - but nothing a Core 2 Duo processor, 4gb ram and 300gb Hitachi SATA drive cant handle...

    What I dont understand is why its been deleting for the past couple of hours with an ETA of another 4hrs? It seems painfully slow and the HDD let indicator and the HDD noise suggests its constantly working through this process....

    I have noticed it takes quite some time to perform tasks on the desktop too especially folders that may have a couple of thousand files.. it takes them a while to get copied/moved/deleted etc..

    Anyone else has this problem? Are the two related??

    Wednesday, July 18, 2007 8:21 PM
  • I have more than 3000-entries in my address book and I had no problem with Windows XP Home Addition and Outlook Express. Also my Inbox and Outbox have more than 10000 messages each.

     

    Have unchecked "autocomplete" option and new mail window is working fine. As far as reply message is concerned its still very slow. If all this data worked in Outlook Express without any problem than it should work in Windows Mail as well. One expects improvement in new softwares rather than poor performance.

     

    Unchecking "Autocomplete" means I have to type complete email address everytime. I didn't have to do that in XP/ OE.

     

    The height of stupidity is that you can't roll back to XP/ OE once you have starting using Windows Mail. Microsoft should have made Windows Mail compatible with Outlook Express.

     

    Using Windows Mail is extremely enoying and Microsoft should do something about it and do it fast,

     

    Ali

    Monday, September 10, 2007 5:43 AM
  • Thanks everyone for all these solutions. It seems that the simple ones are correct. I've unchecked the 'automatic' box and my create and forward are instant now but the replies are still slow. It must be something within the Tools so I'll play around with it!

    Come on Bill Gates, use some of your billions of dollars to sort this out!

     

    Colin

     

     

    Friday, September 28, 2007 9:29 PM
  • Are you running Spybot or similar? I found a fix here http://www.vistax64.com/tutorials/72674-windows-mail-slow.html

    Sunday, October 14, 2007 7:46 AM
  • Some excellent ideas in the post you referred me to.  Thanks! 

     

    I have tried many though not all of them.  I will do so and report back here. 

     

    Still, I think it is unforgivable that Microsfot has neglected a problem that is so obviously widespread and aggravating to so many!

     

    This would seem to be stereotypical of the monopo;y accused of such far-reaching empire building!  Why can't they see how beneficial a little customer service would be?  At least admitting the problem, and promising to work on it and report back would go so far!

     

    Sunday, October 14, 2007 4:35 PM
  • I think I found the solution to the problem.

    Stop using Windows Mail and switch to Mozzila Thunderbird
    Sunday, October 14, 2007 5:36 PM
  • Yes, as it happens I also use Thunderbird but the registry fix suggested on the above forum sorted out my problem with Windows Mail which now works OK. I do have Spybot Search and Destroy installed and I assume that is what caused my problem.

    Sunday, October 14, 2007 9:04 PM
  •  custos wrote:

    Yes, as it happens I also use Thunderbird but the registry fix suggested on the above forum sorted out my problem with Windows Mail which now works OK. I do have Spybot Search and Destroy installed and I assume that is what caused my problem.

    I also have the same software installed but these are very popular items. Microsoft should know whether or not Windows Mail would be incompatible with these products.
    Nevertheless, I'm sick of waiting for an update that will never come. I've been using Thunderbird for nearly 3 months and it's a dream come true. It has many more features than Windows Mail (And even if that's not the case, it certainly has different ones).
    I'm content using this because it's fast and takes no time to load the program. I suggest using it, everybody!
    Sunday, October 14, 2007 9:08 PM
  • Thanks for the tip, but I tried to open that webspage and it comes up

    Internet Explorer cannot display the webpage

    I tried just the site and still got the same.

     

    Colin

     

    Monday, October 15, 2007 9:01 AM
  • Friday, October 19, 2007 8:48 PM
  • Five months ago I bought a Dell Inspiron laptop, wtih Vista and Windows Mail.  WM never worked right.  It doesn't just run slowly, it goes into "Not Responding" before eventually working.  Unchecking "automatically complete addresses" helps, but clicking on "Reply" or "Forward" still causes WM to freeze, fade on the screen, then VERY slowly respond.  It can take several minutes to forward or reply to a message.  I don't know if Microsoft caused this problem or if it was McAfee or Dell.  They blame each other.  But I find myself going back to my old 256 XP desktop with OE6, which, compared to the new Vista, works with lightnilng speed.  Is there any hope at all of a fix?
    ManhattanJack
    Friday, November 16, 2007 11:03 PM
  •  

    I found out my problem. It was webroot's spy sweeper.

    It has an option for "file system" under "windows system shields." I unchecked "file system" under "windows system," and it works like normal then.

     

    I was playing with it... Unchecking and testing windows mail. It was "file system" that made the difference.

     

    Just in case if some people in here have spy sweeper.

     

    Sunday, December 2, 2007 8:05 AM
  • You're a genius.  That worked, although I do miss the auto-complete feature.

     

    Saturday, March 1, 2008 11:52 PM
  • My Send and Receive is fine. My viewing has recently gone slow. To scroll down a message of any size takes about 1-2 minutes, depending on pictures. Any ideas or do you believe this is the same problem all others are mentioning?

     

    Thanks.....Deaper

    Monday, April 7, 2008 6:28 PM
  • Mine is also annoyingly slow when I open a New Message and when I click on "To:" to bring up the contacts.

     

     If anyone has a solution, I would greatly appreciate it.

    Thursday, April 10, 2008 4:09 PM
  •  

    1.Updating firmware for router  do not have any releveance with it.

     

    2.The culprit is window contacts only.Once you empty(obviously after taking back up) your window contacts/address book & use any option of crating/forwarding/replying the time delay get back to normal.

     

    3.I have faced another problem of importing window contacts in Vista>window mail  through CSV file from window xp>outlook exp-6.I got success only through wab file formars.I have 5892 window contacts.

     

    4.I am using Microsoft Outlook(for address book,periodical promotional letters/update) & window mail for normal follow up.

     

     

     GeeksToTheRescue wrote:

    I've found a solution to the slow composing or replying to email issue - although not sure if it is going to solve the problem for all situations.

    In my situation, my client had roughly 1000 entries in her contact list.  Every time she went to create, reply or forward an email, it would take 25 seconds for the new/reply/forward email window to "fill in".  I removed (randomly) half of her contact list entries (after creating a backup of them) and it reduced the lag time to 4 seconds.  I went the whole way and removed the lot and it reduced the lag to zero.

    I got to thinking what might Windows Mail possibly be doing with all the contacts that causes it to lag so long before it can finish drawing the mail composition window. I thought maybe it is loading all the email addresses into memory so that it can autocomplete any email address that is typed into the To: or CC: boxes.  So, I loaded up the 1000 entry contact list again and went hunting in Tools > Options.  I can't remember which tab I found it under (I don't have Vista myself yet, so can't double-check), but I found an "autocomplete email addresses as you type" check box that was (by default) checked. I unchecked this and the mail composition window went to zero lag again, I re-checked it and it went back to the 25 second lag - I think this fairly conclusively proves what the problem was.

    As an epilogue to this story, the client told me that out of the 1000 email addresses, she only uses about 50.  Her job function is to reply to email enquiries for her business, so she gave up on trying to reduce the list as about 20 new ones would be added each day due to the "automatically add contacts that I reply to" feature.  I turned off that feature and told her to cull the ones that she didn't need and she'd eventually get back to a speedy Windows Mail with the added bonus of email autocomplete.

    Saturday, April 12, 2008 11:59 AM
  • What this is the size of the contacts file, if you turn off auto complete in the preferences, a new message opens like it should.
    Shortening the address book seems a bit pointless (even for the Lone Ranger) but that would help I expect.
    Hey man this board could be good but why put the latest posts at the other end?
    And what was all that stuff about firmware for your router!!!!
    Some people?

    Tuesday, April 22, 2008 5:22 PM
  • Unchecking the auto fill makes this faster. However, when I click SEND,  Mail checks the addresses in the Address book & take 20 - 30 seconds before it sends. Does anyone know how to improve the new Contacts function in Vista????

    This seams to be where the slow email issue lies

     

    Wednesday, July 9, 2008 9:54 PM
  • Hi JHarrsch

    I have the same problem, but I think that it is a problem that Microsoft have launched this program far too early and we are the guinea pigs to hiighlight the problems. They then can put their heads together to sort it out. All I can suggest is we just keep on a Microsoft and get them to sort it out. Unless, some nice person out there can fix it for them...

     

    All the best

    Colin

     

    Thursday, July 10, 2008 10:56 AM
  • I was having the same problem.  So, I did what you suggested and lo and behold it works like a charm!!  Thanks so much for posting this!
    Saturday, August 8, 2009 5:33 PM
  • Thankz Problem SOLVED!!!!!!
    Thursday, February 11, 2010 8:42 AM
  • "so, I loaded up the 1000 entry contact list again and went hunting in Tools > Options.  I can't remember which tab I found it under (I don't have Vista Smyself yet, so can't double-check), but I found an "autocomplete email addresses as you type" check box that was (by default) checked. I unchecked this and the mail composition window went to zero lag again, I re-checked it and it went back to the 25 second lag - I think this fairly conclusively proves what the problem was."



    THIS also worked for me annnnnd it worked immediately.  WHAT a difference it made!!! Previous to reading YOUR post I had looked in innumerable places for a solution to THIS problem to NO avail. BTW the autocomplete option is found under Tools>options>Send Tab.  thank you for your help.
    Saturday, February 20, 2010 1:20 AM
  • Try this.....Open Windows Mail, goto Options/Read.....and uncheck >>> Automatically download message when viewing in Preview Pane

    This was very helpful - it work very fast now 

    Tuesday, April 20, 2010 11:15 AM
  • This was very helpful - it works very fast now  - thanks a stack
    Tuesday, April 20, 2010 11:15 AM
  • "Automatically complete e-mail addresses when composing" is the tab to uncheck. This absolutely solves this problem as I too had a very very slow and unresponsive windows mail in the last couple of days until now.

     

    Many thanks on sharing this as you have solved my problem too.

    Thursday, July 15, 2010 9:17 AM
  • THANK YOU to whoever posted the above about unchecking "Auto-Complete emails".  I was having to wait for nearly a minute for my compose message window to fully open.  I went to "Tools" "Options" and then under the "Send" tab you will find the Automatically Complete email addresses when composing.  I unchecked that and now my new message window opens immediately. 
    Thursday, November 3, 2011 1:02 PM
  • I have the same problem, My cpu is pretty good, it still very slow. Really disappointed about MS's slagging mail!

    The only thing greater than the power of mind is the courage of heart.

    Wednesday, March 5, 2014 1:41 AM