locked
Remote Desktop login RRS feed

  • Question

  • We have 2 pcs that we connect to via Remote Desktop.  One of them stops at this screen so we can tell that someone else is already logged in, so we are given the opportunity to CANCEL, so we don't "throw off" the person who is already logged in:

    Sorry, my image is not allowed until account verification is complete.

    The other machine goes straight to this screen, and we can't tell if someone else is already connected.  So when we type the password, it disconnects the person who is already connected through remote desk"vertical-align:top;">Sorry, my image is not allowed until account verification is complete.

    I can't find any settings in the .RDP shortcut that are different between the 2 machines.  It must be something on the machine itself. Can you help? I would like the users to see the first picture above if someone else is already logged in , so the user will have the chance to cancel, so the original user won't be disconnected .

    Thank you!


    Tuesday, October 17, 2017 5:36 PM

All replies

  • Hi,

    Could you please upload the screenshot onto OneDrive and share the link here?

    I did some tests. And there are some screenshots.

    Test 1. Use PC A to connect to a Windows 7 PC via Remote Desktop, then use PC B to connect to it via RDP. It will show as following screenshot.

    Test 2. If use the account that logged on remotely, the PC A will disconnect the connection. If use other user, it will show as following screenshot.

    And if click Yes, PC A will show as following screenshot.

    Test 3. Use the Windows 7 which is the remote desktop PC log on, it will show as following screenshot.

    Test 4.   If the PC has saved the credentials, it will show as following screenshot when connect to it. (Even a user has logged on the remote PC. ) But if choose other User, and use other user account, it will show as Test2.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Vera Hu Wednesday, October 18, 2017 9:02 AM
    Wednesday, October 18, 2017 9:01 AM
  • I am having trouble following your explanation. Maybe with my screen shots, it will be easier for us to communicate:

    Here is my original post on another microsoft board that allowed the images:

    https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/remote-desktop-settings/b608e3e6-724d-4287-8fa7-2528288fd951


    Wednesday, October 18, 2017 3:16 PM
  • Please check if the Prompt for credentials on the client computer is enable in local group policy. Here are steps.

    1. Type gpedit.msc in search box, press Enter.

    2. Navigate to Computer Configuration -> Administrative Templates -> System -> Windows Components -> Remote Desktop Services -> Remote Desktop Connection Client.

    3. Find Prompt for credentials on the client computer in right panel.

    I did a test, if the Prompt for credentials on the client computer is enable, it will show as following screenshots.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 20, 2017 10:28 AM
  • Sorry for any confusion...This is the screen I DO NOT want to see...I want to see the screen that shows you that someone else is already logged on.  This screen above is the screen that just kicks off the person that is already logged in.

    I did change the settings from Not Configured to Enabled. Either way it shows me this screen that I do not want. How do I get the other screen...the one with the blue background?  https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/remote-desktop-settings/b608e3e6-724d-4287-8fa7-2528288fd951

    Friday, October 20, 2017 6:10 PM
  • Please try to set it disable to see if it can work.

    Please check if there are any GPO of remote disconnection. Please take following to see the GPO.

    1. Open Command Prompt (as administrator).

    2. Type gpresult /h c:\gpreport.html

    And you could also upload the report onto OneDrive and share the link here.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 23, 2017 1:19 AM
  • Disable does not work either.

    Why are you having me check settings in the gpedit.msc for Remote Desktop Connection Client? Wouldn't it be the Remote Desktop Connection Host?  It is the computer I am logging into that is the problem.

    Anyway, here are links to the gpreport.htm files. RD3 is the computer that is correct. RD1 is the computer that is not correct.

    I have changed sensitive information to XXX and YYY and saved them as pdfs and you can see them here:

    www.legalperfection.com/downloads/RD1-wrong login.pdf

    www.legalperfection.com/downloads/RD3-right login.pdf

    Tuesday, October 24, 2017 6:54 AM
  • It seems no difference between the two gpreport.

    Did administrator account use RDP also occur the screen?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 31, 2017 10:55 AM
  • Sorry I don't understand.
    Thursday, November 2, 2017 12:48 AM
  • Hi,

    I would like to apologize for the delay in replying.

    Please check if the Remote settings is checked Allow connections only from computers running Remote Desktop with Network Level Authentication(more secure). Here is a screenshot.

    I did a test. If PC A check this setting, then PC B use RDP access PC A, it will occur the following screenshot.

    If yes, please try to check the Allow connections from computers running any version of Remote Desktop (less secure) to see if it can work.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.




    • Edited by Vera Hu Wednesday, November 8, 2017 8:13 AM
    Friday, November 3, 2017 7:32 AM
  • Hi, 

    Hows everything going? Please feel free to give me any update.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 8, 2017 8:13 AM
  • Not resolved. Still desperately need help!
    Wednesday, November 15, 2017 11:39 PM
  • Hi,

    Did you check Allow connections from computers running any version of Remote Desktop (less secure) setting on the wrong login PC Remote settings (Control Panel -> System -> Remote settings) to see if it can work?

    Please also check if you check the Allow me to save credentials setting when you use RDP.

    If you check the setting, it will show as following screenshot. Please try to uncheck the setting.



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 16, 2017 7:23 AM