none
Accessing Domain Shared folder from non-domain computer RRS feed

  • Question

  • Hi everyone!

    Noticed, that if I try to access a shared folder located on domain computer from non-domain computer, typing \ \ computername\sharename, pop-up authentication window appears after some time (30-80 sec). But, if I type \\computername  without pointing sharename, pop-up authentication window appears instantly.

    If I run created shortcut for this share - pop-up authentication window appears instantly.

    I can easily reproduce this problem, it appeared on all machines I was testing.

    Can it be fixed somehow? In my scenario, I can not use net use cmd.

    Thanks.



    Tuesday, December 11, 2012 6:53 AM

All replies

  • Hi,

    What is your real question?

    If you want to access domain share from a non-domain computer, please enable Guest account, assign Everyone group the permission to access the sharing folder and then add the Anonymous SID to the Everyone access token.

     

    To enable anonymous access on a local workstation or server computer

    1.Open Local Security Settings. Click Start, click Control Panel, double-click Administrative Tools, and then double-click Local Security Policy.

     

    2.In the console tree, double-click Local Policies, and then click Security Options.

     

    3.In the details pane, right-click Network access: Let Everyone permissions apply to anonymous users, and then click Properties.

     

    4.On the Local Security Settings tab, click Enabled, and then click OK.


    Alex Zhao
    TechNet Community Support

    Wednesday, December 12, 2012 2:56 AM
    Moderator
  • I want to access domain share from a non-domain computer using Domain Account. But, as I said,  if I type UNC on non-domain machine like \ \ computername\sharename, pop-up authentication window appears after some time (30-80 sec). If I type \\computername  without pointing sharename, pop-up authentication window appears instantly. I do not understand, why a shortcut, consisting of UNC \ \computername\ sharename gives me pop-up authentication window instantly, but if I type the same UNC in Explorer, it takes time. Is this an OS Design, or I must tune something?
    Thursday, December 13, 2012 6:52 AM
  • Try using FQDN.

    For example use \\Computer.domain.com\c$

    If you don't supply what do you want to access on the computer (as in example with \\Computer) then it has to enumerate all of the shares,

    When you do \\Computer\share  works instantly because you are not asking to enumerate share, you are asking to access specific resource.

    Thursday, December 13, 2012 1:55 PM
  • Thanks, but "When you do \ \computer\share  works instantly because... " is wrong. It works instantly when I type \ \ computername, NOT

    \ \computername\sharename!

    Friday, December 14, 2012 7:46 AM
  • See what will happen if you access domain computer using IP address, or use "dir \\servername\sharename"(without the quotes) under command prompt to access the share.

    Which operating system is the non-domain computer running?

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, December 17, 2012 9:25 AM
  • Thanks for reply.

    When I use IP - problem remains.

    When I use dir \ \servername\sharename - it says that user`s login or password are not recognized (sorry, can not say exactly, I have Russian localization).

    Wednesday, December 26, 2012 5:56 AM
  • Hi,

    Does the error message that user's login or password are not recognized pops up immediately when you used dir \\servername\sharename?

    If it appears promptly, the issue should occur on client side.

    Try to boot the non domain-joined client to Safe Mode with Networking, then check the result.

    If the error message also returned with 30-80 sec delay, you can do:

    a. Reboot the domain computer where  shared folder resides in to Safe Mode with Networking to see what will happen.

    b. Restart Server service on the domain computer, and then check if the issue stops.

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, December 26, 2012 9:35 AM
  • The error message that user's login or password are not recognized appears immediately in cmd window.
    Wednesday, December 26, 2012 10:17 AM
  • It looks like the issue only occurs in Windows Explorer, some third party application may cause the issue, especially antivirus software.

    You can reboot the non domain computer into Safe Mode with Networking, and then access \\servername\sharename to see what does happen.

    If the issue remains, capture network monitor on the non domain computer and then analyze where the delay happens.

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, December 27, 2012 2:56 AM
  • There is no AV software installed, it was clear installation of Windows 7 Ent.

    In safe mode the problem remains.

    Please, try to reproduce this problem, you can easily do it. It reproduces on every PC I`ve been testing. I think this is another windows "feature".

    Thursday, December 27, 2012 7:17 AM
  • I have done testing on my side, I cannot reproduce the issue. While accessing \\servername\sharename, the credential prompt pops up immediately.

    Can you let me know which operating system your client and server are running.

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, December 28, 2012 2:46 PM
  • Did you access \ \servername\sharename from non-domain computer? The share was on domain computer?

    Domain computer with shared folder: Windows 7, windows 2008R2.

    Non-domain accessing computer: Windows 7, Windows XP.

    Thursday, January 10, 2013 6:47 AM
  • I'm facing similar problem with WinCE devices. I'm trying to access Win 7 shared folder from WinCE, only \\hostname\<shared-name> and \\hostname\d$ is accessible. WinCE failed to enumerate Win7 shared folders list.

    Tried changing a few Local security policies but none worked so far. Any comments ?


    ◄◄ hypheni ►►

    Thursday, January 10, 2013 9:41 AM
  • Check if the SMB2 related files are newest, if not, install the latest hotfix to update them.

    http://support.microsoft.com/?id=2473205

    Regards,

    Diana


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 17, 2013 9:17 AM
  • All updates/hotfixes were installed. The problem remains :(
    Monday, January 28, 2013 5:28 AM
  • Have you gone in to Control Panel on the offending workstation , go to Manage User Accounts, then on the left hand side click on "Manage My Credentials" and then deleted the entry to the server on the domain. Then you can try to reconnect to the share and re-enter the correct credentials
    Tuesday, January 21, 2014 8:39 PM
  • hey, the problem is that default domain policies do not allow access to your pc outside the domain. Before you connect the pc to a domain- go to advanced sharing options and under "password protected sharing"  choose the "turn off password protected sharing"  
    Save settings and put it back to domain. After that, when you share a folder with "everyone" you will have access... 
    This is how i do it for my self. 

    • Edited by Tonitsh Wednesday, March 25, 2015 8:03 AM typo
    • Proposed as answer by Tonitsh Wednesday, March 25, 2015 8:03 AM
    Wednesday, March 25, 2015 8:01 AM
  • Probably because the proper way to type it in is without the spaces, "\ \ "computername\sharename, when you do that it takes longer for the program to interpret what the heck your trying to input. \\ without the spaces is the proper syntax for the sharename........
    Friday, April 24, 2015 1:25 PM
  • Did this one work?
    Friday, October 28, 2016 4:22 AM