none
Hyper-V VM unable to initialize (After copying from another server) RRS feed

  • Question

  • I have 2 Hyper-V servers in my environment. Both are independent of each other and all VM's are stored on local hard drives.

    HV-1 is 2008 R2

    HV-2 is 2012 R2

    I am moving all VM's from 2008 to 2012 HV. As exported VM's from 2008 do not import into 2012, I copied all files for a VM from 2008 server and put them in VMs folder for 2012. HV2012 imported the VM fine, but when I tried to start it on 2012, it failed to initialize (some error to do with access or permissions).  

    I then exported that VM from 2012 to a new folder on the 2012 server and re-imported the exported VM and it worked fine. I then deleted the other VM and all is fine.

    Only issue is, I now need to do the same with another VM, but this is a file server with nearly 1TB of Data. I do not have enough space on the server to duplicate it. So I can not export it to re-import.

    Can someone suggest another solution to my problem?

    Thursday, May 22, 2014 7:38 PM

All replies

  • Hi,

    I have come across this before, the destination host doesn't have permission to the VHD file, you will need to re-set permissions on the VHD file.

    Daniel

    Friday, May 23, 2014 2:55 PM