locked
Running Office 2010 package on App-v 5.0 Beta 2 RRS feed

  • Question

  • Hi everyone, I am currently testing beta 2 of App-v 5 and as part of the test I've run the conversion of my old app-v 4.6 Office 2010 package. The conversion ran smoothly, I installed the 64bit version of Office deployment kit on my client, loaded the package and attempted to run it. However, before an Office application fully starts, the Office setup launches and after a while I'm getting the following error:

    "The full path to the install location must contain fewer than 115 characters. Choose a shorter path"

    I have a feeling that it's the deployment kit trying to run the license verification and for some reason hits this limit. It's true that the path is now very long, what with the package GUID and the version GUID appended in App-V5:

    C:\ProgramData\App-V\F53DF6CD-38F2-4384-9C0D-11C38F11F26E\8580F9A9-0697-4BE2-BB55-87D958E1A480\Root\...\...\....\Microsoft Office\Office14

    I checked but couldn't find a version of the deployment kit for App-v 5.

    Has anyone see this?

    Thursday, August 30, 2012 3:11 PM

Answers

  • Here's the link: http://connect.microsoft.com/MDOPTAP/content/content.aspx?ContentID=28335

    Support for Office 2010
    Office 2010 is not supported in the Beta release.
    WORKAROUND   None.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    Friday, August 31, 2012 9:01 AM
    Moderator

All replies

  • Office 2010 on App-V 5 beta isn't supported at this time. I'm sure this is in the release notes.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    Thursday, August 30, 2012 4:04 PM
    Moderator
  • Aaron,

    thanks for your reply. I am not able to find the release notes any more, there's only App-V 5 Beta Admin guide available for download on Connect. Do you have a link somewhere?

    Thanks in advance!

    Friday, August 31, 2012 8:42 AM
  • Here's the link: http://connect.microsoft.com/MDOPTAP/content/content.aspx?ContentID=28335

    Support for Office 2010
    Office 2010 is not supported in the Beta release.
    WORKAROUND   None.


    Twitter: @stealthpuppy | Blog: stealthpuppy.com

    This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    Friday, August 31, 2012 9:01 AM
    Moderator
  • I know this is an old thread but I'm having the exact same issue sequencing Visio 2010 and I'm not using the BETA version of App-v (I'm using V5.2).  Any solution would be appreciated.

    "The full path to the install location must contain fewer than 115 characters. Choose a shorter path"

    this is the path the icon shows:

    "%LOCALAPPDATA%\Microsoft\AppV\Client\Integration\C218D426-D242-4890-BB98-C9EE2E3561A0\Root\Microsoft Office\Office14\VISIO.EXE"

    Dave

    Tuesday, January 14, 2014 7:43 PM
  • Hello,

    Best practice states that Primary Virtual Application Directory should be the root-folder of the installation.

    My guess is that you do not have %PROGRAMFILES%\Microsoft Office\ as PVAD, but only %PROGRAMFILES%.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, January 14, 2014 8:04 PM
  • Yes - I was pointing to C:\Program Files (x86) since it's the 32bit version not including \Microsoft Office.  New to App-V and not quite getting all the concepts yet.  Do you have a link to a Best Practices guide that would explain this and other things I should know? 

    thanks for the quick response.

    Dave


    Dave

    Tuesday, January 14, 2014 8:08 PM
  • Excellent - thanks again.

    Have a good one!


    Dave

    Tuesday, January 14, 2014 8:14 PM