none
Disk allocation in DPM 2016 RRS feed

  • Question

  • We have an new Windows Server 2016 with an DPM 2016 with rollup 1 on. It’s installed on an new Hyper-v Host Windows Server 2016.

    We take backup of som Hyper-v virtual machines. We have some problems. Maybe there is some bug in DPM 2016….

    The VM where we take an backup of the hole server, we don’t have the possibility to modify disk allocation. It’s grayed out. (We could do that in DPM 2012 R2). On some of the VM we get this error: ‘DPM is out of disk space for the replica. (ID 58 Details: There is not enough space on the disk (0x80070070))’.

    And there is space enough on the disk. It seems that DPM 2016 have problem to calculate how mouch space there is on the Storage Pool Volumes.

    We also take backup of some file servers (Hyper-v VM) where we take it direct from the VM server. Here we can decide from which volumes on the server we want to make recovery point. And here we have the possibility to modify disk allocation. But not Replica…

    So If we take backup of the hole VM server where the DPM client is installed on the host, we can’t modify disk allocation but if we install the client direct on the VM, we can modify disk allocation. Is that an bug in DPM 2016?

    On the servers where we have the possibility to modify disk allocation we cant’t modify Replica. The possibility is not in DPM 2016. It was there in DPM 2012 R2. So the only possibility we have is to extend is ‘Space Allocated’. In DPM 2012 there was the possibility to extend Replica also.

    For me it seems that there is a lot of errors/bugs in DPM 2016. Or is it me who has misunderstood how DPM 2016 should be running?

    Monday, January 9, 2017 7:40 AM

Answers

  • Work around for my issue was to remove the VM from the PG. Modify existing PG and select the cluster and VM and clear cache on the Select Group Members pane. Add the VM again and it should now show correct data size.
    • Marked as answer by KiimsDK Tuesday, June 13, 2017 11:07 AM
    Monday, March 6, 2017 11:45 AM
  • Refresh DPM in 'Modify Protection group' helped for this error: "DPM is out of disk space for the replica"

    • Marked as answer by KiimsDK Tuesday, June 13, 2017 11:07 AM
    Wednesday, January 11, 2017 8:10 AM

All replies

  • Hi, 

    It used to be a similar replica issue in DPM 2012 as well. 

    Right click on your BMR PG, select "Modify disk Allocation"
    Find the "Replica Volume" field.

    Set the desired amount and apply changes. 

    The replica volume should be big enough (up to 1.5x) to accommodate replicas. 


    • Proposed as answer by Taras Shved Monday, January 9, 2017 3:34 PM
    Monday, January 9, 2017 1:33 PM
  • Hi Max

    This possibility is not an option.  "Modify disk Allocation" is grayed out. 

    Monday, January 9, 2017 2:58 PM
  • And on the servers where we take backup of the whole VM there is not an "Replica Volume" field..
    Monday, January 9, 2017 3:09 PM
  • With DPM 2016 the Modify Disk Allocation does not appear to be a valid setting, as it is always grayed out. Only if the error of the backup detects that it is out of space, then there is link to click to modify the disk allocation but it is automatic not allowing you to manually set the values as before.

    I am having this same issue with BMR backups where each subsequent backup needs to increase the size. Some have the option to modify the allocation as part of the error and others do not.

    I have not found anywhere documented how to manually modify the allocation or to force it to happen on the protection group like we could in 2012 R2.

    Looking forward to someone letting us know how to get past this issue.

    Mike


    Mike

    Monday, January 9, 2017 5:28 PM
  • Make this registry key on DPM server and give it a large value (atleast 1.5 times of vm size)

    datasources using the following registry key: Registry Path :
    HKLM\Software\Microsoft\Microsoft Data Protection Manager\Configuration
    ReplicaSizeInGBForSystemProtectionWithBMR (DWORD)

    Tuesday, January 10, 2017 1:30 AM
  • Hi

    In our case we don't backup BMR (Physical machines). Only VM. 

    Kim

    Tuesday, January 10, 2017 9:15 AM
  • Have same issue

    MCSE:S, MCSE:M, MCITP, MCTS, CCNA, CCDA Infrastructure expert

    Tuesday, January 10, 2017 10:28 AM
  • I think DPM is not able to query VM's storage.

    While creating the protection group, just do a refresh at the vm. This should force DPM to query the vm and get current storage size. If vm is part of cluster, also refresh the cluster.

    Tuesday, January 10, 2017 7:30 PM
  • I think DPM is not able to query VM's storage.

    While creating the protection group, just do a refresh at the vm. This should force DPM to query the vm and get current storage size. If vm is part of cluster, also refresh the cluster.

    Not helping!

    MCSE:S, MCSE:M, MCITP, MCTS, CCNA, CCDA Infrastructure expert

    Wednesday, January 11, 2017 5:37 AM
  • Refresh DPM in 'Modify Protection group' helped for this error: "DPM is out of disk space for the replica"

    • Marked as answer by KiimsDK Tuesday, June 13, 2017 11:07 AM
    Wednesday, January 11, 2017 8:10 AM
  • Same problem here. I tried everything discussed here with no help.
    Monday, January 16, 2017 4:06 PM
  • The same issue with DPM 2016 RU2.

    I have a Win 2008R2 server. I added this server to BMR backup.

    DPM can't create backup because:

        DPM is out of disk space for the replica. (ID 58 Details: Internal error code: 0x80990ED2)

    I can't resize disk space for replica in the DPM. When I choose 'Modify Disk Allocation', there is nothing.

    It seems a bug.

    I added/deleted this server several times, tried 'Refresh' during modify, etc - no success.

    How to manually resize the disk replica size in DPM ?


    mcse^4

    Tuesday, February 21, 2017 5:55 PM
  • #@##!#!##!!

    Helped me to resize a replica size and fix the issue.

    Now backup is working.

    You can use that at your own risk )

    #
    # (c) Alternate
    #

    $PG = Get-DPMProtectionGroup | where {$_.FriendlyName -eq "BMR" }
    Write-host "Protection Group:"
    $PG|fl

    $ds = Get-DPMDatasource $PG | where { $_.Computer -eq "server" }

    Write-host "Datasource:"
    $ds|fl
    Write-host "ReplicaUsedSpace: $($ds.ReplicaUsedSpace)"
    Write-host "ReplicaSize: $($ds.ReplicaSize)"

    #exit

    $sz = $ds.ReplicaSize
    "Old size: ", $sz
    $sz += 20GB
    "New size: ", $sz
    $sz1 = 40GB

    Edit-DPMDiskAllocation -Datasource $ds -ReplicaSize $sz -ShadowCopySize $sz1


    mcse^4



    • Edited by Alternate Tuesday, February 21, 2017 7:07 PM
    • Proposed as answer by Max Craft Wednesday, February 22, 2017 10:34 AM
    Tuesday, February 21, 2017 7:03 PM
  • Also having this issue with VM backups after upgrading from 2012 R2 to 2016. Consistency checks keep failing as the replica volume is not large enough. The volume automatically increases each time but there is no way to manually adjust the size like in 2012 R2 because the option is greyed out in the PG pane and in the monitoring pane under the error the modify disk allocation option doesn't present a UI to do so. HELP!
    Monday, March 6, 2017 10:56 AM
  • See my answer above.

    mcse^4

    Monday, March 6, 2017 11:20 AM
  • Work around for my issue was to remove the VM from the PG. Modify existing PG and select the cluster and VM and clear cache on the Select Group Members pane. Add the VM again and it should now show correct data size.
    • Marked as answer by KiimsDK Tuesday, June 13, 2017 11:07 AM
    Monday, March 6, 2017 11:45 AM
  • I know this is solved but for future reference there is a PowerShell script that does a great job of this now that we don't have the replica volume option on DPM 2016 that uses ReFS.

    https://blogs.technet.microsoft.com/dpm/2017/04/14/how-to-increase-dpm-2016-replica-when-using-modern-backup-storage-mbs/ 

    Particularly useful for BMR backup.

    Monday, July 31, 2017 5:34 AM
  • And yet it *is* grayed out.

    --petrejo


    • Edited by Pablo88008 Monday, October 15, 2018 2:21 PM
    Monday, October 15, 2018 2:20 PM
  • If you go to Monitoring and view the individual error, you have the option to "Modify Disk Allocation ..." as a recommended action.

    I believe it just extends a bit at a time, so you might have to do this several times.

    • Edited by praecoxx Monday, March 4, 2019 11:02 AM
    Monday, March 4, 2019 9:19 AM
  • This is a painful problem. 



    SJ

    Wednesday, March 6, 2019 12:45 AM