none
KPI indicators don't show up RRS feed

  • Question

  • It is very strange behaviour, the same scorecard viewed from the same client look different depending on the logged in user.

     

    For one user it shows the KPI indicators, but if another user log in on the same client machine he doesn't see the KPI indicators, only numbers.

     

    I'm absolutely sure that it is not related to the data access to AS database, we have only one role and everybody is the member of this role.

     

    I'm ready to submit the images of the scorecard.

     

    Plaese help.

     

    Thanks,

     

    Vlad

     

     

    Friday, October 17, 2008 6:22 PM

Answers

  •  

    Vlad,

     

    Thank you for the information.  It is not a bug.  Your users should not have to be part of the local Admin group to see the indicators.  The issue is your users do not have proper access in Dashboard designer.  Grant the users or a group of users Power Reader rights under the Server permissions in Dashbaord designer.  Or if you go to the properties tab of each element of the dashboard you can grant Read access to the group.

     

    Aseem Nayar - MSFT
    Tuesday, October 21, 2008 8:44 PM

All replies

  • Vlad,

     

    What access does the users have to the Scorecard elements in dashboard designer under the Properties tab?  Does the Nt_authority\Authenticated users group have Read rights? 

     

    Or for the Server Permissions under the the Windows symbol in the top left go to options-Server tab-connect-Permissions.

     

    Aseem Nayar - MSFT

     

    Friday, October 17, 2008 8:46 PM
  • Assem,

     

    Thanks for the quick response.

     

    I turns out that it was a security problem after all, after I added the users to a local Admin group they started seeing the indicators.

     

    Everything would be pretty straightforward if the users wasn't be able to see the scorecards at all.

    But users was able to see evrything except indicators.

    I think it is a bug.

     

    Thanks,

     

    Vlad

     

    Saturday, October 18, 2008 12:56 PM
  •  

    Vlad,

     

    Thank you for the information.  It is not a bug.  Your users should not have to be part of the local Admin group to see the indicators.  The issue is your users do not have proper access in Dashboard designer.  Grant the users or a group of users Power Reader rights under the Server permissions in Dashbaord designer.  Or if you go to the properties tab of each element of the dashboard you can grant Read access to the group.

     

    Aseem Nayar - MSFT
    Tuesday, October 21, 2008 8:44 PM
  •  

    Aseem,

     

    I agree that the users didn't have the proper access to the dashboards.

    The problem is that the users weren't  supposed to see the scorecards AT ALL, but they could see everything (all numbers) except indicators.

    I think it doesn't make sense.

    I think it is a security breach.

    Because of this behavior it was so hard to troubleshoot. If the scorecards didn't show at all or show an error message (which would a correct behavior) I would figure out the problem right away.

     

    Thanks,

     

    Vlad

    Wednesday, October 22, 2008 12:33 PM