none
OLsync problem on FIM 2010 R2 RRS feed

  • Question

  • I have been testing a manual installation of the Outlook Live Management Agent (from the OLsync installer) and I've had great luck with in on FIM 2010.  More recently we have decided to go to FIM 2010 R2.  I thought the rename process for an Outlook Live account was working, but now I get an "unexpected-error" when exporting a rename and in the application log I get Event ID 6401:

    The management agent controller encountered an unexpected error.

    "BAIL: MMS(1196): d:\bt\9394412\private\source\miis\cntrler\cntrler.cpp(12123): 0x80004001 (Not implemented)

    BAIL: MMS(1196): d:\bt\9394412\private\source\miis\cntrler\cntrler.cpp(9224): 0x80004001 (Not implemented)

    BAIL: MMS(1196): d:\bt\9394412\private\source\miis\cntrler\cntrler.cpp(8016): 0x80004001 (Not implemented)

    Forefront Identity Manager 4.1.2273.0"

    To give you a quick history of this sync engine, I did a two-step upgrade of the database from ILM-->FIM 2010-->FIM 2010 R2.  I deleted the old MAv3 Hotmail MA and did the manual installation of the Outlook Live MA.  This is running on Windows Server 2008 R2 and SQL Server 2008 R2, all virtual (VMware).

    I still have my roughly-similar OLMA configured on desktop-class hardware and FIM 2010, and I am still able to export the changes to WindowsLiveID (and other name-based attributes) from that sync engine.

    Is it possible the OLsync/OLMA code is not supported on FIM 2010 R2?  Or could I have missed something in the manual installation?  I tried doing another installation on the same FIM 2010 R2 box where I went through the process of installing a blank OLsync solution to make sure all DLLs were in place, registered, or whatever else the MSI package might do.  Then I uninstalled FIM 2010 R2 and reinstalled on top of the database I've been testing with.  No change.

    I've seen the exports succeed from FIM 2010 R2, and for a time I thought it was a problem of having the export combined with the import in the same run profile as a manually-run Export would succeed after an EDIDS run failed with the error above.  But that's not working now, either.  I've also removed export flows for Name, Alias, DisplayName and EmailAddresses and tried just flowing out WindowsLiveID (which also worked earlier today) and that is not having any positive effect now.

    Thanks for any suggestions or wisdom you can share!

    Chris

    Tuesday, August 21, 2012 9:17 PM

Answers

  • I contacted Live@edu Support.  After the case was escalated I was informed that Microsoft has not tested OLsync with R2 (and it likely won't with the conversion to Office 365 for Education in progress).

    Let this be a warning to anyone using OLsync or the OLMA contained within that trouble may lurk in an upgrade to R2.  If you installed it on FIM 2010 and then upgraded the whole works to R2...maybe you'd have a different experience but there are no guarantees.

    Chris

    Thursday, August 23, 2012 6:32 PM