none
User Policy will not copy files specified in GPO

    Question

  • Trying to get a user policy to copy files to a folder under the LocalLow folder under the user's profile. Below is what I've setup in my GPO. I've tested on a few different PCs after running gpupdate /force several times and still nothing. I've even changed the path I'm copying from to the \\servername\sysvol folder thinking it may have something to do with permissions. Below is a screenshot of my GPO settings. There are other GPs applied after this one. Not sure if they would be stopping it from applying either. **In the pic below I replaced my actual server path with \\server\path just for posting. I do have that pointed to the actual location of the source file.**

    

    Thursday, April 13, 2017 12:46 PM

All replies

  • It may seem silly, but have you tried to do it with create/replace instead of update? As far as I'm aware, update will only do something if the file already exists in the file location.

    You can also check if the GPO gets applied properly by checking gpresult on the client side.

    Thursday, April 13, 2017 12:58 PM
  • Thanks for the info. I just checked gpresult. I don't see it being applied at all. I have another setting under the same GPO that is being applied under Computer Settings, however it seems like any settings I have in this GPO under User Settings aren't being applied.

    Thursday, April 13, 2017 1:08 PM
  • > Trying to get a user policy to copy files to a folder under the LocalLow folder under the user's profile. Below is what I've setup in my GPO.
     
    Do you have a security filter on your GPO? Then check MS16-072 known issues...
     
    And use %userprofile% in your target path :-)
     
    Thursday, April 13, 2017 1:09 PM
  • > As far as I'm aware, update will only do something if the file already exists in the file location.
     
    No, unfortunately "update" will do nothing if the file already exists, but it will copy it if it does _not_ :-)
     
    Thursday, April 13, 2017 1:10 PM
  • I started with using %userprofile%, but that didn't seem to work either. At this point I think the problem is the user settings under the GPO just aren't applying for some reason. Below are the security filtering settings as well as delegation.

    Thursday, April 13, 2017 1:33 PM
  • > At this point I think the problem is the user settings under the GPO just aren't applying for some reason.
     
    The possible reason might be that the GPO is linked to an OU that contains computers only. Computers don't apply user settings :)
     
    You have to link this GPO to the users OU, too. Or move the user settings to a new GPO that you link to the users OU.
     
    Thursday, April 13, 2017 2:19 PM
  • Ok, I feel stupid now. Apparently I had users under an OU where another GPO was being applied. I'm guessing because of this, that GPO wins out totally over any other GPO's user settings, even if that GPO doesn't have a policy in affect for the setting that you selected under the OU the computer was in?


     
    Thursday, April 13, 2017 2:24 PM
  • Hi,
    As Martin said, as the setting is user settings, you should link the GPO to users' OU, it will not take effect on computer accounts which is even under the same OU.
    If GPO is not applied, you could follow the article regarding common problems causing Group Policy to not apply:
    https://social.technet.microsoft.com/wiki/contents/articles/22457.10-common-problems-causing-group-policy-to-not-apply.aspx
    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 19, 2017 1:18 PM
    Moderator