none
Internal domain DNS resolve to O365 for autodiscovery RRS feed

  • Question

  • I am having an issue with DNS setup for my internal domain resolving to my Office365 account for actions like autodiscovery, sip, etc.

    I have the domain all set properly with Office Online.  That all works.

    I have an Active Directory ( foo.com ) and integrated DNS.  So that machines that are domain joined resolve locally, and I am syncing the users into Office365.  All that works just fine.

    What is not working is when local clients (using the local DNS) are trying to resolve the Office365 Exchange or Lync service.  Autodiscovery is failing.

    I have DNS forwarders enabled.  But it is as if the resolution is failing and thus discovery for Outlook clients fails.

    If I remove the internal DNS and use any other DNS server it resolves just fine - but the local clients can't resolve any of the local machines for the other applications.

    Anyone know what needs to be done?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Wednesday, January 20, 2016 11:07 PM

Answers

  • I actually ended up sorting it out.

    In the manage domains section of Office365 admin portal.  Select the domain, then domain settings.

    Then you have a very short list of CNAME entries to copy into the local DNS as well as _srv records and the target for the MX record.

    Manually adding these records to the local DNS solved the issues.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    • Marked as answer by BrianEhMVP Wednesday, January 20, 2016 11:43 PM
    Wednesday, January 20, 2016 11:42 PM

All replies

  • I actually ended up sorting it out.

    In the manage domains section of Office365 admin portal.  Select the domain, then domain settings.

    Then you have a very short list of CNAME entries to copy into the local DNS as well as _srv records and the target for the MX record.

    Manually adding these records to the local DNS solved the issues.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    • Marked as answer by BrianEhMVP Wednesday, January 20, 2016 11:43 PM
    Wednesday, January 20, 2016 11:42 PM
  • Hi Brian,

    Thanks for your sharing and I’m glad your issue was solved.

    If you have any further questions, welcome to post in the forum.

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, January 21, 2016 1:13 AM
    Moderator