none
UAG and RD Gateway RRS feed

  • Question

  • Hi Guys!

     

    Struggeling with UAG and RDS. Published a application with help of the Technet documentation (http://technet.microsoft.com/en-us/library/dd861391.aspx) but I can not get it to work. When starting an application from the portal I get Error: "Your computer cannot connect to the remote computer because Remote Desktop Gateway server is unavailable.."

    Have also downloaded latest .chm file for UAG, but can not find any about how publish the RD Gateway with UAG in there either.

     

    Running RD Client on Win 7, Have configured RD Gateway on UAG.. 

    I have also installed hotfix: http://support.microsoft.com/default.aspx/kb/977627?p=1

     

    Thanks. J

    Tuesday, May 18, 2010 7:26 AM

Answers

  • Hi,

    Also verify that you have certificate imported in Remote Desktop Gateway manager -> Properties -> SSL Certificate.

    I have noticed that this is quite often needed although UAG should place it there, I guess.

    After that restart Remote Desktop Gateway service and it should do the trick.

    Also - note that do not use wildcard SSL certificate in this.

    BR, TommiK

    • Marked as answer by Erez Benari Wednesday, May 19, 2010 11:41 PM
    Tuesday, May 18, 2010 9:59 AM
  • Reinstalled UAG - installed Fix 1 for UAG, imported cert to RD Gateway (no other config in RD Gateway) - import apps. Now it works.
    • Marked as answer by Rufuso_12 Tuesday, June 1, 2010 7:03 PM
    Tuesday, June 1, 2010 7:03 PM

All replies

  • I had this error before, and it was my Remote Desktop Gateway Service that was not started. Ensure all the RDP related services are up and running.
    Tuesday, May 18, 2010 8:02 AM
  • Hi,

    Also verify that you have certificate imported in Remote Desktop Gateway manager -> Properties -> SSL Certificate.

    I have noticed that this is quite often needed although UAG should place it there, I guess.

    After that restart Remote Desktop Gateway service and it should do the trick.

    Also - note that do not use wildcard SSL certificate in this.

    BR, TommiK

    • Marked as answer by Erez Benari Wednesday, May 19, 2010 11:41 PM
    Tuesday, May 18, 2010 9:59 AM
  • Thanks!

    The service is started and the cert is ok.

    I am using OTP, radius by the way.

    It seems to easy to just import the apps and setup the gateway. Did you have to set any RDP Custom settings or any special authentication settings in the rd-settings or something like that?

    /J

    Tuesday, May 18, 2010 10:20 AM
  • Followed the guide you mention above.

    I did enable WebSSO by digitally signing the published RemoteApps.

    Does it tell you which Gateway server it is trying to connect to? It should use UAG as the RD Gateway server.

    Tuesday, May 18, 2010 11:45 AM
  • HI,

    The cert is there. This what i came up with:

    If i , by changing in the host file, points the host to the internal interface and connects with mstsc.exe (at the UAG) and RDG settings to antoher server it works, but if i point the hostname/rd gateway to the external nic interface then I get the same error message. The trunk is published with the external ip..

    I am using the selfsigned cert from RD Gateway in UAG - could that be a problem, would like it to get going before buying the cert?

    • Proposed as answer by superNaraen Monday, May 24, 2010 11:13 PM
    Saturday, May 22, 2010 4:32 PM
  • Reinstalled UAG - installed Fix 1 for UAG, imported cert to RD Gateway (no other config in RD Gateway) - import apps. Now it works.
    • Marked as answer by Rufuso_12 Tuesday, June 1, 2010 7:03 PM
    Tuesday, June 1, 2010 7:03 PM