locked
RPC Client Access Service starts and stops on Exchange 2010 - need HELP! RRS feed

  • Question

  • hi i have an Exchange 2010 and can not start MSExchange RPC service.

    all i gety is 

    The MS RPC Client Access service on "server" started and then stopped. Some services stop automatically if they are not in use by other services or programs.

     

    I need this service STARTED.

     

    Any help much appreciated.

    Thank you

     

    Friday, May 6, 2011 9:21 PM

All replies

  • Try solution on my blog.

     

    Microsoft Exchange RPC Client Access Service Fails to Start

    http://msexchangetips.blogspot.com/2011/02/microsoft-exchange-rpc-client-access.html

     

    When starting the Microsoft Exchange RPC Client Access Service you receive the following error:

    The Microsoft Exchange RPC Client Access Service on the local computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

    Verify if you have statically configured the RPC port and that it is a valid port in decimal and not hex format.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\
    MSExchangeRpc\ParametersSystem

    TCP/IP Port




    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Friday, May 6, 2011 9:41 PM
  • Hi Lanzi,

     

    Any updates on this issue?

     

    If the issue persists, please paste the related information you got in your Event log, with this information, we can help you more efficiently.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 9, 2011 7:26 AM
    Moderator
  • James,

    what value did you use for TCP/IP?

     

    Monday, May 9, 2011 12:48 PM
  • Exchange 2010 RPC Client Access Service

    By default the RPC Client Access service on an Exchange 2010 Client Access server uses the TCP End Point Mapper port (TCP/135) and the dynamic RPC port range (6005-59530) for outgoing connections, every time an Outlook clients establish a connection to Exchange.

    To set a static port for the RPC Client Access service on an Exchange 2010 Client Access server, you need to open the registry on the respective server and navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeRPC

    Here, you need to create a new key named ParametersSystem, and under this key create a REG_DWORDnamed TCP/IP Port. The Value for the DWORD should be the port number you want to use.

     

    Configuring static ports for the RPC Client Access service

    Note
    Microsoft recommends you set this to a unique value between 59531 and 60554 and use the same value on all CAS in any one AD site.

     

    When you’ve configured the port, it's required to restart the Microsoft Exchange RPC Client Access service in order for the changes to be applied.

    Hope it's useful to you above.

     


    Steve Xu
    Monday, May 9, 2011 1:11 PM
  • The value is up to you as long as it's in the valid dynamic RPC port range; I used 55000. You just need to ensure that it's set correctly in the registry and that there are no firewall restrictions blocking the port for client to server and server to server communication or service will fail to start.
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Monday, May 9, 2011 2:10 PM
  • After nearly 3 days of loosing pretty much all my hair - comparing my prior instance of exchange 2010 with the new one and RPC not working - this really saved my day if not my life.  My 'old' instance didn't have this parameter set and worked w/o any issues - the new instance didn't do anything w/o it.

    Thank you all!!!

    Tuesday, May 10, 2011 2:47 PM
  • Hi all,

    i actually tried to set TCP/IP Port in the registry and set the same value on the CAS server and the RPC client service still doesn't start on the mailbox server.

    :(

     

     


    ---------- Hani Lanzi
    Tuesday, May 17, 2011 2:20 PM
  • tried this, no dice!

     


    ---------- Hani Lanzi
    Tuesday, May 17, 2011 2:21 PM
  • Hi Lanzi,

     

    Could you paste the related information in your event log? With this information, we can help you more efficiently.

     

    Please make sure you have install all the latest updates for your Exchange Server, as I know, some related issue has been resolved by the updates.

     

    Thanks,

     

    Evan Liu

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 18, 2011 2:34 AM
    Moderator
  • I'm working on a similar problem on a new Exchange 2010 server.  I just migrated from SBS 2003 to SBS 2011.  Exchange RPC Client Access service does not load at startup.  If I start it manually, it remains started. So my problem appears to be a little different.  Do I still need to add this entry to the registry?

    Thanks,


    -J
    • Edited by jamichau Friday, February 3, 2012 9:26 PM
    Friday, February 3, 2012 9:12 PM
  • Ok, now it's gettin' weird. I decided to add the ParametersSystem Key and TCP/IP Port Dword to the registry.  I set the vallue to 59900.  Then I stopped the RPC Client Access service.  When I restarted the service, it immediately stopped.  Any ideas what's going on?  Why won't RPC Client Access service start automatically when I reboot the server?  Thanks,
    -J
    Friday, February 3, 2012 9:40 PM
  • It is outside the dynamic range of 6005-59530.
    Thursday, April 19, 2012 12:54 PM