locked
'Required' profile property in SSP does not appear in 'Edit Details' on MySite? RRS feed

  • Question

  • This is a strange situation for me:
    (Single Server Workgroup, Server 2008, Moss 2007 SP1)
    I've set the e-mail address profile property to be a required profile property (It might have been by default, I can't remember), but it doesn't show up in the "Edit Details" page for users logged into MySite. 
    Now, despite the fact that they don't show up, if I add data anyway to the profiles in SSP by going to SSP home > User Profiles and Properties > View Profile, they WILL show up on the edit details page of that User's Mysite when he logs in.  It appears that they are not editable by the owner of that MySite page for some reason.

    There are a number of other profile properties that do not show up on the "Edit Details" page that are in SSP as well, and they are not dependent on who is allowed to see them (Everyone, My Manager, etc.)
    Saturday, January 2, 2010 9:02 AM

Answers

  • Hi,

    If you cannot see the “Work e-mail” property in My Profile, you can go to the Shared Services Administration Home page>User profiles and properties>View profile properties>select “Work e-mail” property, click “Edit”>in the Edit User Profile Property page, in Display Settings section, make sure the option “Show in the profile properties section of the user’s profile page” is selected; after this, you can see the property in My Profile.

    If you want to edit the property in My Profile, you should select “Allow user to edit values for this property” in Edit Settings section in the page. But the “Work e-mail” property is mapped to a data source such as a property in directory services, the value is replaced with the imported value the next time user profiles are imported. For this reason, administrators typically edit only properties that are not mapped to data sources. So in My Site user profile page, you will see a warning that “Indicates a field that is updated automatically form the corporate directory. Changes to these properties may be lost.” You should edit the properties in your AD services, and then sync it to SharePoint server.

    For more information, please refer to: http://technet.microsoft.com/en-us/library/cc263051.aspx

    Hope it helps.


    Xue-Mei Chang
    Monday, January 4, 2010 6:16 AM
    Moderator

All replies

  • There are a number of options when setting up the profile fields.  In addition to the privacy settings you can set whether a property shows on the profile, shows on the edit screen, and is editable.

    Since most environments go against a full AD that data is typically synchronized from the AD Profile, giving no need for a user to edit it on their profile.  In your case I would set it to allow Edit, and to show on the Edit form.


    SharePoint Developer | Administrator | Evangelist -- Twitter -- Blog - http://nextconnect.blogspot.com
    Saturday, January 2, 2010 2:41 PM
  • Hi,

    If you cannot see the “Work e-mail” property in My Profile, you can go to the Shared Services Administration Home page>User profiles and properties>View profile properties>select “Work e-mail” property, click “Edit”>in the Edit User Profile Property page, in Display Settings section, make sure the option “Show in the profile properties section of the user’s profile page” is selected; after this, you can see the property in My Profile.

    If you want to edit the property in My Profile, you should select “Allow user to edit values for this property” in Edit Settings section in the page. But the “Work e-mail” property is mapped to a data source such as a property in directory services, the value is replaced with the imported value the next time user profiles are imported. For this reason, administrators typically edit only properties that are not mapped to data sources. So in My Site user profile page, you will see a warning that “Indicates a field that is updated automatically form the corporate directory. Changes to these properties may be lost.” You should edit the properties in your AD services, and then sync it to SharePoint server.

    For more information, please refer to: http://technet.microsoft.com/en-us/library/cc263051.aspx

    Hope it helps.


    Xue-Mei Chang
    Monday, January 4, 2010 6:16 AM
    Moderator