locked
The Excel file with documental extension "xlsm" can not be saved in SharePoint document library. RRS feed

  • Question

  • I'm trying to describe the question in detail.

    I uploaded a document named "Myfile.xlsm" into SharePoint library, when I open this document from SharePoint library, its duplicate will be downloaded automatically on my compute, so I can't save it in SharePoint website after I finished editing it.

    The file I edit is at "C:\Users\Myname\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\AP8IZPTX\Myfile.xlsm"

    but it should be at http://dev-sharepoint/Shared Documents/Myfile.xlsm.

    I want it be where it should be, what can I do to resolve it?

    Can anyone help me? Thanks.

    PS: it only happened to the office file with extension "xlsm", even "docm" is OK.

     

    Tuesday, July 26, 2011 11:22 AM

All replies

  • This issue is like if browser don't understood document opener appln then it force user to download and work but if it has it then it open document in respective appln.

    May this thread help you

    http://social.msdn.microsoft.com/Forums/en-US/sharepointadmin/thread/e3076e4a-4a0a-47cf-9f6f-0d721692c55e


    w: http://www.worldofsharepoint.com | t: @sharesandip
    Tuesday, July 26, 2011 11:51 AM
  • Maybe I didn't describe accurately. The file with extension "xlsm" could be opened with Office Excel program in my computer, but this file was downloaded in my computer instead of staying in the SharePoint Server.

    There was neither "Check out" nor "Check in", so that I wasn't able to edit it on line, I don't want it to be a local temporary file, I want it to be a file locating at the SharePoint website so that I could share it with other colleagues via SharePoint Website, and other colleagues should do it in same way.

    Wednesday, July 27, 2011 3:04 AM
  • Hi Hendiko

    Did you get any response or could you fix your problem? We're getting the same behaviour here but it's only occasional and with random office-files.

    Geetings
    Peter


    CIO Swiss Council for Accident Prevention
    Friday, November 11, 2011 1:21 PM
  • Hey

    Try to add XLSM file as trusted file location and known file extension on CA


    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Friday, November 11, 2011 6:33 PM
  • Try to set Browser File Handling to Permissive in the Web Application General Settings. (Central Administration > Web Applications > Manage web applications)
    Thursday, September 20, 2012 12:09 PM