none
NDR not sent to Admin Account for internal to External messages RRS feed

  • Question

  • Previously when an internal user sends an email to somebody outside of my organization and a delivery problem occurs the sender of the email will receive an NDR as well as the admin account that I have configured to receive copies of NDR (Exchange System Manager > Administrative Groups > SERver > Protocols > SMTP > SMTP Virtual server properties > Messages Tab > "Send copy of Non-Delivery Report to").

    As of recently the Admin account is not receiving these NDR's and I cannot figure out what changed.  Sending Internal to Internal will generate an NDR to both sender and Admin account (if a user mistypes an internal address) but if its Internal to External then only the sender receives the NDR.

    We are routing through a smart host but they state nothing has changed on their end in how they handle NDRs.

    The only thing I can think of that changed "around" the time this started happening was a Exchange 2010 Server was introduced into the environment.  There is only one user on this Exchange 2010 server as we are still configuring it.  All users are still on Exchange 2003.  I don't see how its related but the timing is within a month of when this started happening so I am just throwing it out there.

    I am at a loss for why this started happening.

    Please note:  I am not talking about sending NDRs to External domains.

    Any suggestions?
    Thursday, March 8, 2012 3:14 PM

Answers

  • So it appears that my Exchange setup is working just fine.  Because I am routing through a SmartHost my exchange server will never generate the NDR for internal to External failed messages.  Because my Exchange server never generates the NDR nothing is copied to the admin mailbox.  This makes sense now.

    The reason I was seeing intermittant NDRs for internal to external failed messages was because senders were including the "mailto" in the TO field of their Outlook email.  When the NDR is generating back is removes the MailTo and just shows the email address.  However looking through the message tracking logs you can see that MailTo is indeed part of the email address.  When you send an email to an address formatted this way it never makes it to the SmartHost and my Exchange box bounces it immediately.  Since IT is generating the NDR I will receive a copy to the admin mailbox.

    Now I just need to figure out a way to create a rule for all inbound messages that are NDRs to be forwarded to my admin box.

    Thanks all for your help.

    Thursday, March 8, 2012 7:56 PM
  • Possibly mis-read the usage of that parameter....

    For a Transport rule, I would try the following criteria:

         From  people outside the organization

         Words in subject - Undeliverable

         Copy the message to Postmaster (or admin or whoever)

    I would start with that.


    JAUCG

    Thursday, March 8, 2012 8:50 PM

All replies

  • Have you checked your messaging logs to see the path of the incoming NDR message?  I would check (if you have old enough logs) to a period before the Exchange 2010 server was introduced and see what the NDR message looked like.  Then find a more current NDR that only goes to the originator to see what it looks like.

    This article may be of assistance as well - http://support.microsoft.com/kb/821905

    Also, you may just follow this article to configure it in Exchange 2010 to see if that helps as well: http://msundis.wordpress.com/2010/04/21/configure-postmaster-microsoft-exchange-recipient-and-ndr-forwarding-in-exchange-server-2007-and-2010/


    JAUCG

    Thursday, March 8, 2012 4:19 PM
  • For the time being, create a transport rule to forward all NDR to admin and continue the investigation

    Regards from www.windowsadmin.info | www.blog.windowsadmin.info

    Thursday, March 8, 2012 4:47 PM
  • I can find the old NDRs in my message tracking logs but none of my recent test messages.  

    As for the blog article, I believe I have the internal portion set up correct as when I send a test message to a fake internal recipient the sender (myself) AND the admin account both receive the NDR.   I have tested this with users who have mailboxes on Exhange 2003 and the Exchange 2010 server and both NDRs come to the sender as well as the admin account.  

    The NDR does not get copied to the admin account when the message is Internal User to External user (For Example: user1@mydomain.com sending a message to externaluser@gmail.com).  The 

    The blog article also mentioned setting up DSN codes to monitor.  What was interesting was when setting up the DSN codes was that all articles I found state, "To save you some work, Microsot has enabled monitoring for the following DSNs" with a list of DSN codes.  None were listed in my setup. I had to manually enter ALL DSN codes by hand.  This note also states that this affects the entire organization not just the individual Transport Server.  I wonder if this is somehow related.  I am going to remove all NDRs that I entered and see if that affects anything.

    Thanks for your ideas!



    Thursday, March 8, 2012 5:59 PM
  • How do you configure a rule specifically for NDR?  Would I just trap off keywords?

    Thursday, March 8, 2012 5:59 PM
  • In my post, the second link takes you to a short and simple explanation of how to do this or you can look at Microsoft article - http://technet.microsoft.com/en-us/library/bb400930(v=exchg.80).aspx - that applies to Exchange 2007 but if you look here - http://technet.microsoft.com/en-us/library/bb430759.aspx - the parameters are the same in Exchange 2010.


    JAUCG

    Thursday, March 8, 2012 7:19 PM
  • So it appears that my Exchange setup is working just fine.  Because I am routing through a SmartHost my exchange server will never generate the NDR for internal to External failed messages.  Because my Exchange server never generates the NDR nothing is copied to the admin mailbox.  This makes sense now.

    The reason I was seeing intermittant NDRs for internal to external failed messages was because senders were including the "mailto" in the TO field of their Outlook email.  When the NDR is generating back is removes the MailTo and just shows the email address.  However looking through the message tracking logs you can see that MailTo is indeed part of the email address.  When you send an email to an address formatted this way it never makes it to the SmartHost and my Exchange box bounces it immediately.  Since IT is generating the NDR I will receive a copy to the admin mailbox.

    Now I just need to figure out a way to create a rule for all inbound messages that are NDRs to be forwarded to my admin box.

    Thanks all for your help.

    Thursday, March 8, 2012 7:56 PM
  • Not to sound like a broken record, but have you tried setting the 'ExternalPostmasterAddress'?

    JAUCG

    Thursday, March 8, 2012 8:31 PM
  • If I am not mistaken the ExternalPostmasterAddress is used to send NDRs to external domains. This is not what I want.

    Thursday, March 8, 2012 8:35 PM
  • Possibly mis-read the usage of that parameter....

    For a Transport rule, I would try the following criteria:

         From  people outside the organization

         Words in subject - Undeliverable

         Copy the message to Postmaster (or admin or whoever)

    I would start with that.


    JAUCG

    Thursday, March 8, 2012 8:50 PM
  • That looks like it might just to the trick.  Thanks JAUCG!

    Thursday, March 8, 2012 8:52 PM
  • Did you get a chance to test it out?  If it works, please mark the post as answered.  Thanks.

    JAUCG

    Friday, March 9, 2012 2:15 PM
  • Your Transport rule suggestion worked great.  Thank you for your assistance.

    Friday, March 9, 2012 2:20 PM