none
FIM/AD SYNC RRS feed

  • Question

  • Hello There,

    We are AD as an authorative source using which we are pushing user in FIM  portal, but there are  few users for whom "country" attribute is coming with value "-1". However this attribute is having value in AD (like India).. We have  import sync rules defined in portal.

    I have chekced in the AD connector space and there as well i have noticed value is coming as "-1" . Kindly suggest.

    Regards,

    Suman Baurai

    Tuesday, July 26, 2016 2:43 PM

All replies

  • When you say "country" what's the attribute name in connector space? C or CO?

    Can you also run this in a PowerShell session that has AD modules for a user whose country shows as -1 and show us the result

    Get-ADUser userID -pr country, c, co, countrycode


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Tuesday, July 26, 2016 3:43 PM
  • Hello,

    The connector space attribute name is co.

    Below is the result of the power shell script.

    

    Regards,

    Suman

    Wednesday, July 27, 2016 9:31 AM
  • Hello Suman,

    But as you mentioned already - your authoritative source is AD, so as long you'd have "-1" in co attribute in AD, it would be the same in FIM Portal. So you should try to trace, what has set co as "-1".

    You can verify for example a tool that your company uses to create new account as it seems that in some cases it returns "-1" instead of the value.


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Wednesday, July 27, 2016 10:10 AM
  • Yup but AD accounts are created manually here.

    Regards,

    Suman

    Wednesday, July 27, 2016 11:41 AM
  • Suman,

    If the user in AD has co as -1, then there is no surprise that he comes as -1 in FIM.

    For such user, can you try to change the country in AD to something like India, then change it back to US. Does that fix the co attribute? if it does, I suggest you run a small code to fix the co attribute for your AD users. Let me know if you need help with that.


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Wednesday, July 27, 2016 1:42 PM
  • Hello,

    I have noticed that co attribute which is used in connectoe space is having value "-1".

    However the "country" field has the reqiured value "United states". Please see screen shot below.

    Can you please tell me one thing is their any difference between the two attributes("co" and "country").

    Wednesday, July 27, 2016 2:50 PM
  • This might be useful

    https://social.technet.microsoft.com/Forums/office/en-US/827c4208-834f-4248-b995-51e88c0ee68c/setaduser-update-countryregion-attribute-field-in-aduc?forum=winserverpowershell

    Country in ADUC is used to update different attribute in AD.


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Wednesday, July 27, 2016 3:09 PM
  • Hello,

    I went through the link you have shared.

    But here accounts are created manually using GUI and value is assigned to "country" field.

    And still there are some users for whom co is "-1".

    Regards,

    Suman

    Thursday, July 28, 2016 11:24 AM