locked
Flash Drive not recognized? RRS feed

  • Question

  • Hi:

    As a preface, FYI, my autoplay is turned off.

    I recently discovered that my usb connected flash drive was not accessible via My Computer.  I googled the problem and was led to Disk Management.  In Disk Management's Diskeeper, the flash drive is listed and is healthy.  In a google fix, the instructions were to change the drive letter, etc. but that hasn't worked. 

    To sum up, the flash drive appears in Device Manager, Disk Management but not recognized in My Computer.

    Am I not using Disk Management properly?


    • Edited by papaboy Friday, March 2, 2012 3:40 PM
    Friday, March 2, 2012 3:30 PM

Answers

  • Hi Again Chris:

    I found the solution thru a friend who has assisted me with other problems in the past.  As a full time worker, he can help only in his spare time which is why my problem was not resolved earlier.

    I want to thank you so very much for hanging in there with me.  A thank you also to h9ck3r.  The solution is a fix for Autoplay:

    http://www.microsoft.com/download/en/details.aspx?id=2648

    One more question;  how do I end this thread and insure that this fix is publicized on the forum?

    • Proposed as answer by Techie Smurf Thursday, March 8, 2012 6:19 PM
    • Marked as answer by papaboy Friday, March 9, 2012 1:58 PM
    Thursday, March 8, 2012 4:23 PM

All replies

  • Is the drive detected when you plug it into another computer?
    Monday, March 5, 2012 3:06 AM
  • try opening device manager and right at the computer name and select "Scan for Hardware changes". Tell me if any window is prompted for driver installation.


    Regards, h9ck3r.

    Monday, March 5, 2012 8:55 AM
  • Yes.
    Monday, March 5, 2012 1:14 PM
  • No prompts.
    Monday, March 5, 2012 1:14 PM
  • It's possible this is a registry issue. I've seen and resolved similar issues with CD drives having the same problem. Try running the Microsoft Fix It utility on the following page and let us know if it works.

    http://support.microsoft.com/kb/925196


    Tuesday, March 6, 2012 7:23 AM
  • Hi Chris:

    I tried this fix before and again now with no positive results.  Most everything on FixIt is specific to cd/dvd drives.  I do want to thank you for your help.

    Tuesday, March 6, 2012 2:23 PM
  • From another computer, can you try copying the data off the drive, reformat the flash drive, then move the data back. Afterwards, see if it will be detected by the computer.
    Tuesday, March 6, 2012 3:32 PM
  • If that works, should I do the same with the external HD?

    Tuesday, March 6, 2012 4:57 PM
  • You never mentioned an external HD. I would just try it with the flash drive first. If that doesn't work, you can try to remove and reinstall the USB controllers on the computer. If that doesn't work, it probably wouldn't hurt to install all the necessary updates for Windows XP, as well as any manufacturer updates for your computer.
    Tuesday, March 6, 2012 8:23 PM
  • Sorry about that.  I've allready done that. 
    Tuesday, March 6, 2012 8:42 PM
  • hi,

    Try clearing the entries in the MountedDevices key in the Registry:
    HKLM\SYSTEM\MountedDevices

    This key is basically a database of all the mounted devices on the machine, including the partitions or mapped drives, etc.

    You will find a number of entries like \??\Volume......... These correspond to external disks, flash drives etc that you've plugged in to your system. Although it's mainly a lot of random characters, sometimes looking at the value (double-click the entry) will allow you to know which device it corresponds to since part of the manufacturer name might be recognisable. If you find the entry for this specific flash drive, delete it. If you cannot identify it, delete all of them. Do not touch the ones that have drive letters, and make a backup of the key first (right-click MountedDevices, Export, save as reg file). In case anything goes wrong you can just import it back.

    MountedDevices

    cheers,


    hope this helps,
    David
    :: Please remember to vote if the info helped you :: Please post back so everyone can benefit from the solution ::

    Thursday, March 8, 2012 2:42 AM
  • Hi Again Chris:

    I found the solution thru a friend who has assisted me with other problems in the past.  As a full time worker, he can help only in his spare time which is why my problem was not resolved earlier.

    I want to thank you so very much for hanging in there with me.  A thank you also to h9ck3r.  The solution is a fix for Autoplay:

    http://www.microsoft.com/download/en/details.aspx?id=2648

    One more question;  how do I end this thread and insure that this fix is publicized on the forum?

    • Proposed as answer by Techie Smurf Thursday, March 8, 2012 6:19 PM
    • Marked as answer by papaboy Friday, March 9, 2012 1:58 PM
    Thursday, March 8, 2012 4:23 PM