none
Blank Attachments on internal Emails RRS feed

  • Question

  • Hello,

    We use a document management system to store and view work related emails, the emails are stored as .eml files. Within the document management system we can email files as attachments to whoever. When we select a .eml file to email as an attachment, the .eml files arrive blank for internal users. However if we send the same .eml file to an external email they arrive fine. If we then forward this email from the external email address to an internal one the .eml file is blank.

    As internal emails are not passed through our filtering and archiving programs I'm led to believe this is something to do with Exchange 2007. What could be causing Exchange to blank .eml files sent to internal emails addresses? The .eml files are completely blank with no header information or body.

    Wednesday, May 18, 2011 12:32 AM

All replies

  • Hi,

     

    How do you opened the .EML file, with Outlook or OWA?

    What’s the size of the attachment if you save it on your computer?

     

    Could you please try the following workaround?

    1. Open the EML file with Notepad.

    2. Save it locally, and try to open it.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, May 19, 2011 9:51 AM
  • I am opening it with Outlook 2007.

     

    When I save the file, it saves it as a .msg file that is 198 bytes. If i open this file with notepad I get the following:

     

    ÐÏࡱá                >  þÿ                               þÿÿÿ       ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿR o o t   E n t r y                                               ÿÿÿÿÿÿÿÿ                               °bSoýÌ          _ _ p r o p e r t i e s _ v e r s i o n 1 . 0                   0  ÿÿÿÿÿÿÿÿÿÿÿÿ                                       à      _ _ n a m e i d _ v e r s i o n 1 . 0                           ( ÿÿÿÿÿÿÿÿ                       °ñPoýÌ°ñPoýÌ            _ _ s u b s t g 1 . 0 _ 0 E 0 4 0 0 1 F                         * ÿÿÿÿÿÿÿÿÿÿÿÿ                                    þÿÿÿ           ýÿÿÿÿÿÿÿÿÿÿÿ      

       þÿÿÿ     þÿÿÿþÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿR o o t   E n t r y                                               ÿÿÿÿÿÿÿÿ  

         À      F            °bSoýÌ          _ _ p r o p e r t i e s _ v e r s i o n 1 . 0                   0  ÿÿÿÿÿÿÿÿÿÿÿÿ                                       à      _ _ n a m e i d _ v e r s i o n 1 . 0                           ( ÿÿÿÿÿÿÿÿ                       °ñPoýÌ°ñPoýÌ            _ _ s u b s t g 1 . 0 _ 0 E 0 4 0 0 1 F                         * ÿÿÿÿÿÿÿÿÿÿÿÿ                                    þÿÿÿ        ÿÿÿÿÿÿÿÿ   ýÿÿÿ      

       þÿÿÿ     þÿÿÿþÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ_ _ s u b s t g 1 . 0 _ 0 E 0 3 0 0 1 F                         *    

       ÿÿÿÿ                                    þÿÿÿ        _ _ s u b s t g 1 . 0 _ 0 E 0 2 0 0 1 F                         *  ÿÿÿÿÿÿÿÿÿÿÿÿ                                    þÿÿÿ        _ _ s u b s t g 1 . 0 _ 0 0 1 A 0 0 1 F                         *       ÿÿÿÿ                                              _ _ s u b s t g 1 . 0 _ 0 0 7 1 0 1 0 2                         *  ÿÿÿÿÿÿÿÿÿÿÿÿ                                              _ _ s u b s t g 1 . 0 _ 0 0 7 D 0 0 1 F                         *       ÿÿÿÿ                                       Z       _ _ s u b s t g 1 . 0 _ 0 E 2 7 0 1 0 2                         *    ÿÿÿÿÿÿÿÿ                                    

       p       _ _ s u b s t g 1 . 0 _ 1 0 0 0 0 0 1 F                         *      ÿÿÿÿ                                    þÿÿÿ        _ _ s u b s t g 1 . 0 _ 1 0 0 9 0 1 0 2                         * ÿÿÿÿÿÿÿÿÿÿÿÿ                                       ‰       _ _ s u b s t g 1 . 0 _ 1 0 1 3 0 1 0 2                         *       ÿÿÿÿ                                       7      _ _ s u b s t g 1 . 0 _ 1 0 F 3 0 0 1 F                         *  ÿÿÿÿÿÿÿÿÿÿÿÿ                                              _ _ s u b s t g 1 . 0 _ 3 0 0 B 0 1 0 2                         * 

          ÿÿÿÿ                                               _ _ s u b s t g 1 . 0 _ 0 0 0 2 0 1 0 2                         *  ÿÿÿÿÿÿÿÿÿÿÿÿ                                    þÿÿÿ        þÿÿÿþÿÿÿ            þÿÿÿ     þÿÿÿ   þÿÿÿ

       þÿÿÿþÿÿÿþÿÿÿ                     þÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿHáÛì÷{˜I{°›¾ø²                                                N o   S u b j e c t . E M L                                     <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">

    <HTML>

    <HEAD>

    <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">

    <META NAME="Generator" CONTENT="MS Exchange Server version 08.03.0145.000">

    <TITLE></TITLE>

    </HEAD>

    <BODY>

    <!-- Converted from text/plain format -->

     

    </BODY>

    </HTML>         …     LZFu! !´ 

     rcpg125"2CtexBbiþd 0÷

    €¤äÿ€s PVU²¥'Q ch

    ÀseÜt2 Ã¥3F7Þ0¬³ï ÷;Ÿ0v5¢ `c P d3&6Ð ¦ }€                                                              /Œ0   L                ¿                 íBhcª=ChGH’q          íBhcª=ChGH’                  M I M E - V e r s i o n :   1 . 0 

     

     C o n t e n t - T y p e :   t e x t / p l a i n 

     

                                           ÌíaÜÚŠ®®ÆC¡âœRï–9H                                          I P M . N o t e                                                 _ _ s u b s t g 1 . 0 _ 0 0 0 3 0 1 0 2                         *       ÿÿÿÿ                                    þÿÿÿ        _ _ s u b s t g 1 . 0 _ 0 0 0 4 0 1 0 2                         *  ÿÿÿÿÿÿÿÿÿÿÿÿ                                    þÿÿÿ                                                                            ÿÿÿÿÿÿÿÿÿÿÿÿ                                                                                                                    ÿÿÿÿÿÿÿÿÿÿÿÿ                                                                                @ 0   °ñPoýÌ@ 0   °ñPoýÌ ÷         e  ô      e r  

    4   y p e                                                       6            q        C

     }    \       Æe                      ý?   ä                 '   p    C

    b                          ‰    C

       7   C

     ó         ô           õ           ö            0       C

     Þ?   ŸN                                                                                                                                                                                                                          

    Monday, May 23, 2011 3:59 AM
  • So I suggest you check the following options:

    1. Run this command: Get-AttachmentFilterEntry |fl

    I am sure the .eml file is in the attachment filter.

    Exchange will take the following actions if the attachment in the filter list.

    a. Block whole message and attachment

    b. Strip attachment but allow message through

    c. Silently delete message and attachment

    You could remove it from the attachment filter on both Hub server and Edge transport server.

    Remove-AttachmentFilterEntry

    More information:

    Configure Attachment Filtering

     

    If you installed Forefront, you also need to check the file filter on Forefront.

    Understanding Attachment Filtering


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 24, 2011 2:16 AM
  • We currently do not have the attachment filter turned on.
    Tuesday, May 24, 2011 4:11 AM
  • As I know, Exchange can only filter attachment on hub transport server, edge transport server and OWA virtual directory  configuration. Because Outlook come across the issue, so I think it is not due to the OWA direct file access.

    As you mentioned, you haven’t enable attachment filter. So I think this is not caused by Exchange server.

    Did you install any third party e-mail filter software?

    Did all the uses come across the issue?

    Are you able to open the .EML file via OWA?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 25, 2011 1:34 AM
  • Hi Jerome,

    I cannot access the file via OWA, it produces the same results. We have 3rd party filtering software however it doesn't scan or filter internal emails, which is where we are having the problem. If I send the file to external email address  and it does pass through the filtering software it arrives fine. So even if the filtering software did scan internal emails I'd be led to believe it wasn't the problem. It is effecting all users. All our Exchange Server roles are installed on the same server.

    Wednesday, May 25, 2011 1:45 AM
  • Hi,

     

     

    If this is possible?

    The 3rd party filtering software scans internal E-mail not external E-mail?

    I suggest you check the configuration again.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 25, 2011 2:18 AM
  • Hi Jerome,

    The 3rd party filtering software does not filter internal mail as it sits between the Exchange server and the internet. However I don't think it would be the issue as these files pass through it and appear in external mail boxes fine.

    Friday, May 27, 2011 6:00 AM