locked
Get-ADPrincipalGroupMembership -Server "localhost:60000" didn't work RRS feed

  • Question

  • Hello everyone,

    Recently I wanted to extract from an AD Snapshot some information (Member Of groups) for one particular user with Get-ADPrincipalGroupMembership cmdlet, but it seems that -Server parameter didn't work, in order to access AD Snapshot instance.

    Running the ntdsutil and dsamain cmdlets, I successfully mapped and explored the AD Database via Active Directory User and computers Console:

    But when I tried to extract specific information via PowerShell script I revived errors. 

    I wanted to run Get-ADPrincipalGroupMembership to get all groups that user "jony" was member of.

    Here you can find user information:

    Bellow you can see the examples for this command:


    And here are errors that I encountered on PowerShell console :

    First one with -partition parameter

    Get-ADPrincipalGroupMembership -Identity "CN=jony,OU=Users,OU=ProService,DC=proservice,DC=local" -Server "localhost:60000" -Partition "dc=proservice,dc=local"

    And second one without -Partition parameter

    Get-ADPrincipalGroupMembership -Identity "CN=jony,OU=Users,OU=ProService,DC=proservice,DC=local" -Server "localhost:60000" #-Partition "dc=proservice,dc=local"

    As you can see from first images, I already connect to Snapshot AD via MMC console and from GUI it seems to work's fine, but I wanted to extract this information from powershell using -server parameter. 

    Any help would be highly appreciated. Thank you!



    • Edited by Ionut Sandu Thursday, September 7, 2017 1:25 PM
    Thursday, September 7, 2017 1:23 PM

Answers

  • Have you tried just

    Get-ADPrincipalGroupMembership -Identity USERNAME


    • Edited by I.T Delinquent Thursday, September 7, 2017 1:32 PM
    • Proposed as answer by jrv Thursday, September 7, 2017 4:23 PM
    • Marked as answer by Richard MuellerMVP Thursday, September 14, 2017 1:53 PM
    Thursday, September 7, 2017 1:32 PM