locked
Error in DelegateControl: "Name cannot begin with the ' ' character" RRS feed

  • Question

  • Hi,


    We have a number of SP sites and some of these sites give the "An unknown error has occurred" issue. Viewing the log file, I saw this error:

    "Name cannot begin with the ' ' character, hexadecimal value 0x20. Line 14, position 58."

    When I opened the sites' master page (default.master) in SharePoint Designer, I noticed that the error is showing up in all Sharepoint:delegatecontrol controls.

    We are running MOSS 2007 on MS Windows Server 2003 R2.

    Can anyone point me to where I should start looking for this "Line 14, position 58" that SP says is causing this issue?

    Any help is greatly appreciated.

    Thanks,

    Edgar


    • Edited by PinoyEdge Tuesday, October 25, 2011 3:03 AM
    Tuesday, October 25, 2011 3:03 AM

All replies

  • HI,

    Open any one page where you are facing this error in SPD and navigate to the position as mentioned to find out the issue.

     


    Thanks, Rahul Rashu
    Tuesday, October 25, 2011 11:53 AM
  • Hi Rahul,

    Thanks for your reply. I already checked it and can't find anything wrong with the mark-up of the default.master page.

    To give more background on the issue, we have a similar site on another server and we don't have any problem with the second site.

    I think the problem might be connected with the control templates (?) that is being used by the first (problematic) site. I am not sure about this as I just inherited this problem recently.

    Any idea on which template/configuration/settings/etc file should I check?

    Thursday, October 27, 2011 2:49 AM