locked
Android Setting up mail requires a client certificate RRS feed

  • Question

  • I have just got a new Asus ZenFone 2 and trying to add an Exchange account to the built-in Email app. My Exchange Server is Office 365.

    After entering Email address, Password and Server (https://outlook.office365.com/mapi/emsmdb/?Mailbox=....a-long-guid....), it insists on a Client certificate.  Where do I get this Client certificate?  When I touch Select, it says:

    Choose certificate

    The app Email has requested a certificate.  Choosing a certificate will let the app use this identity with servers now and in the future.

    You can install certificates from a PKCS#12 file with a .pfx or a .p12 extension located in external storage.

    What is going on here?

    Thanks.

    Monday, April 27, 2015 7:49 AM

Answers

  • I solved it by ignoring it.

    Previously, I couldn't proceed as the Next button was disabled.  I found that it was disabled because the server name is given in the wrong format.  I got the https://outlook.office365.com/mapi/emsmdb/?..... version from the configuration dialog in my desktop Outlook set up.

    The proper way to enter the Exchange server for Office 365 is simply outlook.office365.com!

    • Marked as answer by K.Kong Tuesday, April 28, 2015 8:51 AM
    Tuesday, April 28, 2015 8:41 AM

All replies

  • I solved it by ignoring it.

    Previously, I couldn't proceed as the Next button was disabled.  I found that it was disabled because the server name is given in the wrong format.  I got the https://outlook.office365.com/mapi/emsmdb/?..... version from the configuration dialog in my desktop Outlook set up.

    The proper way to enter the Exchange server for Office 365 is simply outlook.office365.com!

    • Marked as answer by K.Kong Tuesday, April 28, 2015 8:51 AM
    Tuesday, April 28, 2015 8:41 AM
  • I try with same name but it's not working. either  we choose SSL connection it's give us error user name password is incorrect but same credentials working fine with other place or with SSL gave us error connection not open.

    So what the issue it's issue of Exchange server or android OS. before that it's working fine with my Samsung phone(on kitkat OS) 

    Friday, October 16, 2015 12:20 PM