none
Can summary tasks be prevented from toggling to "Manual Scheduled" Task Mode? RRS feed

  • Question

  • Hi gang,

    Can summary tasks be prevented from toggling to "Manual Scheduled" Task Mode?  I am using MS Project 2013 Professional, and have the Task Mode defaulted to "Auto Scheduled" for new tasks, and noticed that if I "accidentally" enter some text in the summary task's Duration field that the text gets accepted and the Task Mode for that Summary Task toggles to "Manual Scheduled".

    Perhaps should be my 1st question, is this normal behaviour?

    Thanks in advance


    \Spiro Theopoulos, Montreal, QC (Canada)

    Monday, April 13, 2015 6:36 PM

Answers

  • Spiro,

    I can confirm the same behavior you are seeing. I am not sure of the design decision based on this, and I do not think there is way to lock summary tasks to be always Autop Scheduled. Sorry!


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Monday, April 13, 2015 7:21 PM
    Moderator
  • Spiro,

    I am afraid there is no way to avoid this happening. I guess the purpose is to implement top-down planning, but at least, I would expect Project to display a warning message before changing the mode. Even you overwrite the same duration amount, the task mode is "automatically" changed to manual in a summary task. IMO, the best way is to keep the Task Mode column in the table and check AutoFilter to see whether there is any manual summary task/task or not.  

    Regards,

    Ismet



    Monday, April 13, 2015 7:37 PM
  • Spiro --

    To confirm what the others have already correctly stated, you are seeing the default behavior of Task Mode in either Microsoft Project 2010 or 2013.  When you manually enter data in the Duration, Start, or Finish fields for a summary task, Microsoft Project will ALWAYS change the Task Mode setting for the summary task to Manually Scheduled.  There is no way to change this behavior, or to prevent this from happening.  Therefore, I would strongly recommend that you tell your PMs to NEVER type schedule data for a summary task because of this consequence.  Hope this helps.


    Dale A. Howard [MVP]

    Monday, April 13, 2015 7:53 PM
    Moderator

All replies

  • Spiro,

    I can confirm the same behavior you are seeing. I am not sure of the design decision based on this, and I do not think there is way to lock summary tasks to be always Autop Scheduled. Sorry!


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Monday, April 13, 2015 7:21 PM
    Moderator
  • Spiro,

    I am afraid there is no way to avoid this happening. I guess the purpose is to implement top-down planning, but at least, I would expect Project to display a warning message before changing the mode. Even you overwrite the same duration amount, the task mode is "automatically" changed to manual in a summary task. IMO, the best way is to keep the Task Mode column in the table and check AutoFilter to see whether there is any manual summary task/task or not.  

    Regards,

    Ismet



    Monday, April 13, 2015 7:37 PM
  • Spiro --

    To confirm what the others have already correctly stated, you are seeing the default behavior of Task Mode in either Microsoft Project 2010 or 2013.  When you manually enter data in the Duration, Start, or Finish fields for a summary task, Microsoft Project will ALWAYS change the Task Mode setting for the summary task to Manually Scheduled.  There is no way to change this behavior, or to prevent this from happening.  Therefore, I would strongly recommend that you tell your PMs to NEVER type schedule data for a summary task because of this consequence.  Hope this helps.


    Dale A. Howard [MVP]

    Monday, April 13, 2015 7:53 PM
    Moderator
  • Keep the task mode column in view, watch out for the different coloured/shaded bars, catch any that get changed from auto to manual, but best of all do not type in dates or durations to summaries.
    Tuesday, April 14, 2015 12:19 AM