none
SCCM 1606 creating Enterprise Sites XML list for Edge. How do I disable it? RRS feed

  • Question

  • I was trying to figure out why Edge wasn't processing my user group policy for "Configure the Enterprise Site Mode List" for Edge. Digging thru the registry I found I had machine policy being applied but it wasn't from group policy it was the SCCM agent.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\Main\EnterpriseMode]
    "SiteList"="C:\\WINDOWS\\CCM\\MSEdgeSiteList.xml"

    Then I noticed entries in my SoftwareCataloUpdateEndpoint.log:

    Created Microsoft Edge Site List file 'C:\WINDOWS\CCM\MSEdgeSiteList.xml' with version 874

    In my site client settings > Computer Agent I do not have "Add default App Catalog website to IE trusted sites zone" or "Allow Silverlight apps to run in elevated trust mode." enabled.

    So I'm wondering - is this just a Windows 10 SCCM agent thing? and how do I stop it? Right now I can't apply my user group policy because this appears to trump it.

    Tuesday, December 6, 2016 7:09 PM

All replies


  • What does UpdateTrustedSites.log show?
    Tuesday, December 6, 2016 7:50 PM
  • Here you go:

    Starting UpdateTrustedSites with FALSE http://SERVERNAME:80/CMApplicationCatalog ***SID*** UpdateTrustedSites 12/6/2016 3:00:49 PM 15316 (0x3BD4)
    AddDefaultPortalToTrustedSites: Existing URL is empty or add to trusted sites is true and the default URL hasn't changed. Not deleting the existing URL from trusted sites list. UpdateTrustedSites 12/6/2016 3:00:49 PM 15316 (0x3BD4)
    AddDefaultPortalToTrustedSites: It was determined that catalog Url should not be added to the trusted sites zone. UpdateTrustedSites 12/6/2016 3:00:49 PM 15316 (0x3BD4)
    AddDefaultPortalToTrustedSites: Existing URL is empty. UpdateTrustedSites 12/6/2016 3:00:49 PM 15316 (0x3BD4)
    AddDefaultPortalToTrustedSites: It was determined that catalog Url should not be added to the trusted sites zone. UpdateTrustedSites 12/6/2016 3:00:49 PM 15316 (0x3BD4)

    Tuesday, December 6, 2016 8:17 PM
  • can't see anything obviously related to this in the client settings documentation for CMCB.

    are you using 'the new software center' ?

    can't find any search hits on connect for this either, but maybe you should log a bug there for this?

    https://connect.microsoft.com/ConfigurationManagervnext/Feedback

    I'm not using CMCB just yet, but this would be a problem for us, since we have a big investment in EMIEsitelist and not having our EMIEsitelist would be a dealbreaker for us..


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Wednesday, December 7, 2016 8:41 AM
  • Just found out we have the same issue, SCCM 1606, Windows 10, user-GPO to set enterprisemodelist.xml, and "new software center" enabled. If we would set the Enterprise mode list xml in computer settings instead of user settings, I wonder what will be written to the registry key since both the GPO and the SCCM-agent wants to set the registry value?
    Thursday, December 8, 2016 10:41 AM
  • Moved the GPO-setting from User to Computer, ran gpupdate /force from elevated command prompt, which replaced the SCCM-value, then ran SCCM-cycles and later found the line "Microsoft Edge Enterprise List is already configured outside of Configmgr client. No changes will be made." in SoftwareCatalogUpdateEndpoint.log. So, if we use Computer-settings, SCCM Client will leave the registry value alone and not overwrite it. But it would have been nice to set the setting in User-side of GPO instead of Computer..

    Thursday, December 8, 2016 1:38 PM
  • Thanks for the feedback. I submitted the bug. Looks like I'm applying that via Computer Policy for now.

    https://connect.microsoft.com/ConfigurationManagervnext/Feedback/Details/3115112

    Thursday, December 8, 2016 1:47 PM
  • Thanks for the feedback. I submitted the bug. Looks like I'm applying that via Computer Policy for now.

    https://connect.microsoft.com/ConfigurationManagervnext/Feedback/Details/3115112

    You were also using User Policy for the EMIEsitelist?

    Looks like I should be ok when we move to CMCB, we only use EMIEsitelist via Computer Policy not User Policy.


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Thursday, December 8, 2016 8:42 PM