sbs 2011 can't backup due to semaphor wait time


  • Hi, my sbs 2011 standard doesn't want to perform a backup anymore.

    The log tells (in French): "Impossible de créer l'un des fichiers de sauvegarde. Le délai de temporisation du sémaphore a expiré".

    Translation: "unpossible to create one of the backup files. The semaphore wait time expired".

    The external hdd is 1.8Tb, only 320Gb are used on the server.

    Tried applying updates, reboot, no change.

    Does someone know how to fix that?

    Alain Bourgeois

    Sunday, July 28, 2013 4:21 PM


All replies

  • Bonjour Alain:

    Additional information please.  Do you have more than one external drive?  Do they all behave this way?  I fear the drive in question may be failing, but is there anything else that has changed?  For example, the addition of additional internal storage? 

    Please try with a new external drive and a new cable, using a different USB port.  Verify you can format the drive and copy files to and from.

    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Monday, July 29, 2013 12:51 AM
  • There is only one disk.

    I don't have any other "officially supported" external disk (a few disks are recognized by the sbs 2011). It has worked for ~1 year, and sbs "sees" the drive. The backups cannot be taken for 2 weeks. If there is a drive failure, is there any tool to check it?

    Also, this server will be re-formatted (customer changes the domain name). I tried to virtualize it before reformatting (just to keep it running until the end of the migration) using vmware. Curiously, after copying nearly the whole contents, vmware stops for an "unexpected error".

    I'm afraid that backup and virtualization fail for the same reason, not due to external hdd.

    There are 2 internal hdd's in raid-1, so internal hdd shouldn't be the cause.

    Is there any event viewer that could give a better explanation?

    I saw an event id 8230:

    "Opération : Rassembler l’état des rédacteurs Opération asynchrone en cours d’exécution Contexte : État actuel: GatherWriterStatus Détails de l’erreur : Erreur: NetLocalGroupGetMemebers(spsearch), 0x80070560, Le groupe local spécifié n’existe pas. "

    I don't know if related or not.

    Any hint?

    Alain Bourgeois

    Monday, July 29, 2013 5:57 PM
  • at the date & time of the backup, I have:

    the eventIDs 8230 9782 2007 517 (and in 517 error code is 2155348010)

    Alain Bourgeois

    Monday, July 29, 2013 6:26 PM
  • This thread talks about it and it seems there are "known problems" with sbs backup.

    Alain Bourgeois
    • Edited by Alain Bourgeois Monday, July 29, 2013 6:57 PM add link to thread
    Monday, July 29, 2013 6:35 PM
  • Agreed that thread, started in October 2009 discusses the various issues that can arise using unsupported media, but those issues in one form or another have been a part of all computing issues since they were first developed.  MS even has/had an entire department given over to testing various componenets and giving it blessing on the HQL lists.

    But your drive did work for several months, so it is not the sector size.  To preserve the contents of the RAID, remove one of the drives and replace with a new one, or better, remove both and start fresh with new drives.  Depending on their age this would add some life into the system.

    As for the backup drives... you should have at least two, and I prefer three.  That way one is always out of the building when the others are being switched over.  Here is a list of known good drives.

    But I make my own with an external case and a quality drive.  Longer warranties and if the case dies they are very inexpensive.. under 40 USD.

    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Monday, July 29, 2013 11:06 PM
  • Sir,

    for info: I made tests.

    1. the backup drive used is a Seagate expansion external 2Tb and is supported. I made several checks on it (chkdsk, copy, ...) and the disk is fine!

    2. I made a check of the raid on the server (the server is only one year old, it is a dell PowerEdge T410 with hardware raid-1). The internal disks of the server are also fine, no error was detected.

    According to me the problem is not due to disks (nor external, nor internal) nor the hardware. The only problem is Windows SBS 2011 that is, according to me, bugged.

    Alain Bourgeois

    Tuesday, July 30, 2013 4:12 PM
  • Alain:

    While there are a reasonable ( or unreasonable <g>) number of cases where SBS backup has not been 100 percent successful, this is also true for any computer utility.  In the vast number of cases that we see involving SBS backup it is related to the target drive or the VSS writers.

    I encourage you to try a different drive, cable, usb port/adapter.  Run the SBS backup wizard again.  Search the net for the bat/cmd file to register the VSS writers.  There is a much higher probability that something else besides the SBS script or Server Backup utility is the root cause of your backup failures.

    Of course the script and utility that drives the backup could be corrupted. You might try System File Checker or System Repair as well.

    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Wednesday, July 31, 2013 2:55 AM
  • The problem is solved and is not due to any hard drive problem.

    As said earlier it is a bug, even a KNOWN bug (or "feature").

    In the post installation tasks, this link was pointed (You Must Manually Run PSCONFIG after Installing SharePoint 2010 Patches):

    Although it was already done in the week following the installation, it seems this has do be re-done manually after each Windows-update downloaded by the server. Re-doing it solved my issue.

    Alain Bourgeois

    Thursday, August 01, 2013 2:18 PM
  • Alain:

    My appologies, and I am embarrased.  Should have suggested this, but did not.  As a matter of fact, the SBS Cosole will give an alert to the need to run the PS Config.

    BTW, it is not every update, just those that affect/patch SharePoint.

    Larry Struckmeyer[SBS-MVP] If your question is answered, please mark the response as the answer so that others can benefit.

    Thursday, August 01, 2013 3:04 PM