locked
Double-click interpreted as single click RRS feed

  • Question

  • It appears that many places in the Windows 7 interface interpret double clicks as single clicks, eg. in classic open/save dialogs clicking the Up One Level button twice will only move you a single directory up, instead of two directories up. This is pretty annoying, as it slows me down considerably, because I have to wait between clicks. Is this a bug, or is it intentional (and if it's intentional, how do I disable it)?
    Friday, May 22, 2009 12:36 PM

Answers

  • Ender,

    I understand what you mean when you say it's not a matter of double-click sensitivity - this seems to just be a UI change, inasmuch as Windows explorer will no longer register two commands to go up one level in a shorter amount of time than it can go up a single level.

    As such, I'd recommend that you post this to the general feedback thread .
    -Alex
    • Marked as answer by axfelix Saturday, May 23, 2009 9:58 PM
    Saturday, May 23, 2009 9:57 PM

All replies

  • There is a setting for the double click speed in the Mouse control panel.   Perhaps you need to adjust this.   A double click is supposed to be different from 2 single clicks, but the difference is all in the timing.

    Personally, I have the single click option turned on.   Double clicking is twice as much work, and is not needed.
    Friday, May 22, 2009 12:44 PM
  • Double-click time doesn't really have anything to do here - I have that set to as short as possible for me, but the problem is, that the second click gets eaten on controls that should only respond to single clicks (where double-clicking that control should cause the action to be done twice). Another factor is, that I have the forward side button on my mouse set to do a double left click, and I got used to clicking certain things with this button to do 2 actions. Now instead I have to click-wait-click for the same effect.
    Friday, May 22, 2009 3:20 PM
  • It is not a widespread issue, so it is not intentional, nor is it a widespread bug. It appears to be local to you, so your software settings will need to be adjusted. It sounds like your double click sensitivity is not high enough, you may want to adjust it.
    Friday, May 22, 2009 10:44 PM
  • I'm pretty sure this has nothing to do with double-click sensitivity, since it's happening on controls that should react to individual clicks only. Also, when I use the side button on my mouse, the two clicks are sent so fast that it doesn't matter how the double-click sensitivity is set. This works fine in Vista and XP, but in 7 the controls react as if they only received one click.
    Saturday, May 23, 2009 8:22 AM
  • Ender,

    I understand what you mean when you say it's not a matter of double-click sensitivity - this seems to just be a UI change, inasmuch as Windows explorer will no longer register two commands to go up one level in a shorter amount of time than it can go up a single level.

    As such, I'd recommend that you post this to the general feedback thread .
    -Alex
    • Marked as answer by axfelix Saturday, May 23, 2009 9:58 PM
    Saturday, May 23, 2009 9:57 PM
  • This problem (it is real) also exists in Vista and XP. Check your mouse adjustments for double click speed. It doesn't matter where the setting is, a single click is interpreted as a double click. This showed up with one of the Windoze updates about a year ago and has been missed by most. 

    Just another reason to wait patiently for Google's new OS

    John

    Saturday, February 5, 2011 5:34 PM