locked
SCCM 2012 - Failed Client Installations RRS feed

  • General discussion

  • I have succesfully installed SCCM 2012 but now I am having issues installing the clients on the workstation.  I have included the CCM LOG files below with errors in BOLD.  I need help resolving failed client installations onto workstations. Your feedback is greatly appreciated.

    TEST ENVIROMENT SETUP:

    1 - (Server Name = DC01) Windows Server 2008 R2. Fully patched with latest security updates and configured as Active Directory Domain Controller, DNS and DHCP.

    ROLES: DNS, DHCP, and Domain Controller

    1- (Server Name = CM01) Windows Server 2008 R2. Fully patched with latest security updates and configured as a member server in the domain called dcs.local. Server is configured with WDS and WSUS roles. It has SQL Server 2008 R2 Standard installed.

    ROLES: Management Point, Software Update Point, Distribution Point, Application Catalog Web Service Point, and Application Catalog Website Point.

    SOFTWARE: SQL Server 2008 R2 Standard, Configuration Manager 2012 Primary Site Server (PS1), and Microsoft Deployment Toolkit 2012.

    1 - (Workstation Name = PC01) Windows 7 x64 Client, fully patched. Configured as workstation in the domain.

    ROLE:  Client

    *****Errors From CCM LOG*****

    CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e


    SMS_CLIENT_CONFIG_MANAGER 10/24/2012 8:43:11 AM 3192 (0x0C78)

    --->Unable to connect to WMI (root\ccm) on remote machine "PC01", error = 0x8004100e

    Execute query exec [sp_CP_SetLastErrorCode] 2097152066, 0 SMS_CLIENT_CONFIG_MANAGER 10/24/2012 8:43:32 AM 3192 (0x0C78)


    ---> Unable to get SMS_Client object from WMI on remote machine "DCSRCCM01", error = 0x80041010.


    Execute query exec [sp_CP_SetLastErrorCode] 2097152000, 0



    • Edited by RB Martin Wednesday, October 24, 2012 5:04 PM
    Wednesday, October 24, 2012 3:59 PM

All replies

  • Please post the entire passage from ccm.log. Those errors might not indicate a problem.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, October 24, 2012 8:07 PM
  • Hi Torsten,

    Here is the CCM.LOG file in its entirety.

    ======>Begin Processing request: "2097152066", machine name: "PC01" SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    Execute query exec [sp_IsMPAvailable] N'PS1' SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0) SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> Attempting to connect to administrative share '\\PC01\admin$' using account 'DCS\CM_CP' SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    Getting a new request from queue "Incoming" after 100 millisecond delay. SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 8080 (0x1F90)
    Waiting for change in directory "D:\Program Files\Microsoft Configuration Manager\inboxes\ccr.box" for queue "Incoming", (30 minute backup timeout). SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 8080 (0x1F90)
    ---> The 'best-shot' account has now succeeded 5 times and failed 0 times. SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> Connected to administrative share on machine PC01 using account 'DCS\CM_CP' SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> Attempting to make IPC connection to share <\\PC01\IPC$> SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> Searching for SMSClientInstall.* under '\\PC01\admin$\' SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:01 PM 7292 (0x1C7C)
    ---> System OS version string "6.1.7601" converted to 6.10 SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    CWmi::Connect(): ConnectServer(Namespace) failed. - 0x8004100e SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Unable to connect to WMI (root\ccm) on remote machine "PC01", error = 0x8004100e. SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Creating \ VerifyingCopying exsistance of destination directory \\PC01\admin$\ccmsetup. SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Copying client files to \\PC01\admin$\ccmsetup. SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Copying file "D:\Program Files\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "MobileClient.tcf" SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Copying file "D:\Program Files\Microsoft Configuration Manager\bin\I386\ccmsetup.exe" to "ccmsetup.exe" SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:02 PM 7292 (0x1C7C)
    ---> Updated service "ccmsetup" on machine "PC01". SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    ---> Started service "ccmsetup" on machine "PC01". SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    ---> Deleting SMS Client Install Lock File '\\PC01\admin$\SMSClientInstall.PS1' SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    Execute query exec [sp_CP_SetLastErrorCode] 2097152066, 0 SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    ---> Completed request "2097152066", machine name "PC01". SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    Deleted request "2097152066", machine name "PC01" SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    Execute query exec [sp_CP_SetPushRequestMachineStatus] 2097152066, 4 SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    Execute query exec [sp_CP_SetLatest] 2097152066, N'10/24/2012 19:48:17', 7 SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)
    <======End request: "2097152066", machine name: "PC01". SMS_CLIENT_CONFIG_MANAGER 10/24/2012 2:48:17 PM 7292 (0x1C7C)


    Richard Martin

    Wednesday, October 24, 2012 8:43 PM
  • Any ideas why client push install fails?  I have boundary and boundary groups configured.  I have a service account CM_CP to push clients added to local admin group.  AD Schema is extended.  Created Systems Management container with ADSI.  Windows Firewall configured to allow File/Print Share, WMI, Remote Assistance and Remote Desktop. Am I missing anything?

    Richard Martin

    Thursday, October 25, 2012 12:11 AM
  • Do you have any antivirus enable on the client machine? I've seen antivirus blocking SCCM client installation. Please check in the client machine ccmsetup.log located C:\Windows\ccmsetup. Thanks!

    Thursday, October 25, 2012 3:28 PM
  • Client push does not fail: Started service "ccmsetup" on machine "PC01". 
    See ccmsetup.log on the client as DamianVarona already suggested.


    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, October 25, 2012 3:46 PM
  • I had a similar problem if the workstation have installed Vmware, Virtualbox, etc.
    Monday, November 5, 2012 2:07 PM
  • I had a similar problem if the workstation have installed Vmware, Virtualbox, etc.

    That's irrelevant and has nothing to do with client push.

    Jason | http://blog.configmgrftw.com

    Monday, November 12, 2012 12:37 AM
  • Has there been any further development on this issue? I have the same issue, environment meets requirements: Firewall disabled, CM_CP added to local admin of target server, no AV, boundaries added to boundary group and resources tab configured, System Management container configured with required permissions, discovery of clients successful, ccmsetup service starts on target machine (can verify that I can see the service run in target machine's task manager), admin share is accessible on target computer, target computer can be pinged and returns a valid IP withing the aforementioned configured boundary.

    What I cant see: CCM folder on the target computer under Windows\System32 (can see it in the admin share folder though)

    Also, manually running setup.exe on target computer installs the client, however it cannot find the site server when i manually specify the site code.  Target computer can also browse the shares on the SCCM server. Error: Execute query exec [sp_CP_SetLastErrorCode] 2097152000, 0

    SCCM is running on W2008R2 VM, target computers are also 2008R2 VM's.

    Any help would be appreciated.


    • Edited by liesief Monday, November 19, 2012 11:40 AM
    Monday, November 19, 2012 11:40 AM
  • CCM does not live under system32 in 2012, it lives directly under c:\Windows (which is what admin$ shares out).

    You'll have to check your log files under ccm\logs to get more info; specifically, locationservices.log and clientlocation.log (to start with).

    Also, have you extended the AD schema?

    Have you properly created boundaries and boundary groups?


    Jason | http://blog.configmgrftw.com

    Monday, November 19, 2012 4:20 PM
  • Hi Jason,

    Thanks, I have located the admin$ and can access the CCM log files there. Schema has not been extended (further up in this doc it says that this is not necessary for successful client install), the only reason I havent extended yet is because I have Exchange 2010 running in this prod environment and dont yet understand the impact of extending it during prod hours.

    As for boundaries and boundary groups, the boundaries themselves were populated automatically (IP ranges & AD Sites, which also tells me schema extension is not necessary), from there I have created boundary groups and configured the References tab for site assigmnent, configured the assigned site and the Site System Server.

    Locationservices.log: Failted to resolve 'SMS_SLP' from WINS and LSGetLookupMP: Failed to resolve lookup MP from WINS with 87D00215. Check if it is published.

    The locationservices.log actually identifies which AD site the SCCM server is associated with, but returns 'no lookup MP's from AD'.

    • Edited by liesief Tuesday, November 20, 2012 8:18 AM
    Tuesday, November 20, 2012 8:04 AM
  • If you haven't extended the schema, then clients have no way to find the MP automatically so you must use the SMSMP property when installing the agent or add the MP (which also serves as the SLP in 2012) to WINS.

    You're right that extending the schema is not strictly required, but it makes things a lot easier. The schema change is tiny -- 3 brand new classes and less than 20 brand new attributes (13 I think) -- and has no impact on anything else in any other portion of the schema. There will be a very small amount of replication traffic generated of course since this has to go out to all DCs in the forest, but this truly is trivial.


    Jason | http://blog.configmgrftw.com

    Tuesday, November 20, 2012 2:41 PM
  • Can you provide an example of how would I do this?

    "use the SMSMP property when installing the agent or add the MP (which also serves as the SLP in 2012) to WINS."

    Wednesday, June 19, 2013 9:12 PM
  • The documentation is at http://technet.microsoft.com/en-us/library/gg699356.aspx

    Jason | http://blog.configmgrftw.com

    Wednesday, June 19, 2013 9:23 PM
  • I chased this for days! What finally fixed mine is it turned out even though I configured all my AD access in ADSIEDIT using the SCCM server computer account, not until I changed my Active Directory Forest publishing account to an admin account (a domain admin to be specific) did it FINALLY start successfully registering clients. The discovery status was successful, but publishing was not, until I changed that. I still don't know why the sccm computer account won't publish, but I'm so sick of chasing it I don't even care, it works now.
    Thursday, November 5, 2015 12:43 AM