locked
KB2467174 & 175 on Windows7 RRS feed

  • Question

  • Security update KB2467174 and KB2467175 keep coming up on windows update on my Windows 7-64 system. KB.....175 installs succesful but keeps coming up again on windowsupdate and KB2467174 (Visual 2008 update) does not complete succesfully. As a consequence (According to windows update) Explorer 9 (64) does not install.

    I did see several notes re..the mentioned KB's relative to W2K systems and XP but not yet on W7 systems. Why do these updates come up for Windows7 at all ?

    Willem


    Photo
    Tuesday, May 10, 2011 9:34 AM

All replies

  • Hi,

     

    According to the description of the KB2467174 and KB2467175, KB2467174 is the latest version for Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package MFC instead of KB2467175. You can refer to the following link.

     

    KB2467174 Version 9.0

    http://www.microsoft.com/downloads/en/details.aspx?familyid=05ce856d-8128-408b-96fa-5e1f57b097d8&displaylang=en

     

    KB2467175 Version 8.0

    http://www.microsoft.com/downloads/en/details.aspx?familyid=fb01abe6-9099-4544-9aec-0ac13f19bc50&displaylang=en

     

    The update is supported for Windows 7 which is installed Microsoft Visual C++ 2008 SP1. I suggest you download the update from the link directly and install it manually to check the result. If the issue persists, please go to uninstall KB2467175 and then install KB2467174 to check the result.

     

    How to uninstall update

    ------------------------------------

    1. click Start -> type installed updates -> choose View installed updates

    2. In the list, right click the KB2467175 and choose uninstall

     

    If any error is received when installing KB2467174, please let me know it exactly. If it still cannot be installed, there may be problem with visual program. Try repairing the program and then install update again.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Niki Han Monday, June 27, 2011 9:08 AM
    • Unproposed as answer by Willemvoorneveld Monday, June 27, 2011 9:55 AM
    Thursday, May 12, 2011 10:12 AM
  • Having the same issues discribe in this topic, plus cannot install IE9.

    Have jumped through all the hoops, including uninstall/reinstall of .NET Framework 4.

    KB2467174 shows up as a successful install, yet still shows up as a priority update !

    Which one of the downloads, there are 3, do I use for KB2467175 ?

    Running Windows 7  64bit here.

     

    Thanks in advance..............this issue is driving me nuts !

    Saturday, May 14, 2011 11:54 AM
  • Update: In windows update the file size of KB2467174 is 9.2 MB. The link you provided, to manually download this update has 3 downloads.

    vcredist_IA64.exe which is 4.4 MB. This download was not compatible with my system!

    The next 2 downloads were vcredist_x64.exe 5.0 MB and vcredist_x86.exe 4.3 MB As you can see , none of these downloads are the same size , 9.2 MB, as windows update, on my system shows.

    Neither one of the last two downloads would install, on my system, saying among other things, "Error 1935" and "HRESULT:0x8007371b".

    I have tried every method I could find on the web, including one that had me uninstall and reinstall .NET Framework 4, and also more than one of the imfamous Mr. Fix it's !

    About to try a registry cleaner, then will give up and do a OS reinstall. PC is running fine, just don't like not having it up-dated !

    Sunday, May 15, 2011 7:36 PM
  • Hi,

     

    The second update vcredist_x64.exe is for 64-bit OS. The standalone package will not the same as the one from Windows Update. It seemed the update failed with error code 1935.

     

    The issue could be related to Windows Installer, check if the following KB could resolve the issue.

     

    http://support.microsoft.com/kb/958052

     

    Regards,

    L.S


    Monday, May 16, 2011 3:00 AM
  • OK, downloaded and tried to install KB2767174, vcredist_x64.exe

    Here is the failed result, word for word.

     

    Microsft Visual C++ 2008 Redistributable - KB246174 Setup

    Error 1935. An error occured during the installation of assembly'policy.9.0.Microsoft.VC90.ATL,version=9.0.307729.5570",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture

    ="amd64",type=win32-policy"". Please refer to Help and Support for more information. HRESULT:0x8007377B

    The link you provided, Little Sheep, were for Error codes 0x80070643 and 0x643. No mention of error code 1935.

    Also noticed , while typing the error I received, 1935, amd64. I'm running an intel T9300 cpu.

    Thanks for any and all help !

     

     


    Monday, May 16, 2011 4:45 PM
  • Wow...........like a Ghost town around here !

    Anyways, think I found the culprit of my issues.......maybe.

    After scouring the net for days and coming across people with the same issues, jumping through all kinds of hoops, I discovered a program, on my pc, called "Visual Studio 2008 x64 Redistributables....by AVG Technologies" !

    I use to use AVG, but uninstalled and have been using Microsoft Security Essentials, for the last couple of months, which I am happy with !

    I have uninstalled the Visual Studios 2008 x64 by AVG and hidden the SP update for this program !

    We'll see what happens tonight, software release night ! Why would this program still be on my pc, if in fact it was install by AVG and I uninstalled AVG ?

    Tuesday, May 17, 2011 5:56 PM
  • I am having the exact same problem, with the same error message. Let me know if you manage to find anything!

     

    K

    Tuesday, May 17, 2011 9:21 PM
  • Do you or have you ever installed AVG anti-virus ?
    Wednesday, May 18, 2011 5:38 AM
  • I never did ! I use MS security essentials since as long as it is available and its pre-decessor before that.
    Photo
    Wednesday, May 18, 2011 10:25 AM
  • Check programs and features list for "Visual Studio 2008 by AVG " .
    Wednesday, May 18, 2011 4:44 PM
  • I know it is 3 weeks later, but has anyone gotten anywhere with this?  Now that I have your attention, let me tell you my story:

    I screwed up and this is how I got here.  Now, this doesn't happen every time.  Programs will work about 50% of the boots.  Last night, though, I learned that as time goes on, programs are less likely to start correctly.  For each program that I try to run, the process starts, 104K of memory is used (always the same) but no window opens.  I have an SSD that is smallish... 64 GB running Windows 7. It is a machine I built myself. I have about 11 Gig free at any given time. I have a 2 Tb secondary drive where I keep my data and some, less used, programs. This is also where I keep my virtual machines (VM). I currently have 2 linux machines. This weekend, I tried creating a Windows 7 (W7) virtual machine with an extra copy of W7 that I have. Well, I forgot to switch the target VM install area from my system disk to the secondary disk. When I realized what I had done, the install was almost finished and I had about 1 GB left on the system disk. I worked to kill everything and delete the W7 VM. (That was a time consuming pain. PC was as slow as mud, which was to be expected, I guess.) So, after I got the W7 VM deleted everything seemed to be alright, until I tried to start Firefox and it wouldn't. Thunderbird 3 also wouldn't start.  Ditto for Norton Antivirus, Truecrypt, Microsoft Office, and Ccleaner.  IE 9 will start. As will Photoshop CS 5.0, and Windows Media Player. I have my machine locked down; so, I'm confident it isn't a virus or malware. I ran a full scan on saturday morning and again this morning - when I got Norton to start.

    When I look at the Process list it says the programs that are not opening a window are using 104K of memory.  My research is leading me to believe this is a Windows Update issue, specifically KB2467173, 4 and 5.  I'm not going to completely blame Microsoft for it yet, though.  It started right after I filled my hard drive; so, maybe I aggravated an already broken piece of software.

    I have never used any antivirus software other than Norton.  I also keep a tight lid on what I install on my machine.  (That's the reason for the virtual windows machine and the virtual linux machines.) 

    I don't have the time or the will to rebuild the software on this machine. I do have a backup, but I've never had much luck getting those to work properly.

    Soooooo, HELLLLPPPPPP!!!!!

    Thanks everyone.

    Monday, June 6, 2011 2:34 PM
  • try this tool:

     

    Description of the System Update Readiness Tool for Windows Vista, for Windows
    Server 2008, for Windows 7, and for Windows Server 2008 R2

    http://support.microsoft.com/kb/947821 

    • Proposed as answer by Niki Han Monday, June 27, 2011 9:08 AM
    • Unproposed as answer by Willemvoorneveld Monday, June 27, 2011 9:41 AM
    Wednesday, June 8, 2011 6:16 AM
  • I HAVE TRIED THIS SOLUTION PROPOSAL TWICE, TRYING BOTH THE solution through Windows update and also the manual download solution. The automated WU solution does not provide me with any Readiness tool and the manual solution tells me that the tool in question is not applicable for my system (X64 on windows 7). None of the manual downloads proclaim any applicability.
    Photo
    Monday, June 27, 2011 9:45 AM
  • My W7 system does not show any updates in the list installed updates. It never has. The only place where succesful installations can be viewed is under History under windows update. !
    Photo
    Monday, June 27, 2011 9:51 AM
  • What is the status of updates under history? Are they successful? What is the latest successfully update?

    Try to reset Windows Update components with the following KB.
    http://support.microsoft.com/kb/971058

    Also check the system file as well.
    http://support.microsoft.com/kb/929833

    L.S

     

     


    Wednesday, June 29, 2011 7:44 AM
  • Hallo L.S.

    All updates install succesfully except the visual 2008 related ones.

     KB2467174 and now KB2538243 are listed as fail. (Mislukt in Dutch)

    Error code remains 643.

    The most recent succesful update was the Office 2010 Service pack 1 from yesterday. etc.

    So, the problem seems isolated to the visual 2008 ones. This also stop the upgrade to IE 9.

    Willem.

    The link provided in your post does not work for me. It seems to have been removed.

     


    Photo
    Wednesday, June 29, 2011 9:03 AM
  • Little Sheep's hyperlink for KB971058 (to reset the Windows Update components) is broken but you should be able to copy or type the address into the IE address bar (this should be a working version of the link: http://support.microsoft.com/kb/971058).  If you are able to install other Windows Updates, however, that seems unnecessary (likewise, the System Update Readiness Checker).

    @Willemvoorneveld:

    Did you have any luck using the System File Checker tool (instructions at http://support.microsoft.com/kb/929833)? 

    The other thing I would try is manually installing the update for KB2538243: http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26368

    This KB article was published as a replacement for KB2467174, so you should only need the newer of the two.

    Wednesday, June 29, 2011 9:20 PM
  • Thanks for your note Simon,

    Both the 971058 and 929833 (the file checker) did not find any irregularities.

     Later today I will try a manual install of the KB2538243 and report back,

    Willem


    Photo
    Thursday, June 30, 2011 10:04 AM
  • Update:

     

    manual install of the KB2538243 result in error 1935. I did take the X64 file for my  Intel i3 CPU running on W7 64bit version.

     

    Willem


    Photo
    Thursday, June 30, 2011 11:04 AM
  • OK, so now we've eliminated the Windows Update process and the older version of the MFC security update (2467174).

    The next thing I would try is the fix for error 1935 installing a VC2008 redistributable mentioned here:  http://support.microsoft.com/kb/970652

      Although the Fixit is labeled for Windows Vista, it does seem to describe the earlier problems you had, and apparently has worked on Windows XP and 7 systems encountering this error. 

    http://support.microsoft.com/default.aspx?scid=kb;en-us;946414

    If you're comfortable working with the registry, you could see if these values are present before running the Fixit:

    • HKEY_LOCAL_MACHINE\COMPONENTS\PendingXmlIdentifier
    • HKEY_LOCAL_MACHINE\COMPONENTS\NextQueueEntryIndex
    • HKEY_LOCAL_MACHINE\COMPONENTS\AdvancedInstallersNeedResolving

    I'm not familiar with localized versions of Windows, so it might be good to manually look for these keys, in case they are localized. 

    Friday, July 1, 2011 6:01 PM
  • I do not seem to have a COMPONENTS directory in HKEY_Local_Machine. Should I still try to load the 970652?

     

    Willem


    Photo
    Sunday, July 3, 2011 5:37 AM
  • If you don't see the COMPONENTS branch, I don't think the Fixit in 970652 will do anything. 

    Going back to error 1935 installing KB2538243, there should be more error details- can you post the entire error message?

    If not (or if the additional error details don't tell us anything), install the update with the logging option. 

    First, close everything you can- any open applications plus stuff like scanning "hotkey" programs.  You can usually right-click them in the Notification Area of the taskbar (next to the clock) and click Exit. They will usually start up the next time you reboot.

    Next, open your TEMP directory- click the Start button, then type %TEMP% and press [Enter].  Delete everything in here that you can.  Windows won't let you delete files that are in use, so just leave those alone.

    To install the update with logging, put it in the TEMP directory.  Click Start, then type CMD.  Right-click the CMD option in the search results, select Run As Administrator, and confirm the UAC security prompt.  At the command prompt, type this command, then press [Enter]:

    %TEMP%/vcredist_x64.exe /L

     

     

    Tuesday, July 5, 2011 2:01 PM
  • Since error message 1935 that I encountered did not give me firther detail on the error I will try it with the logging option today. More later.

     

    Willem


    Photo
    Saturday, July 9, 2011 6:51 AM