locked
getting null values when browsing a cube in ssas RRS feed

  • Question

  • hi, i got null values when i browse a cube after processing, please help me to get values

    and also

    explain in what situations we have to give column binding property for the hierarchiey


    • Edited by krs777 Monday, July 16, 2012 11:41 AM
    Monday, July 16, 2012 11:40 AM

Answers

  • You should also check to see whether you have deleted the Calculate statement on your MDX Script: http://cwebbbi.wordpress.com/2011/10/20/why-has-all-the-data-in-my-cube-disappeared/ Chris

    Blog: http://cwebbbi.wordpress.com/ Consultancy: http://www.crossjoin.co.uk/

    • Marked as answer by Elvis Long Wednesday, July 25, 2012 10:48 AM
    Monday, July 23, 2012 8:14 AM

All replies

  • Do you have any measures defined while browsing?

    If you want to see data returned, you must add any measure.

    • Proposed as answer by Elvis Long Thursday, July 19, 2012 1:26 AM
    Monday, July 16, 2012 1:02 PM
  • i build a cube with individualsalesamount , resellerssalesamount as measures  and dimproduct, dimgeography,dimtime,dimcustomer as dimensions

    when i browse the cube, it doesn't show any values for the IndividualSalesAmount,it shows only blank cells.

    But it shows values for ResellersSalesAmount for all dimensions

    what's the reason for getting blank cells,even if all  the relations are maintained correctly between fact and dim tables

    thanks in advance

    Friday, July 20, 2012 6:18 AM
  • i build a cube with individualsalesamount , resellerssalesamount as measures  and dimproduct, dimgeography,dimtime,dimcustomer as dimensions

    when i browse the cube, it doesn't show any values for the IndividualSalesAmount,it shows only blank cells.

    But it shows values for ResellersSalesAmount for all dimensions

    what's the reason for getting blank cells,even if all  the relations are maintained correctly between fact and dim tables

    thanks in advance


    Friday, July 20, 2012 4:39 PM
  • On what you created the measures? Try adding a measure tocount the rows in the fact table IndividualSalesAmount.

    Open the DSV and review the relationships between tables. Open the Cube > go to Dimension Usage tab > check the relationships and keys between Fact tables and dimensions.

    • Edited by irusul Monday, July 23, 2012 5:59 AM
    Monday, July 23, 2012 5:57 AM
  • You should also check to see whether you have deleted the Calculate statement on your MDX Script: http://cwebbbi.wordpress.com/2011/10/20/why-has-all-the-data-in-my-cube-disappeared/ Chris

    Blog: http://cwebbbi.wordpress.com/ Consultancy: http://www.crossjoin.co.uk/

    • Marked as answer by Elvis Long Wednesday, July 25, 2012 10:48 AM
    Monday, July 23, 2012 8:14 AM