locked
IIS v6.0 RRS feed

  • Question

  • Dear all,

    We have a dot net nuke web service running on IIS v6.0 . And it uses windows authentication login. Web server used to authenticate using server 2008 dc but now we have upgraded our directory services to 2012r2.

    Since then it takes a lot of time for web service to load and many times it doesnt authenticate automatically with the dc.

    We disabled anonymous login on IIS and we use a policy to automatic logon only in Intranet.

    Is there something that we are missing?

    Regards

    Nima


    nimz

    Friday, May 29, 2015 8:26 AM

Answers

  • If it takes time to authenticate in that case make sure you enable netlogon debug log using the following command and also try and capture network trace between IIS server and domain controller.

    Possible verify the network settings at both ends like DNS / Router / VLAN /Switch etc..

    To enable the netlogon debug log use the following command run as administrator (Download the nltest from 2003 support tool)

    nltest.exe /dbflag:0x2080ffff (Enable netlogon debug logs)

    nltest.exe /dbflag:0x0 (Disable netlogon debug logs)

    • Proposed as answer by Frank Shen5 Tuesday, June 9, 2015 8:47 AM
    • Marked as answer by Frank Shen5 Wednesday, June 10, 2015 8:38 AM
    Sunday, May 31, 2015 6:12 PM
  • I would recommend asking them in IIS forums: http://forums.iis.net/

    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    • Proposed as answer by Frank Shen5 Tuesday, June 9, 2015 8:47 AM
    • Marked as answer by Frank Shen5 Wednesday, June 10, 2015 8:38 AM
    Sunday, May 31, 2015 6:28 PM

All replies

  • On Which Server IIS is installed? Is is on domain controller?
    Friday, May 29, 2015 9:20 AM
  • No Purvesh. It is located on a member server running windows server2003.

    nimz

    Friday, May 29, 2015 9:23 AM
  • OK. I thought it is running on DC then Microsoft does not recommend to run IIS on DC.
    Friday, May 29, 2015 9:25 AM
  • Are you observing any errors in eventlog or IIS log ?

    Devaraj G | Technical solution architect

    Friday, May 29, 2015 3:07 PM
  • No Devaraj. It only takes a lot of time to authenticate.

    nimz

    Saturday, May 30, 2015 7:42 AM
  • If it takes time to authenticate in that case make sure you enable netlogon debug log using the following command and also try and capture network trace between IIS server and domain controller.

    Possible verify the network settings at both ends like DNS / Router / VLAN /Switch etc..

    To enable the netlogon debug log use the following command run as administrator (Download the nltest from 2003 support tool)

    nltest.exe /dbflag:0x2080ffff (Enable netlogon debug logs)

    nltest.exe /dbflag:0x0 (Disable netlogon debug logs)

    • Proposed as answer by Frank Shen5 Tuesday, June 9, 2015 8:47 AM
    • Marked as answer by Frank Shen5 Wednesday, June 10, 2015 8:38 AM
    Sunday, May 31, 2015 6:12 PM
  • I would recommend asking them in IIS forums: http://forums.iis.net/

    This posting is provided AS IS with no warranties or guarantees , and confers no rights.

    Ahmed MALEK

    My Website Link

    My Linkedin Profile

    My MVP Profile

    • Proposed as answer by Frank Shen5 Tuesday, June 9, 2015 8:47 AM
    • Marked as answer by Frank Shen5 Wednesday, June 10, 2015 8:38 AM
    Sunday, May 31, 2015 6:28 PM