none
MAP 9.0 Powershell Inventory Collection not working RRS feed

  • Question

  • Guys,

    I am looking for some guidance on getting the Powershell element of the MAP 9 toolkit to work to assess my Volume Licence usage. I have created a F/W rules to allow WinRM over Port 5985 and a policy to both enable WinRM and to allow all listeners on my local subnet. I then update policy on client systems and run the MAP inventory and when I run the assessment it always brings back the "MAP was unable to run a PowerShell script on this computer in order to determine the volume license status.". At this stage it is beginning to drive me to distraction and coupled with the fact that the documentation for the product is not great I am really starting to lose patience with this.

    My client are Win 7 SP1\Win 8 and Windows 8.1, I just do not understand why this is occurring. Any help would be very much obliged.

    Regards,

    Mark



    • Edited by MarkBow Tuesday, March 4, 2014 3:03 PM
    Tuesday, March 4, 2014 3:02 PM

All replies

  • Have you tried testing that remote PowerShell is working? You can do this by picking one of the target machines that is failing and then typing this in at the PowerShell prompt on the MAP machine:

    Test-WSMan <host name>

    If this is also unsuccessful then something in your environment is blocking remote PowerShell. If it is successful, then we can try coming up with some tests to determine the block in MAP.



    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. Please VOTE as HELPFUL if the post helps you. This can be beneficial to other community members reading the thread.

    Tuesday, March 4, 2014 8:11 PM
    Moderator
  • Michael,

    First up, thanks for the response. I have run that command against a few machines and receive a response similar to the following on them:


    wsmid           : http://schemas.dmtf.org/wbem/wsman/identity/1/wsmanidentity.xsd
    ProtocolVersion : http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd
    ProductVendor   : Microsoft Corporation
    ProductVersion  : OS: 0.0.0 SP: 0.0 Stack: 3.0

    So to me it all looks good. Now to do a further test I set up a new DB in MAP and instead of scanning against the whole domain I scanned against particular systems (that I know this command has worked on) that I added through the inventory wizard, same result as before, Powershell simply doesn't run on the clients.

    Any further ideas?

    Thanks,

    Mark

    Wednesday, March 5, 2014 10:55 AM