locked
Help configuring Voice Routing RRS feed

  • Question

  • OK, this probably falls into the category of too much information, but here goes…

    I’m having trouble configuring calling on my test Lync Server setup.  My initial goal is to configure internal calling with three digits, 5XX, and external calling with a single POTS line.  For test purposes, I have only attempted to call (314) 496-9999.

    Another major goal is to understand all the voice routing components and how they interact.  I haven’t found any docs with that info. 

    My symptom is that when dialing the number I get the response that “Call was not completed or has ended.” 

    Conference

    14010

    Call was not completed or has ended.

    Cannot complete the call. To correct this problem you may need to provide an area code, a number to access an outside phone line, or a number to dial long distance. If you cannot resolve this problem, your system administrator may need to change the geographic location on your user account or update the company dialing rules.

    Unable to find an exact match in the rules set.

    I’m confident my voice routing configuration is wrong, because using the “Test Voice Routing” fails.  Numbers are normalized correctly, but the “First PSTN usage” and “First route” items fail.

     

    So what am I doing wrong/not doing?

     

    Lync Environment:

    Lab/test system running on a single Standard Edition server.  Enterprise Voice is enabled.  The Mediation Server is enabled ad collocated on the Front End/only server.  The PSTN gateway device is an AudioCodes MediaPack ( MP-114, 2FXS + 2FXO )  The Gateway device has a DNS entry, and is peered with the Mediation Server (I think).  Both the Mediation Server and the Gateway are configured to use TCP, on port 5060.

    I have included the exported configuration information at the end of this post…

    Trunk:

    Defined connection between Mediation Server and Gateway. 

    I have the Global Trunk Configuration and a Pool scope entry, to which I added the media bypass option (also tested without bypass.)  Neither definition has any translations associated.

    Verified, in Topology Builder, Mediation Server’s peer, the MediaPack gateway, using same port, 5060/TCP.

    Dial Plan:

    Associates normalization rules (and sets a few parms.)

    Using only Global Dial Plan

    Normalization Rules: Translate input phone numbers into standardized form for dialing.

    I have six rules, appearing in the order mentioned here.  Three for local calls.  Need to dial local numbers as “314xxxYYYY, without leading “1.”

    ·         If 7 digits long, add prefix, 314, for a 10 digit string.   [   ^(\d{7})$  and  +314   ]

    ·         If 10 digits long, beginning with 314, use that number as is (avoids the last, generic rule to add 1 prefix. [   ^(314\d{7})$  and   +$1   ]

    ·         If 11 digits long, beginning with “1314,” remove the first digit.  [   ^1(314\d{7})$  and  +$1   ]

    There are two more rules to catch numbers for long distance.

    ·         If 11 digits long, add a “+” prefix.

    ·         If 10 digits long, add a “+1” prefix.

    Last rule for internal dialing (I think.)

    Voice Policy:

    Associates PSTN Usages (and sets a few parms.)

    Using only Global Voice Policy.

    Policy has one PSTN Usage Record defined, with two associated routes.

    Routes:

    Routes associate a called number with a Gateway.  At the moment, all I need to do is distinguish an internal call from an external call, and route all external calls to the only gateway.  The routes associate +1314xxxyyyy and +314xxxyyyy with the only gateway.

    I assume I will eventually add a route for all 11 digit traffic to the gateway.  I’m also assuming the numbers referred to in Route definitions are the dialed numbers AFTER they are normalized.

    PSTN Usage:

    Associates Policies and Routes.  As mentioned, the only, Global, policy is associated with the only two Routes.

    Monday, December 20, 2010 9:59 PM

All replies

  • Wow, you are right..  This is a lot of information and almost scared me off from responding :-)

    Anyways.  I believe after reading this only once that your issue is with your route.  If your number normalizes how you want it, now we need to get Lync to let go of it.  Since you have a pretty simple environment I would recommend creating the following route:

    Match this pattern: .*

    Associated Gateways: Your PSTN Gateway

    Usage: Default Usage

    Mark


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCSE: Messaging | MCITP:Enterprise Messaging | www.unplugthepbx.com
    Tuesday, December 21, 2010 3:17 AM
  • Thanks.  That is progress, but not success.

    The symptom now is a brief attempt at dialing (one, or a fraction, of the Lync client ringback), and the response: "[normalized number] is not in service.  Please check..."   This happens for a local, 314, area code for which there are normailization rules, and for an 800 number that uses a generic normalization rule to add "+1".  In both cases, the number seems to be normalized correctly.  The failure seems quick enough that it is not coming from the call progress tone for a number that is not in service.

    BTW, the test cases on the "Test Voice Routing" tab now work correctly.

    Tuesday, December 21, 2010 9:12 PM
  • Can you capture a log in Lync...

    Open the Lync Logging Tool - Select S4 and Sipstack (both all flags)

    Start Logging

    Make a test call

    Stop Logging

    Select View Log Files

    Save to a text file

    Post here


    Mark King | MVP: Lync Server | MCTS:UC Voice | MCSE: Messaging | MCITP:Enterprise Messaging | www.unplugthepbx.com
    Tuesday, December 21, 2010 9:38 PM
  • Thanks again.

    Update...

    After playing around in the AudioCodes, gateway device, interface, it seems I had not associated the FXO port(s) with a "Hunt Group"  and configured "IP to Tel" routing.  I think I have done that.  Current staus, on placing a call, the system seizes the line but does not dial.  Dial tone is heard, and if I use the dial pad, within the active call window of the Lync client, the call connects.  I tried this with/without the gateway's option to wait for dial tone before dialing.

     

    Previous post...

    Was unable to submit this reply with full log content.

    Don't know if I can include a URL here...  You can get the full log here:

        http://www.itartisan.com/Geek/LyncLog1.txt

    The first bit that looks like the error is here:

    SIP/2.0 404 Not Found
    FROM: "Trey Shaffer"<sip:trey@home.hom>;tag=9696d8bb03;epid=cfc6ebd93f
    TO: <sip:+3144968000@home.hom;user=phone>;tag=39a0467a58;epid=B7F8AE9338
    CSEQ: 1 INVITE
    CALL-ID: dfb48cd54e3c40f5bb759c8233ce5ad8
    VIA: SIP/2.0/TLS 192.168.1.65:58752;branch=z9hG4bK805F7996.D508D8EABE831CF1;branched=FALSE,SIP/2.0/TLS 192.168.1.100:53297;ms-received-port=53297;ms-received-cid=A00
    CONTENT-LENGTH: 0
    P-ASSERTED-IDENTITY: <sip:+3144968000@Home.hom;user=phone>
    SERVER: RTCC/4.0.0.0 MediationServer
    ms-diagnostics: 10404;source="Lync1.Home.hom";reason="Gateway responded with 404 Not Found (User Not Found)";component="MediationServer";SipResponseCode="404";SipResponseText="Not Found";sip-reason="Q.850 ;cause=3 ;text="local"";GatewayFqdn="MediaPack.Home.hom"
    ms-diagnostics-public: 10404;reason="Gateway responded with 404 Not Found (User Not Found)";component="MediationServer";SipResponseCode="404";SipResponseText="Not Found";sip-reason="Q.850 ;cause=3 ;text="local""
    Reason: Q.850 ;cause=3 ;text="local"
    ms-trunking-peer: MediaPack.Home.hom;User-Agent="Audiocodes-Sip-Gateway-/v.6.00A.023.007"
    ms-endpoint-location-data: NetworkScope;ms-media-location-type=intranet

    • Edited by CBS3 Wednesday, December 22, 2010 4:56 PM
    Wednesday, December 22, 2010 3:17 PM
  • Ok this is good, the problem is now at the gateway.  Can you provide information on how the gateway is configured? 
    Mark King | MVP: Lync Server | MCTS:UC Voice | MCSE: Messaging | MCITP:Enterprise Messaging | www.unplugthepbx.com
    Wednesday, December 22, 2010 3:40 PM
  • After playing around in the AudioCodes, gateway device, interface, it seems I had not associated the FXO port(s) with a "Hunt Group"  and configured "IP to Tel" routing.  I think I have done that.  Current staus, on placing a call, the system seizes the line but does not dial.  Dial tone is heard, and if I use the dial pad, within the active call window of the Lync client, the call connects.  I tried this with/without the gateway's option to wait for dial tone before dialing.

    Link to manual, if helpfull

    http://www.audiocodes.com/filehandler.ashx?fileid=708336

    Following is the AudioCodes MediaPack (MP-114) ini/config file contents:
        Content was truncated on posting. Here is link to complete file:   

        http://www.itartisan.com/Geek/MP114Config1.txt 

    Wednesday, December 22, 2010 5:01 PM
  • Sounds like one stage dialing is not turned on..  go to Protocol Management - Advanced Applications - Dialing Mode.  Do you have One Stage selected?
    Mark King | MVP: Lync Server | MCTS:UC Voice | MCSE: Messaging | MCITP:Enterprise Messaging | www.unplugthepbx.com
    Thursday, December 23, 2010 4:40 AM
  • Correct, it was set to Two-stage dialing.  And again, the behavior there was to pick up the line and "do nothing."

    I had tried it with one-stage dialing. 

    With that setting, behavior is to initiate the call, I hear 1-2 ringback tones from the Lync client, then a fast-busy/reorder apparently from the Telco, and the call session terminates without further status display...

    Thursday, December 23, 2010 5:29 PM