locked
Windows Vista default login procedure / Adminitrative rights RRS feed

  • Question

  • Two questions, help with what you can.

    How do I disable the login process on a Windows Vista PC?

    When logged into a Windows Vista PC as an Administrator (the only account on the PC) and I try to delete "some" folders it pops up and says I must have Administrative privaledges or some such non-sense. How do I tell Vista I am an administrator when I am already logged in as an administrator?

    Thursday, September 2, 2010 3:50 AM

Answers

  • Hi,

    For question 2, I would like to confirm what kind of folders are they? Usually, this is because Windows system files are owned by the TrustedInstaller service by default, and Windows File Protection will keep them from being overwritten. To delete them, you need to grand yourself full control over the folder.

    Click Start, type CMD and press Ctrl+Shift+Enter key combination to open an administrator command prompt.

    To take ownership of the file, you’ll need to use the takeown command. Here’s an example:

    takeown /f C:\Windows\System32\Test.txt

    The folder Test.txt under C:\Windows\System32 is the one you want to delete.

    After taking ownership of the file, please run the cacls command to give yourself full control rights to the file:

    cacls C:\Windows\System32\Test.txt /G Magon:F

    Please note: Magon is my username, replace it with your username.

    After that, try deleting the folders. If still no go, in case any application is using them, please boot into Safe Mode and repeat the steps above.

    Good Luck.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, September 3, 2010 9:41 AM
    Moderator

All replies

  • Found the answer to question 1 on a different forum. Required the use of CONTROL USERPASSWORD2 in the search box and selecting the properbox to disable. Any suggestions on question 2?
    Thursday, September 2, 2010 3:56 AM
  • Hi,

    For question 2, I would like to confirm what kind of folders are they? Usually, this is because Windows system files are owned by the TrustedInstaller service by default, and Windows File Protection will keep them from being overwritten. To delete them, you need to grand yourself full control over the folder.

    Click Start, type CMD and press Ctrl+Shift+Enter key combination to open an administrator command prompt.

    To take ownership of the file, you’ll need to use the takeown command. Here’s an example:

    takeown /f C:\Windows\System32\Test.txt

    The folder Test.txt under C:\Windows\System32 is the one you want to delete.

    After taking ownership of the file, please run the cacls command to give yourself full control rights to the file:

    cacls C:\Windows\System32\Test.txt /G Magon:F

    Please note: Magon is my username, replace it with your username.

    After that, try deleting the folders. If still no go, in case any application is using them, please boot into Safe Mode and repeat the steps above.

    Good Luck.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, September 3, 2010 9:41 AM
    Moderator