"Unable to select TWAIN source" - Canon LIDE 25 scanner issue RRS feed

  • General discussion

  • Hi.  I had been running Windows 7 Ultimate RC, since July.  When I plugged in my scanner, it went and found the correct software (CanoScan Toolbox), and my scanner worked perfectly. 

    This weekend I installed Windows 7 Pro.  When I plugged in the same scanner...nothing happened.  So I installed the CanoScan toolbox, using the setup CD that came with the scanner.  I didn't think much of it.  Subsequently, I pushed a button on the scanner, and Windows Fax and Scan opened, and the scanner made a terrible noise.

    When I open the CanoScan toolbox, and try to scan, it says "unable to select TWAIN source."  I have tried the troubleshooter, downloaded the driver and the entire CanoScan program (for 64-bit Vista) from Canon's website, and tried many other fixes. 

    Any advice would be appreciated.

    • Changed type Andy Song Monday, September 21, 2009 4:03 AM duplicated thread
    Monday, September 21, 2009 1:40 AM

All replies

  • I managed to get it working.  I am not entirely sure what caused it to work, I kept trying different "Vista" downloads from Canon's website.

    Monday, September 21, 2009 3:21 AM
  • you could alternatively use the windows fax and scanner software that comes free with vista or win 7. start>all programes>windows fax and scan.
    Tuesday, October 13, 2009 9:13 PM