none
Help Hyper-V NIC missing!! RRS feed

  • Question

  • Hi

    We have a Server 2016 Host running Hyper-V. The host server has all of its available updates from MS Update and its running Hyper-V Manager Version 10.0.014393.0, The Host is a HP Proliant (ML350 I believe) and it has a HPE Ethernet 1Gb-4 Port 331i adapter.

    Within Hyper V we have 2 VM's - One is a Server 2012 running fine and shows its NIC card as Hyper V Virtual NIC - Running at 1Gbps so all good. however the 2nd VM which is a Small Business Server 2011 (fully updated) is now showing its Hyper-V NIC with a ! mark in device manager stating "The Device Cannot Start (Code 10) "

    I have tried to find the answer but cannot get a solution, Lots of people say to choose ACTION then INTEGRATED SERVICES from the Hyper-V menu when selecting connect but when I select Action that option is not available.

    I have checked and the Ethernet driver for the host (Server 2016) NIC is the latest version.

    I have rebooted the VM into safe mode / normal mode etc but nothing works.

    I have enabled a legacy NIC for now but this only runs at 100Mbps and given this server is managing Exchange 2010 for 30 client PC's its causing a problem - Outlook clients are freezing due to the NIC 100Mbps bottle neck.

    Please help!


    Monday, December 23, 2019 3:10 PM

All replies

  • Hello,

    What happens if you add another regular NIC? That should be detected by the SBS server and added automatically.

    What does the eventviewer say about the NIC that is causing issues? Do you have any error message for us?

    Regards,

    Niels

    Monday, December 23, 2019 4:21 PM
  • If I add another NIC via Hyper V settings I just get the same - another Hyper-V NIC that cannot start.

    Re event viewer where should it be stored? Sorry but not very good at this stuff just trying to figure it out as I go along - Our main IT chap is not around at the mo.

    Thanks

    Monday, December 23, 2019 5:56 PM
  • Hello

    Enter the RUN windows (windows key + R) and entervwr, this screen should pop up:

    Go to the system and check whether you can find anything about the Hyper V NIC.

    Regards,

    Niels

    Tuesday, December 24, 2019 8:07 AM
  • Nothing in Eventvwr system about Hyper-V NIC
    Friday, December 27, 2019 11:59 AM
  • Hello,

    What do you in devicemanagement? Are you able to install a driver for the NIC that is having problems?

    Regards,

    Niels

    Friday, December 27, 2019 4:26 PM
  • For Hyper-V questions, I'd recommend posting in teh Hyper-V forum, this one's for Virtual Server 2005. 

    https://social.technet.microsoft.com/Forums/en-US/home?forum=winserverhyperv&filter=alllanguages

    Did you install SBS2011 or is it a P2V?  The default NIC will work without any updates to the Integration components.  You don't need to use the legacy NIC.

    IC are updated through Windows Updates, so the Action/IC is for previous versions of Hyper-V.

    Monday, December 30, 2019 9:40 PM