none
site creation fail RRS feed

  • Question

  • Hi, everytime I create a new project, my project site fails to create.  Any ideas as to why?  This appears to only happen when I have saved my own custom template to be used for new project creations.

    Have I missed anything out here?  Do I need to remove the site name before saving as a template??

    Steve

    Thursday, May 2, 2013 1:59 PM

All replies

  • Hi,

    what error do you get in the queue? What did you change in the template?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, May 2, 2013 2:24 PM
    Moderator
  • Hi, the error message in the queue is pasted below. 

    I took an existing project site template and used that. I seem to remember that causes problems unless you use a default SharePoint Project Site.  I have now tried to create one of those but that won't even create at all let alone customise it and save it as a template..?

    • CreateWssSiteContent: Creating project site failed! Project Uid=a9e9bbfb-2cb3-e211-96dd-00155d8d7d0d, site URL=https://projectasia.sharepoint.com/sites/pwa/CBG001 - RMT Warrington, site name=CBG001 - RMT Warrington. System.Runtime.InteropServices.COMException (0x8107058A): <nativehr>0x8107058a</nativehr><nativestack></nativestack>Failed to activate feature _MBrowserRedirect_ (id: _d95c97f3-e528-4da2-ae9f-32b3535fbb59_). The feature is not a member of the associated site subscription feature pack. at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId)Microsoft.SharePoint.SPException: Failed to activate feature _MBrowserRedirect_ (id: _d95c97f3-e528-4da2-ae9f-32b3535fbb59_). The feature is not a member of the associated site subscription feature pack. ---> System.Runtime.InteropServices.COMException: <nativehr>0x8107058a</nativehr><nativestack></nativestack>Failed to activate feature _MBrowserRedirect_ (id: _d95c97f3-e528-4da2-ae9f-32b3535fbb59_). The feature is not a member of the associated site subscription feature pack. at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) --- End of inner exception stack trace --- at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, Int32 fIgnoreMissingFeatures, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.SPWeb.ProvisionWebTemplate(SPWebTemplate webTemplate, String webTemplateToUse, SPFeatureWebTemplate featureWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(SPWebTemplate webTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors) at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, Guid rootFolderId, Boolean createSystemCatalogs, Guid appInstanceId, String appWebDomainId) at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean useUniquePermissions, Boolean bConvertIfThere, Guid appInstanceId) at Microsoft.Office.Project.Server.BusinessLayer.AdminProjectSiteAllocator.CreateSPWeb(ProjectSiteConfigurationInfo configInfo, SPSite topSite):
        • WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='77422f6f-2db3-e211-b92b-00155d106205' projectUID='a9e9bbfb-2cb3-e211-96dd-00155d8d7d0d' workspaceUrl='https://projectasia.sharepoint.com/sites/pwa/CBG001 - RMT Warrington/CBG001 - RMT Warrington' projectWorkspaceName='CBG001 - RMT Warrington'.
    • Queue:
      • GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='78422f6f-2db3-e211-b92b-00155d106205' JobUID='4256a26a-2db3-e211-96dd-00155d8d7d0d' ComputerName='165a1fc6-0cf9-41ee-8900-03db3bf471ac' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage='' CorrelationUID='307a179c-01e4-209b-f18e-f13b23d94523'. For more details, check the ULS logs on machine 165a1fc6-0cf9-41ee-8900-03db3bf471ac for entries with JobUID 4256a26a-2db3-e211-96dd-00155d8d7d0d.
    Thursday, May 2, 2013 2:33 PM
  • Hi Stev, as you mention, you must create from a true Project Site created from the template - but it should ne be associated with any plan.  Not sure if it is that or something deeper - do you have features missing in som way.  Did the template come from the same farm?

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    • Proposed as answer by Kashif Nizam Friday, May 3, 2013 8:30 PM
    Thursday, May 2, 2013 9:03 PM
    Owner
  • Also this doesn't appear to be a Project Online question - so moving to another more appropriate forum.

    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Thursday, May 2, 2013 9:04 PM
    Owner
  • Steve,

    If you are using existing site associated with project plan, as Brian mentioned project plan has to be disassociated from the site before saving site as a template.

    Ideally you should create a new Project Site using New site option and select Microsoft Project Site template.

    Also as per the error message

    Failed to activate feature _MBrowserRedirect_ (id: _d95c97f3-e528-4da2-ae9f-32b3535fbb59_). The feature is not a member of the associated site subscription feature pack

    Site creation while activating specific feature. Is your  template source site based on Project template or different?

     


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    • Proposed as answer by Kashif Nizam Friday, May 3, 2013 8:30 PM
    Thursday, May 2, 2013 9:23 PM
    Moderator