none
Is My .NET Framework Broken/How Do I Fix It? RRS feed

  • Question

  • I recently acquired Age of Empires III and when I tried to launch the game from Steam, it told me that Windows could not complete the requested change, and when I tried to verify game cache, it kept telling me it was missing a file and would replace it, but it never work. So, from there, I looked into ways to fix it. One way was to enable DirectPlay. However, when I went to the Windows Feature window and hunted the "Legacy Components" folder, there was no way to expand the folder and select DirectPlay, implying pretty strongly that I don't have it at all. However, regardless of this, when I try to change anything on that window, Windows gives me the same error it did when I tried to launch Age of Empires. And, so, I tried to update my computer and it gives me an Error 1009 and says, just like the other two errors, that the configuration registry database is corrupt. When I troubleshoot the updates, it says it fix certain problems but can't with others and they're different issues and solutions each time I troubleshoot and I still can't download the updates. One of them is listed as a .NET Framework update which, when I search Google by the error codes and other pertinent info, I keep coming across that as a potential source for the issue I'm having with my computer.

    I just want to play this damn game. Any help?

    Tuesday, October 8, 2019 2:11 AM

All replies