locked
Index formatting problem after section break RRS feed

  • Question

  • I like the change to two columns for index entries, but am having a problem with section break to go from one column (regular page format) to 2 columns.

    At the end of word doc is the index.  The index begins with the index heading. After the index heading is a section break (presumably to change to 2 columns) but it also causes a page break, then on the next page starts the two column index entries. Is there a way I can modify the word template (section break?) so there is no page break after the Index heading? I need the section break after the heading, but i don't like the index heading as a widow on the previous page.

    After looking at the doc generated by the template, i have more info. There is an "odd page" section break before every heading 1 (which is fine). Index is heading 1 and that's okay. After the index heading is a "continuous" section break (presumably to set up 2 columns) --but why is it causing a page break? So as i mentioned, the index heading is at the top of a blank page and then the index entries start on the next page.


    • Edited by jeffam Friday, March 9, 2012 10:03 PM
    Friday, March 9, 2012 9:29 PM

Answers

  • I tried an experiment with the template and solved the problem, but i don't know why it solved the problem.

    here's what i did:

    1. opened the template
    2. at the bottom of the template i add a couple lines and created some text and an index marker so i could insert an index.
    3. added a couple more lines and selected "insert index" from references tab
    4. to setup the index, i changed the "formats" option from "from template" to "formal" and checked "right align" and "Tab leader" (that's the way i like my index format). Inserted the index.
    5. closed and saved the template
    6. generated my document using the template, and suddenly, there is a "odd page" section break before the index heading (as there should be) and there is now no section break after the index heading (good), and two column index entries begins right below the heading (good).

    problem solved.


    • Edited by jeffam Friday, March 9, 2012 11:27 PM
    • Marked as answer by William Zhou CHN Monday, March 19, 2012 2:44 AM
    Friday, March 9, 2012 11:26 PM

All replies

  • I tried an experiment with the template and solved the problem, but i don't know why it solved the problem.

    here's what i did:

    1. opened the template
    2. at the bottom of the template i add a couple lines and created some text and an index marker so i could insert an index.
    3. added a couple more lines and selected "insert index" from references tab
    4. to setup the index, i changed the "formats" option from "from template" to "formal" and checked "right align" and "Tab leader" (that's the way i like my index format). Inserted the index.
    5. closed and saved the template
    6. generated my document using the template, and suddenly, there is a "odd page" section break before the index heading (as there should be) and there is now no section break after the index heading (good), and two column index entries begins right below the heading (good).

    problem solved.


    • Edited by jeffam Friday, March 9, 2012 11:27 PM
    • Marked as answer by William Zhou CHN Monday, March 19, 2012 2:44 AM
    Friday, March 9, 2012 11:26 PM
  • Hi,
     
    I’m glad to hear that you resolve this issue.
    Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.
     

    Best Regards.


    William Zhou

    TechNet Community Support

    Monday, March 19, 2012 2:45 AM