locked
Cannot create a connection to data source RRS feed

  • Question

  • Hello,

    I have granted the content manager role to the user but he is getting the following error


    An error has occurred during report processing. (rsProcessingAborted)

     

    • Cannot create a connection to data source 'SUSData'. (rsErrorOpeningConnection)
      • For more information about this error navigate to the report server on the local server machine, or enable remote errors


        I have the same role on my pc but it is working fine on my pc but few users are getting this error. Any idea?
    Wednesday, December 30, 2009 2:06 PM

Answers

  • Try this
    Connection string
    Data Source=.;Initial Catalog=DWH

    Connect Using:
    Credentiasl stored securely in the report server
    User name: sa
    Password: abcd

    (don't check the options use as windows credentials when connecting to a datasource , impersonate the authenticated user after a connection...)

    • Marked as answer by MustafaH Tuesday, January 12, 2010 9:00 AM
    Tuesday, January 5, 2010 9:38 PM

All replies

  • Seems to be the new user doesn't have permissions on the datasource, being a content manager doesn't mean it will have permissions on the database from where the data is extracted.

    So verify the DataSource SUSData an check what kind of credentials is using (from your error I guess Windows Integrated if so you need to give permissions to your user directly in the database, or change the credentials to store in the report server and provide an user and password)
    • Proposed as answer by Jerry Nee Monday, January 4, 2010 7:18 AM
    Friday, January 1, 2010 1:01 AM
  • Hello Jamie,

    Thanks for your reply. I have tried with SQL Server credentials and embed the user name and password in connection string, it does work with my login because i am an administrator. I have installed with Mixed mode. But other users who does not have an account in database but have an account in Active Directory are unable to access the data getting the same error message.

    I am using this connection string but it is still not working for other users

    Data Source=.;Initial Catalog=DWH;Persist Security Info=True;User ID=sa;Password=abcd

    Any idea why?
    Monday, January 4, 2010 9:49 AM
  • Try this
    Connection string
    Data Source=.;Initial Catalog=DWH

    Connect Using:
    Credentiasl stored securely in the report server
    User name: sa
    Password: abcd

    (don't check the options use as windows credentials when connecting to a datasource , impersonate the authenticated user after a connection...)

    • Marked as answer by MustafaH Tuesday, January 12, 2010 9:00 AM
    Tuesday, January 5, 2010 9:38 PM
  • Thanks Jamie for your reply. I will try this and let you know.
    Thursday, January 7, 2010 1:43 PM
  • Thank you Jaime it is working now.
    Tuesday, January 12, 2010 9:01 AM
  • i have the exact same issue, however i am using a shared data source on a report server thus cannot use the custom connection.

    only the admin can view the reports, the rest get event 18456 and the above error message.

    i believe that  if i grant all my users read permissions in the sql db, they will be able to view the reports, but this seems just wrong.

    any help would be highly appreciated.

    Thursday, February 4, 2010 12:01 AM
  • Well actually giving read permissions or not is more a security model decision, so if you want to stick on the model where the users are totally isolated from the database you need to modify your shared datasource connection string to set in it the credentials.

    Think in this, there are two options to present the credentials to the databse the first one is allowing reporting only to forward the current user credentials , the consequence of this is that your users need access to the database.

    The second is making that reporting present the credentials, and to do this reporting need to store the credentials, the place to do it is the connection configuration for the datasource.
    Thursday, February 4, 2010 1:08 AM